Ok, so I don't think this is strictly a Ubuntu problem, probably more of an rTorrent problem, however it's only occurred since I moved my server over to Ubuntu. I have rTorrent set up to watch directories and auto-add torrents based on the location. Under my previous install of kFreeBSD this worked beautifully, however this just isn't happening now. Instead of downloading it to the specified directory, they end up in ./torrent_folder_name, which is invariably my home directory. I'll post my config so someone might be able to see something I can't:

Code:
schedule = watch_directory_2,10,10,"load_start=/mnt/tank/downloads/rtorrent/watch/distros/*.torrent,d.set_custom1=/mnt/tank/downloads/distros/"
Now I'm wondering if it's a permissions issue, I run rtorrent under my own user and I've chowned the directory as simon:simon (my user).

Can anyone shed any light on why this would be happening?



edit: not that I can see why it would make a difference, but the drive mounted at /mnt/tank is a zfspool