Results 1 to 10 of 13

Thread: 'x' key on keyboard activates xkill!

Hybrid View

  1. #1
    Join Date
    Jul 2011
    Beans
    19

    Question 'x' key on keyboard activates xkill!

    G'day.

    I have an unusual problem I can't find a solution to.

    I updated my other desktop computer this afternoon(12.04 32 bit plain-jane ubuntu) which has been running fine for months BTW..

    I continued working, surfing the web mainly, and some time later Firefox seemed to corrupt. I was trying to type a email message and misspelt 'next'; 'net'.

    I attempted to correct the spelling mistake and insert the 'x' pressed 'x' on the K/B, and next thing the tell-tale 'x' cursor of xkill appeared and was xkill was running! As soon as I clicked on the email (web-based) Firefox closed.

    Opened FF again home page appeared (google) typed an 'x' in the search box, same thing happened, xkill running clicked on page killed FF.

    Tried this again on the desktop, killed GNOME.

    Restarted computer, same thing again.

    Shutdown again deleted my K/B shortcut CNTRL-ALT-X for xkill, rebooted again, same thing again.

    This time shutdown, tried a new keyboard/mouse combo - same thing.

    Help please! This is weird!

    Thanks

    ~L.
    Last edited by lauribuntu; February 25th, 2013 at 09:18 AM. Reason: spelling

  2. #2
    Join Date
    May 2010
    Location
    Tewkesbury uk
    Beans
    7,916
    Distro
    Ubuntu Development Release

    Re: 'x' key on keyboard activates xkill!

    Hi

    Can you post the output of

    Code:
    ls -l /etc/dconf/profile/
    and

    Code:
    whoami
    Kind regards
    If you believe everything you read, you better not read. ~ Japanese Proverb

    If you don't read the newspaper, you're uninformed. If you read the newspaper, you're mis-informed. - Mark Twain

  3. #3
    Join Date
    Jul 2011
    Beans
    19

    Re: 'x' key on keyboard activates xkill!

    Quote Originally Posted by matt_symes View Post
    Hi

    Can you post the output of

    Code:
    ls -l /etc/dconf/profile/
    and

    Code:
    whoami
    Kind regards
    Sure thing Matt; as long as I don't type an 'x'!

    ls -l /etc/dconf/profile
    total 4
    -rw-r--r-- 1 root root 9 Sep 24 2011 gdm

    whoami
    lauricat

    thanks matt.

    ~L
    Last edited by lauribuntu; February 25th, 2013 at 09:52 AM. Reason: spell

  4. #4
    Join Date
    May 2010
    Location
    Tewkesbury uk
    Beans
    7,916
    Distro
    Ubuntu Development Release

    Re: 'x' key on keyboard activates xkill!

    Hi

    I'm wondering if the setting are in the dconf profile.

    Code:
    grep -R kill /etc/dconf/profile/*
    See if that returns anything.

    Kind regards
    If you believe everything you read, you better not read. ~ Japanese Proverb

    If you don't read the newspaper, you're uninformed. If you read the newspaper, you're mis-informed. - Mark Twain

  5. #5
    Join Date
    Jul 2011
    Beans
    19

    Re: 'x' key on keyboard activates xkill!

    Quote Originally Posted by matt_symes View Post
    Hi

    I'm wondering if the setting are in the dconf profile.

    Code:
    grep -R kill /etc/dconf/profile/*
    See if that returns anything.

    Kind regards
    G'day Matt.

    Tried that returned nothing back.

    Still the same problem.

    Thanks

    ~L.

  6. #6
    Join Date
    May 2010
    Location
    Tewkesbury uk
    Beans
    7,916
    Distro
    Ubuntu Development Release

    Re: 'x' key on keyboard activates xkill!

    Hi

    Let's make 100% sure of the dconf setting

    Code:
    sudo mv /etc/dconf/profile{,.old}
    Code:
    sudo reboot
    How does that work ? It can always be reverted.

    Kind regards
    If you believe everything you read, you better not read. ~ Japanese Proverb

    If you don't read the newspaper, you're uninformed. If you read the newspaper, you're mis-informed. - Mark Twain

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •