Results 1 to 1 of 1

Thread: libgl error, unity and compiz not starting

Hybrid View

  1. #1
    Join Date
    May 2012
    Beans
    10

    libgl error, unity and compiz not starting

    Recently, on startup, my unity and comiz have stopped working. Also, I'm seeing a lot of this error:

    Code:
    [vj]:~$ LIBGL_DEBUG=verbose /usr/lib/nux/unity_support_test -p
    libGL: screen 0 does not appear to be DRI2 capable
    libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/tls/swrast_dri.so
    libGL: OpenDriver: trying /usr/lib/i386-linux-gnu/dri/swrast_dri.so
    libGL error: dlopen /usr/lib/i386-linux-gnu/dri/swrast_dri.so failed (/usr/lib/i386-linux-gnu/dri/swrast_dri.so: wrong ELF class: ELFCLASS32)
    libGL: OpenDriver: trying /usr/lib/x86_64-linux-gnu/dri/tls/swrast_dri.so
    libGL: OpenDriver: trying /usr/lib/x86_64-linux-gnu/dri/swrast_dri.so
    libGL error: failed to load driver: swrast
    Can anyone please tell me cause of this problem and how to fix it? Thanks in advance.


    Ubuntu Version: 12.10 64-bit
    Graphics Adapter: AMD nee ATI Madison [Radeon HD 5000M series]
    Last edited by vj41; February 24th, 2013 at 07:42 PM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •