Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 41

Thread: Radeon 4500 series VESA: M92

  1. #11
    Join Date
    Feb 2013
    Beans
    16

    Re: Radeon 4500 series VESA: M92

    nicolas@nicolas-HP-Pavilion-dv6-Notebook-PC:~$ lspci -k | grep VGA -A2
    01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RV710 [Mobility Radeon HD 4500/5100 Series]
    Subsystem: Hewlett-Packard Company Device 3628
    Kernel driver in use: fglrx_pci

  2. #12
    Join Date
    Jul 2008
    Location
    The Left Coast of the USA
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: Radeon 4500 series VESA: M92

    Quote Originally Posted by Pilot6 View Post
    That is not completely true. It is possible to use fglrx-legacy with 12.04.2. But you need to install xserver-xorg instead of xserver-xorg-lts-quantal. And use patched driver for 3.5 kernel or use 3.2.
    A bit of a tall order for someone just trying to figure out how to install the driver, eh?

    Let me step in for a moment so we can start fresh...

    Let's get you back to the default open source Radeon driver. Trying to install both could make moving on difficult.

    Just to be sure we have cleared out the attempted install from the AMD website:

    Code:
    sudo sh /usr/share/ati/fglrx-uninstall.sh
    This may fail. Don't worry about it if it does.

    Remove what was installed from the repo:

    Code:
    sudo apt-get purge fglrx fglrx-amdcccle
    Code:
    sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.bak2
    Then:

    Code:
    sudo apt-get install --reinstall libgl1-mesa-glx libgl1-mesa-dri  xserver-xorg-core
    Code:
    sudo dpkg-reconfigure  xserver-xorg
    Reboot. You should now be on the default open source Radeon driver.

  3. #13
    Join Date
    Dec 2011
    Beans
    170

    Re: Radeon 4500 series VESA: M92

    I could give already patched debs.

    The driver looks to be installed.

    Then one more command
    dpkg --list | grep fglrx*

  4. #14
    Join Date
    Feb 2013
    Beans
    16

    Re: Radeon 4500 series VESA: M92

    Quote Originally Posted by Temüjin View Post
    You did both? Sigh...
    lol first i installed the driver from amd. then i checked the additional drivers and it notified me about the fglrx so i installed it too.
    this is my first week with linux so excuse if i did something stupid
    should i remove one of them?

  5. #15
    Join Date
    Feb 2013
    Beans
    16

    Re: Radeon 4500 series VESA: M92

    Quote Originally Posted by Pilot6 View Post
    I could give already patched debs.

    The driver looks to be installed.

    Then one more command
    dpkg --list | grep fglrx*
    nicolas@nicolas-HP-Pavilion-dv6-Notebook-PC:~$ dpkg --list | grep fglrx*
    ii fglrx 2:8.960-0ubuntu1.1 Video driver for the AMD graphics accelerators
    ii fglrx-amdcccle 2:8.960-0ubuntu1.1 Catalyst Control Center for the AMD graphics accelerators

  6. #16
    Join Date
    Dec 2011
    Beans
    170

    Re: Radeon 4500 series VESA: M92

    I am confused by model of the chip HD 4500/5100 Series.

    For 4xxx you need legacy, for 5xxx you need normal driver.

  7. #17
    Join Date
    Feb 2013
    Beans
    16

    Re: Radeon 4500 series VESA: M92

    ok so i'm gonna try QIII solution and check out the result

  8. #18
    Join Date
    Dec 2011
    Beans
    170

    Re: Radeon 4500 series VESA: M92

    I think the problem is that you need legacy.

    So remove the driver

    sudo apt-get purge fglrx*

    Then download the driver frome here.
    https://www.dropbox.com/sh/aw6oth9799n43hh/jawiIddfZm

    You need only 2 files with i386 at the end. These are latest legacy drivers. It is easier that to build them yourself.

    Create a folder in your home folder and call it AMD. Put there these 2 files.

    Then in terminal run commands

    cd AMD
    sudo dpkg -i *.deb

    Then reboot.

  9. #19
    Join Date
    Dec 2011
    Beans
    170

    Re: Radeon 4500 series VESA: M92

    QIII is the right solution to remove the driver and use opesource one. Then you can install propritary. It must solve the problem.

    Note: Driver I suggest can be used for kernel 3.5 as well.

  10. #20
    Join Date
    Jul 2008
    Location
    The Left Coast of the USA
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: Radeon 4500 series VESA: M92

    Quote Originally Posted by Pilot6 View Post
    I am confused by model of the chip HD 4500/5100 Series.

    For 4xxx you need legacy, for 5xxx you need normal driver.
    Quirk in how ATI describes the Mobility line. It's actually an overclocked 4000 series.

    Also, again, the 12.4 driver is the one available in the Precise repo. There is no need to do anything fancy. The legacy driver is just 12.6 anyway.

Page 2 of 5 FirstFirst 1234 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •