Results 1 to 10 of 14

Thread: Dependency Problem

Hybrid View

  1. #1
    Join Date
    Jul 2012
    Beans
    15

    Dependency Problem

    Hey guys,
    Running into a problem here and as always looking for some support from you guys.
    I have a dependency problem and it won't let me install any new programs.
    I had reinstalled Ubuntu on the same partition few days back because of some serious problems.And ran Deja vu Backup after re-installation that restored data of the non installed programs too.
    So while running sudo apt-get install -f
    I get the following errors.
    Code:
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Correcting dependencies... Done
    The following extra packages will be installed:
      gstreamer0.10-plugins-ugly libaccess-bridge-java libmjpegtools-1.9 libzbar0
    The following packages will be upgraded:
      gstreamer0.10-plugins-ugly libaccess-bridge-java libmjpegtools-1.9 libzbar0
    4 upgraded, 0 newly installed, 0 to remove and 86 not upgraded.
    7 not fully installed or removed.
    Need to get 0 B/1,095 kB of archives.
    After this operation, 249 kB disk space will be freed.
    Do you want to continue [Y/n]? y
    dpkg: dependency problems prevent configuration of libmjpegtools-1.9:
     libmjpegtools-1.9 depends on libjpeg62 (>= 6b1); however:
      Package libjpeg62 is not installed.
    dpkg: error processing libmjpegtools-1.9 (--configure):
     dependency problems - leaving unconfigured
    No apport report written because the error message indicates its a followup error from a previous failure.
                              dpkg: dependency problems prevent configuration of gstreamer0.10-plugins-bad-multiverse:
     gstreamer0.10-plugins-bad-multiverse depends on libmjpegtools-1.9 (>= 1:1.9.0); however:
      Package libmjpegtools-1.9 is not configured yet.
    dpkg: error processing gstreamer0.10-plugins-bad-multiverse (--configure):
     dependency problems - leaving unconfigured
    No apport report written because the error message indicates its a followup error from a previous failure.
                              dpkg: dependency problems prevent configuration of gstreamer0.10-plugins-ugly:
     gstreamer0.10-plugins-ugly depends on libcdio10; however:
      Package libcdio10 is not installed.
    dpkg: error processing gstreamer0.10-plugins-ugly (--configure):
     dependency problems - leaving unconfigured
    No apport report written because MaxReports is reached already
                                                                  dpkg: dependency problems prevent configuration of libaccess-bridge-java:
     libaccess-bridge-java depends on default-jre | openjdk-6-jre | sun-java6-jre; however:
      Package default-jre is not installed.
      Package openjdk-6-jre is not installed.
      Package sun-java6-jre is not installed.
    dpkg: error processing libaccess-bridge-java (--configure):
     dependency problems - leaving unconfigured
    No apport report written because MaxReports is reached already
                                                                  dpkg: dependency problems prevent configuration of libaccess-bridge-java-jni:
     libaccess-bridge-java-jni depends on libaccess-bridge-java (>= 1.26.2-6); however:
      Package libaccess-bridge-java is not configured yet.
    dpkg: error processing libaccess-bridge-java-jni (--configure):
     dependency problems - leaving unconfigured
    No apport report written because MaxReports is reached already
                                                                  dpkg: dependency problems prevent configuration of libzbar0:
     libzbar0 depends on libjpeg62 (>= 6b1); however:
      Package libjpeg62 is not installed.
    dpkg: error processing libzbar0 (--configure):
     dependency problems - leaving unconfigured
    No apport report written because MaxReports is reached already
                                                                  dpkg: dependency problems prevent configuration of gstreamer0.10-plugins-bad:
     gstreamer0.10-plugins-bad depends on libzbar0 (>= 0.10); however:
      Package libzbar0 is not configured yet.
    dpkg: error processing gstreamer0.10-plugins-bad (--configure):
     dependency problems - leaving unconfigured
    No apport report written because MaxReports is reached already
                                                                  Errors were encountered while processing:
     libmjpegtools-1.9
     gstreamer0.10-plugins-bad-multiverse
     gstreamer0.10-plugins-ugly
     libaccess-bridge-java
     libaccess-bridge-java-jni
     libzbar0
     gstreamer0.10-plugins-bad
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    To make it short:
    "Errors were encountered while processing:
    libmjpegtools-1.9
    gstreamer0.10-plugins-bad-multiverse
    gstreamer0.10-plugins-ugly
    libaccess-bridge-java
    libaccess-bridge-java-jni
    libzbar0
    gstreamer0.10-plugins-bad
    E: Sub-process /usr/bin/dpkg returned an error code (1)"

    Done a lot of searching.
    May be you guys can help.

  2. #2
    Join Date
    Mar 2007
    Beans
    301
    Distro
    Ubuntu 6.10 Edgy

    Re: Dependency Problem

    Do you have any unofficial source in your sources.list?

  3. #3
    Join Date
    Jul 2012
    Beans
    15

    Re: Dependency Problem

    No,I haven't added any sources as of now.

  4. #4
    Join Date
    Feb 2013
    Beans
    Hidden!

    Re: Dependency Problem

    Try
    Code:
    sudo apt-get dist-upgrade

  5. #5
    Join Date
    Jul 2012
    Beans
    15

    Re: Dependency Problem

    Nah.
    That didn't help.Still same error.

  6. #6
    Join Date
    Oct 2011
    Location
    ZZ9 Plural Z Alpha
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Dependency Problem

    Try

    Code:
    sudo dpkg --configure -a

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •