Page 1 of 4 123 ... LastLast
Results 1 to 10 of 33

Thread: Nvidia X Driver Fails to Install

  1. #1
    Join Date
    Feb 2013
    Beans
    42

    Nvidia X Driver Fails to Install

    My laptop is the Acer Timeline Ultra M5-481TG. It has an Nvidia Geforce GT 640M LE gpu. I am running Ubuntu Studio 12.10.
    I have tried to install this driver many ways because Nouveau eats my battery and I believe is somewhat out of date. I have even tried using 'sudo stop lightdm' in another console. I have tried nvidia_current, nvidia_current_updates, nvidia_experimental_310, and the .run file off their website. Every time I open nvidia-settings it tells me to run the 'nvidia-xconfig' as root then restart X. I tried this both in X and with X stopped in an alternate console. I have also installed bumblebee and that did nothing to get the Nvidia X Driver Running. I installed jockey common as well and enabled these drivers using it, but again to no avail. When I run 'nvidia-xconfig' it does create the necessary changes to the config file, but these don't result in it actually running or resolving the error. I have read very many articles and tried so many things. i.e. 'sudo apt-add-repository ppaorg-edgers/ppa' and of course apt's update, upgrade, and dist-upgrade. I have purged and reinstalled everything in numerous ways looking for just the right combination--no luck thus far.
    This has eaten hours of my time! Please help and thanks!
    Edit: sudo apt-get remove nvidia-common nvidia-current nvidia-settings && sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade && sudo apt-get install nvidia-common nvidia-current nvidia-settings && sudo jockey-text -e kmod:nvidia_current && sudo nvidia-xconfig && sudo restart lightdm
    I made a "meta"-command for lulz and to give it one last shot--still no luck.

  2. #2
    Join Date
    Jun 2007
    Beans
    11,172

    Re: Nvidia X Driver Fails to Install

    Remove any proprietary nvidia driver you tried to install and then:
    https://wiki.ubuntu.com/Bumblebee

  3. #3
    Join Date
    Feb 2013
    Beans
    42

    Re: Nvidia X Driver Fails to Install

    I removed nvidia-current, nvidia-common, and nvidia-settings with the synaptic package manager then followed the bumblebee instructions step by step. These instructions ended up asking me to reinstall so I did at the appropriate time. After a reboot nothing changed and my resolution is still horribly dystopic.

    So I tried a couple other things. Bumblebee makes it impossible to run nvidia-xconfig; when run it displays an error saying package is not found even though nvidia-settings says to run it as root still. I still cannot find it in additional drivers and sudo jockey-text -e kmod:nvidia_current said driver could not be installed. I also edited the xorg file related to bumblebee and pointed it to the nvidia driver instead of nouveau, although maybe I did this step wrong. I tried to follow the directions that came up in the terminal window during step 1 of Bumblebee's Ubuntu installation instructions. All the code I thought I needed was already there. I just put octothorpes before the nouveau related stuff and removed them before the nvidia related stuff.

  4. #4
    Join Date
    Feb 2013
    Beans
    42

    Re: Nvidia X Driver Fails to Install

    According to this log, it seems the nvidia driver is not recognizing my gpu. When i run an lspci it comes up as 01:00.0 VGA compatible controller: NVIDIA Corporation Device 0fd3 (rev ff).

    nvidia-installer log file '/var/log/nvidia-installer.log'
    creation time: Fri Feb 22 19:11:41 2013
    installer version: 310.32

    PATH: /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin

    nvidia-installer command line:
    ./nvidia-installer

    Using: nvidia-installer ncurses user interface
    WARNING: You do not appear to have an NVIDIA GPU supported by the 310.32 NVIDIA Linux graphics driver installed in this system. For further details, please see the appendix SUPPORTED NVIDIA GRAPHICS CHIPS in the README available on the Linux driver download page at www.nvidia.com.
    -> License accepted.
    -> Installing NVIDIA driver version 310.32.
    -> There appears to already be a driver installed on your system (version: 310.32). As part of installing this driver (version: 310.32), the existing driver will be uninstalled. Are you sure you want to continue? ('no' will abort installation) (Answer: Yes)
    -> Running distribution scripts
    executing: '/usr/lib/nvidia/pre-install'...
    -> done.
    -> The distribution-provided pre-install script failed! Continue installation anyway? (Answer: Yes)
    -> Would you like to register the kernel module sources with DKMS? This will allow DKMS to automatically build a new module, if you install a different kernel later. (Answer: Yes)
    -> Installing both new and classic TLS OpenGL libraries.
    -> Installing both new and classic TLS 32bit OpenGL libraries.
    -> Install NVIDIA's 32-bit compatibility OpenGL libraries? (Answer: Yes)
    -> Parsing log file:
    -> done.
    -> Validating previous installation:
    -> Unable to access previously installed file '/usr/lib/xorg/modules/drivers/nvidia_drv.so' (No such file or directory).
    -> Unable to access previously installed file '/usr/bin/nvidia-smi' (No such file or directory).
    -> Unable to access previously installed file '/usr/share/man/man1/nvidia-smi.1.gz' (No such file or directory).
    -> Unable to access previously installed file '/usr/bin/nvidia-xconfig' (No such file or directory).
    -> Unable to access previously installed file '/usr/share/man/man1/nvidia-xconfig.1.gz' (No such file or directory).
    -> Unable to access previously installed file '/usr/bin/nvidia-settings' (No such file or directory).
    -> Unable to access previously installed file '/usr/share/man/man1/nvidia-settings.1.gz' (No such file or directory).
    -> Unable to access previously installed file '/usr/bin/nvidia-bug-report.sh' (No such file or directory).
    -> Unable to access previously installed file '/etc/OpenCL/vendors/nvidia.icd' (No such file or directory).
    -> Unable to access previously installed symlink '/usr/lib/libOpenCL.so' (No such file or directory).
    -> Unable to access previously installed symlink '/usr/lib/vdpau/libvdpau_nvidia.so.1' (No such file or directory).
    -> Unable to access previously installed symlink '/usr/lib/libvdpau_nvidia.so' (No such file or directory).
    -> Unable to access previously installed symlink '/usr/lib32/libOpenCL.so' (No such file or directory).
    -> Unable to access previously installed symlink '/usr/lib32/libvdpau_nvidia.so' (No such file or directory).
    -> Unable to access previously installed symlink '/usr/lib32/vdpau/libvdpau_nvidia.so.1' (No such file or directory).
    -> done.
    WARNING: Your driver installation has been altered since it was initially installed; this may happen, for example, if you have since installed the NVIDIA driver through a mechanism other than nvidia-installer (such as your distribution's native package management system). nvidia-installer will attempt to uninstall as best it can. Please see the file '/var/log/nvidia-installer.log' for details.
    -> Uninstalling NVIDIA Accelerated Graphics Driver for Linux-x86_64 (1.0-31032 (310.32)):
    WARNING: Failed to delete the directory '/usr/share/doc/NVIDIA_GLX-1.0' (Directory not empty).
    WARNING: Failed to delete the directory '/etc/OpenCL/vendors' (No such file or directory).
    WARNING: Failed to delete the directory '/etc/OpenCL' (No such file or directory).
    WARNING: Failed to delete the directory '/usr/lib32' (Directory not empty).
    -> Unable to delete directories created by previous installation.
    -> done.
    -> Uninstallation of existing driver: NVIDIA Accelerated Graphics Driver for Linux-x86_64 (310.32) is complete.
    -> Searching for conflicting X files:
    -> done.
    -> Searching for conflicting OpenGL files:
    -> done.
    -> Installing 'NVIDIA Accelerated Graphics Driver for Linux-x86_64' (310.32):
    executing: '/sbin/ldconfig'...
    executing: '/sbin/depmod -aq'...
    -> done.
    -> Driver file installation is complete.
    -> Installing DKMS kernel module:
    -> done.
    -> Running post-install sanity check:
    -> done.
    -> Post-install sanity check passed.
    -> Shared memory test passed.
    -> Running runtime sanity check:
    -> done.
    -> Runtime sanity check passed.
    -> Would you like to run the nvidia-xconfig utility to automatically update your X configuration file so that the NVIDIA X driver will be used when you restart X? Any pre-existing X configuration file will be backed up. (Answer: Yes)
    -> Your X configuration file has been successfully updated. Installation of the NVIDIA Accelerated Graphics Driver for Linux-x86_64 (version: 310.32) is now complete.

  5. #5
    Join Date
    Feb 2013
    Beans
    42

    Re: Nvidia X Driver Fails to Install

    I ctrl f'd my Xorg.0.log and this is all I found:

    [ 22.237] (II) LoadModule: "nvidia-current"
    [ 22.238] (WW) Warning, couldn't open module nvidia-current
    [ 22.238] (II) UnloadModule: "nvidia-current"
    [ 22.238] (II) Unloading nvidia-current
    [ 22.238] (EE) Failed to load module "nvidia-current" (module does not exist, 0)

  6. #6
    Join Date
    Feb 2013
    Beans
    42

    Re: Nvidia X Driver Fails to Install

    My Xorg.8.log has a lot more related information so I will post the whole thing

    Code:
    [   488.245] 
    X.Org X Server 1.13.0
    Release Date: 2012-09-05
    [   488.245] X Protocol Version 11, Revision 0
    [   488.245] Build Operating System: Linux 3.2.0-32-generic x86_64 Ubuntu
    [   488.245] Current Operating System: Linux noah-Aspire-M5-481TG 3.5.0-25-lowlatency #24-Ubuntu SMP PREEMPT Wed Feb 20 23:44:07 UTC 2013 x86_64
    [   488.245] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.5.0-25-lowlatency root=UUID=9182da1e-3bba-4d4a-9643-e145e36cb54b ro quiet splash
    [   488.245] Build Date: 27 November 2012  07:44:35AM
    [   488.245] xorg-server 2:1.13.0-0ubuntu6.1 (For technical support please see http://www.ubuntu.com/support) 
    [   488.245] Current version of pixman: 0.26.0
    [   488.245]     Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
    [   488.245] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    [   488.245] (==) Log file: "/var/log/Xorg.8.log", Time: Fri Feb 22 19:03:25 2013
    [   488.245] (++) Using config file: "/etc/bumblebee/xorg.conf.nvidia"
    [   488.245] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
    [   488.269] (==) ServerLayout "Layout0"
    [   488.269] (==) No screen section available. Using defaults.
    [   488.269] (**) |-->Screen "Default Screen Section" (0)
    [   488.269] (**) |   |-->Monitor "<default monitor>"
    [   488.269] (==) No device specified for screen "Default Screen Section".
        Using the first device section listed.
    [   488.269] (**) |   |-->Device "Device1"
    [   488.269] (==) No monitor specified for screen "Default Screen Section".
        Using a default monitor configuration.
    [   488.269] (**) Option "AutoAddDevices" "false"
    [   488.269] (**) Not automatically adding devices
    [   488.269] (==) Automatically enabling devices
    [   488.269] (==) Automatically adding GPU devices
    [   488.270] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
    [   488.270]     Entry deleted from font path.
    [   488.270] (WW) The directory "/usr/share/fonts/X11/100dpi/" does not exist.
    [   488.270]     Entry deleted from font path.
    [   488.270] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
    [   488.270]     Entry deleted from font path.
    [   488.270] (WW) The directory "/usr/share/fonts/X11/100dpi" does not exist.
    [   488.270]     Entry deleted from font path.
    [   488.270] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
    [   488.270]     Entry deleted from font path.
    [   488.270] (WW) The directory "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType" does not exist.
    [   488.270]     Entry deleted from font path.
    [   488.270] (==) FontPath set to:
        /usr/share/fonts/X11/misc,
        /usr/share/fonts/X11/Type1,
        built-ins
    [   488.270] (++) ModulePath set to "/usr/lib/nvidia-current/xorg,/usr/lib/xorg/modules"
    [   488.270] (==) |-->Input Device "<default pointer>"
    [   488.270] (==) |-->Input Device "<default keyboard>"
    [   488.270] (==) The core pointer device wasn't specified explicitly in the layout.
        Using the default mouse configuration.
    [   488.270] (==) The core keyboard device wasn't specified explicitly in the layout.
        Using the default keyboard configuration.
    [   488.270] (II) Loader magic: 0x7f9036cbbc40
    [   488.270] (II) Module ABI versions:
    [   488.270]     X.Org ANSI C Emulation: 0.4
    [   488.270]     X.Org Video Driver: 13.0
    [   488.270]     X.Org XInput driver : 18.0
    [   488.270]     X.Org Server Extension : 7.0
    [   488.271] (II) config/udev: Adding drm device (/dev/dri/card0)
    [   488.271] setversion 1.4 failed
    [   488.273] (--) PCI:*(0:1:0:0) 10de:0fd3:1025:0713 rev 161, Mem @ 0xd2000000/16777216, 0xa0000000/268435456, 0xb0000000/33554432, I/O @ 0x00003000/128, BIOS @ 0x????????/524288
    [   488.273] (II) Open ACPI successful (/var/run/acpid.socket)
    [   488.273] Initializing built-in extension Generic Event Extension
    [   488.273] Initializing built-in extension SHAPE
    [   488.273] Initializing built-in extension MIT-SHM
    [   488.273] Initializing built-in extension XInputExtension
    [   488.273] Initializing built-in extension XTEST
    [   488.273] Initializing built-in extension BIG-REQUESTS
    [   488.273] Initializing built-in extension SYNC
    [   488.273] Initializing built-in extension XKEYBOARD
    [   488.273] Initializing built-in extension XC-MISC
    [   488.273] Initializing built-in extension SECURITY
    [   488.273] Initializing built-in extension XINERAMA
    [   488.273] Initializing built-in extension XFIXES
    [   488.273] Initializing built-in extension RENDER
    [   488.274] Initializing built-in extension RANDR
    [   488.274] Initializing built-in extension COMPOSITE
    [   488.274] Initializing built-in extension DAMAGE
    [   488.274] Initializing built-in extension MIT-SCREEN-SAVER
    [   488.274] Initializing built-in extension DOUBLE-BUFFER
    [   488.274] Initializing built-in extension RECORD
    [   488.274] Initializing built-in extension DPMS
    [   488.274] Initializing built-in extension X-Resource
    [   488.274] Initializing built-in extension XVideo
    [   488.274] Initializing built-in extension XVideo-MotionCompensation
    [   488.274] Initializing built-in extension XFree86-VidModeExtension
    [   488.274] Initializing built-in extension XFree86-DGA
    [   488.274] Initializing built-in extension XFree86-DRI
    [   488.274] Initializing built-in extension DRI2
    [   488.274] (II) LoadModule: "glx"
    [   488.274] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
    [   488.285] (II) Module glx: vendor="NVIDIA Corporation"
    [   488.285]     compiled for 4.0.2, module version = 1.0.0
    [   488.285]     Module class: X.Org Server Extension
    [   488.285] (II) NVIDIA GLX Module  310.32  Mon Jan 14 15:02:04 PST 2013
    [   488.285] Loading extension GLX
    [   488.285] (II) LoadModule: "nvidia"
    [   488.285] (WW) Warning, couldn't open module nvidia
    [   488.285] (II) UnloadModule: "nvidia"
    [   488.285] (II) Unloading nvidia
    [   488.285] (EE) Failed to load module "nvidia" (module does not exist, 0)
    [   488.285] (==) Matched nvidia as autoconfigured driver 0
    [   488.285] (==) Matched nouveau as autoconfigured driver 1
    [   488.285] (==) Matched nv as autoconfigured driver 2
    [   488.285] (==) Matched vesa as autoconfigured driver 3
    [   488.285] (==) Matched modesetting as autoconfigured driver 4
    [   488.285] (==) Matched fbdev as autoconfigured driver 5
    [   488.285] (==) Assigned the driver to the xf86ConfigLayout
    [   488.285] (II) LoadModule: "nvidia"
    [   488.286] (WW) Warning, couldn't open module nvidia
    [   488.286] (II) UnloadModule: "nvidia"
    [   488.286] (II) Unloading nvidia
    [   488.286] (EE) Failed to load module "nvidia" (module does not exist, 0)
    [   488.286] (II) LoadModule: "nouveau"
    [   488.286] (WW) Warning, couldn't open module nouveau
    [   488.286] (II) UnloadModule: "nouveau"
    [   488.286] (II) Unloading nouveau
    [   488.286] (EE) Failed to load module "nouveau" (module does not exist, 0)
    [   488.286] (II) LoadModule: "nv"
    [   488.286] (WW) Warning, couldn't open module nv
    [   488.286] (II) UnloadModule: "nv"
    [   488.286] (II) Unloading nv
    [   488.286] (EE) Failed to load module "nv" (module does not exist, 0)
    [   488.286] (II) LoadModule: "vesa"
    [   488.287] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
    [   488.287] (II) Module vesa: vendor="X.Org Foundation"
    [   488.287]     compiled for 1.12.99.902, module version = 2.3.2
    [   488.287]     Module class: X.Org Video Driver
    [   488.287]     ABI class: X.Org Video Driver, version 13.0
    [   488.287] (II) LoadModule: "modesetting"
    [   488.287] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
    [   488.287] (II) Module modesetting: vendor="X.Org Foundation"
    [   488.287]     compiled for 1.13.0, module version = 0.5.0
    [   488.287]     Module class: X.Org Video Driver
    [   488.287]     ABI class: X.Org Video Driver, version 13.0
    [   488.287] (II) LoadModule: "fbdev"
    [   488.287] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
    [   488.287] (II) Module fbdev: vendor="X.Org Foundation"
    [   488.287]     compiled for 1.12.99.902, module version = 0.4.3
    [   488.287]     Module class: X.Org Video Driver
    [   488.287]     ABI class: X.Org Video Driver, version 13.0
    [   488.287] (II) LoadModule: "mouse"
    [   488.287] (II) Loading /usr/lib/xorg/modules/input/mouse_drv.so
    [   488.295] (II) Module mouse: vendor="X.Org Foundation"
    [   488.295]     compiled for 1.12.99.902, module version = 1.7.2
    [   488.295]     Module class: X.Org XInput Driver
    [   488.295]     ABI class: X.Org XInput driver, version 18.0
    [   488.295] (II) LoadModule: "kbd"
    [   488.296] (WW) Warning, couldn't open module kbd
    [   488.296] (II) UnloadModule: "kbd"
    [   488.296] (II) Unloading kbd
    [   488.296] (EE) Failed to load module "kbd" (module does not exist, 0)
    [   488.296] (II) VESA: driver for VESA chipsets: vesa
    [   488.296] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
    [   488.296] (II) FBDEV: driver for framebuffer: fbdev
    [   488.296] (--) using VT number 7
    
    [   488.297] vesa: Ignoring device with a bound kernel driver
    [   488.297] (WW) Falling back to old probe method for vesa
    [   488.297] (WW) Falling back to old probe method for modesetting
    [   488.297] (II) modesetting(2): using default device
    [   488.297] (II) Loading sub module "fbdevhw"
    [   488.297] (II) LoadModule: "fbdevhw"
    [   488.297] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
    [   488.297] (II) Module fbdevhw: vendor="X.Org Foundation"
    [   488.297]     compiled for 1.13.0, module version = 0.0.2
    [   488.297]     ABI class: X.Org Video Driver, version 13.0
    [   488.298] (**) FBDEV(3): claimed PCI slot 1@0:0:0
    [   488.298] (II) FBDEV(3): using default device
    [   488.298] (EE) Screen 0 deleted because of no matching config section.
    [   488.298] (II) UnloadModule: "vesa"
    [   488.298] (EE) Screen 0 deleted because of no matching config section.
    [   488.298] (II) UnloadModule: "modesetting"
    [   488.298] 
    Fatal server error:
    [   488.298] Cannot run in framebuffer mode. Please specify busIDs        for all framebuffer devices
    [   488.298] 
    [   488.298] (EE) 
    Please consult the The X.Org Foundation support 
         at http://wiki.x.org
     for help. 
    [   488.298] (EE) Please also check the log file at "/var/log/Xorg.8.log" for additional information.
    [   488.298] (EE) 
    [   488.298] Server terminated with error (1). Closing log file.
    Last edited by howefield; February 23rd, 2013 at 08:19 PM. Reason: added code tags.

  7. #7
    Join Date
    Oct 2006
    Location
    Ayrshire
    Beans
    40,291
    Distro
    Ubuntu Development Release

    Re: Nvidia X Driver Fails to Install

    Check that you have the kernel headers installed...

    Code:
    uname -a
    to get the kernel version that you are using.

    Then install the kernel headers matching that kernel.

    You may need to do this every time you update the kernel.

  8. #8
    Join Date
    Feb 2013
    Beans
    42

    Re: Nvidia X Driver Fails to Install

    Here is my bumblebee.conf and the xorg.nvidia.conf that is in my /etc/bumblebee not my /etc/X11 folder.

    # Configuration file for Bumblebee. Values should **not** be put between quotes

    ## Server options. Any change made in this section will need a server restart
    # to take effect.
    [bumblebeed]
    # The secondary Xorg server DISPLAY number
    VirtualDisplay=:8
    # Should the unused Xorg server be kept running? Set this to true if waiting
    # for X to be ready is too long and don't need power management at all.
    KeepUnusedXServer=false
    # The name of the Bumbleblee server group name (GID name)
    ServerGroup=bumblebee
    # Card power state at exit. Set to false if the card shoud be ON when Bumblebee
    # server exits.
    TurnCardOffAtExit=false
    # The default behavior of '-f' option on optirun. If set to "true", '-f' will
    # be ignored.
    NoEcoModeOverride=false
    # The Driver used by Bumblebee server. If this value is not set (or empty),
    # auto-detection is performed. The available drivers are nvidia and nouveau
    # (See also the driver-specific sections below)
    Driver=nvidia-current

    ## Client options. Will take effect on the next optirun executed.
    [optirun]
    # The method used for VirtualGL to transport frames between X servers.
    # Possible values are proxy, jpeg, rgb, xv and yuv.
    VGLTransport=proxy
    # Should the program run under optirun even if Bumblebee server or nvidia card
    # is not available?
    AllowFallbackToIGC=false


    # Driver-specific settings are grouped under [driver-NAME]. The sections are
    # parsed if the Driver setting in [bumblebeed] is set to NAME (or if auto-
    # detection resolves to NAME).
    # PMMethod: method to use for saving power by disabling the nvidia card, valid
    # values are: auto - automatically detect which PM method to use
    # bbswitch - new in BB 3, recommended if available
    # switcheroo - vga_switcheroo method, use at your own risk
    # none - disable PM completely
    # https://github.com/Bumblebee-Project...-of-PM-methods

    Section with nvidia driver specific options, only parsed if Driver=nvidia
    [driver-nvidia]
    Module name to load, defaults to Driver if empty or unset
    KernelDriver=nvidia-current
    Module=nvidia
    PMMethod=bbswitch
    LibraryPath=/usr/lib/nvidia-current:/usr/lib32/nvidia-current
    XorgModulePath=/usr/lib/nvidia-current/xorg,/usr/lib/xorg/modules
    XorgConfFile=/etc/bumblebee/xorg.conf.nvidia

    ## Section with nouveau driver specific options, only parsed if
    # Driver=nouveau
    # [driver-nouveau]
    # KernelDriver=nouveau
    # PMMethod=auto
    # XorgConfFile=/etc/bumblebee/xorg.conf.nouveau



    ~~~~~~~AND~~~~~~~~~~


    ‪Section "ServerLayout"
    Identifier "Layout0"
    Option "AutoAddDevices" "false"
    EndSection

    Section "Device"
    Identifier "GeForce GT 640M LE"
    Driver "nvidia-current"
    VendorName "NVIDIA Corporation"
    Option "NoLogo" "true"
    Option "UseEDID" "false"
    Option "ConnectedMonitor" "DFP"
    EndSection

  9. #9
    Join Date
    Feb 2013
    Beans
    42

    Re: Nvidia X Driver Fails to Install

    Finally here is my xorg.conf that is in my /etc/X11 folder.

    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig: version 304.64 (buildmeister@swio-display-x86-rhel47-12) Tue Oct 30 12:04:46 PDT 2012


    Section "ServerLayout"
    Identifier "Layout0"
    Screen 0 "Screen0" 0 0
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Mouse0" "CorePointer"
    EndSection

    Section "Files"
    EndSection

    Section "InputDevice"

    # generated from default
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "auto"
    Option "Device" "/dev/psaux"
    Option "Emulate3Buttons" "no"
    Option "ZAxisMapping" "4 5"
    EndSection

    Section "InputDevice"

    # generated from default
    Identifier "Keyboard0"
    Driver "kbd"
    EndSection

    Section "Monitor"
    Identifier "Monitor0"
    VendorName "Unknown"
    ModelName "Unknown"
    HorizSync 28.0 - 33.0
    VertRefresh 43.0 - 72.0
    Option "DPMS"
    EndSection

    Section "Device"
    Identifier "GeForce GT 640M LE"
    Driver "nvidia-current"
    VendorName "NVIDIA Corporation"
    EndSection

    Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    SubSection "Display"
    Depth 24
    EndSubSection
    EndSection

  10. #10
    Join Date
    Feb 2013
    Beans
    42

    Re: Nvidia X Driver Fails to Install

    Quote Originally Posted by howefield View Post
    Check that you have the kernel headers installed...

    Code:
    uname -a
    to get the kernel version that you are using.

    Then install the kernel headers matching that kernel.

    You may need to do this every time you update the kernel.
    I made sure I had the latest headers for 3.7.0-7-generic then rebooted. It didn't change anything.

Page 1 of 4 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •