Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Webcam Issues

  1. #1
    Join Date
    Feb 2013
    Beans
    8

    Webcam problems on Lemu4 after kernel update

    After a recent ubuntu update, I no longer had webcam functionality. I reinstalled 12.10 via a live disk and tested the webcam with cheese--it worked fine. It only stops working after fully updating.

    The restore settings feature via the System76 driver did not fix the problem.
    Resetting things to "Optimized Defaults" in the bios didn't help either.

    This could be a number of things (gstreamer?, kernel patch?). I will look at the packages installed in the update

    Model: Lemu4, Ubuntu 12.10

    UPDATE: Device is still listed under ls /dev/video* as video0
    lsusb still displays the device
    In the preferences menu of cheese the device is still recognized but no image is displayed.
    Testing the pipeline in gstreamer-properties yields no display of output, only says "testing pipeline"
    kamerka doesn’t display anything either.

    I think the problem is coming from linux-headers-generic 3.5.0.25.31

    UPDATE 2: Running the System Testing program's camera test shows that it doesn't work.
    Results for picture test: Image viewer opened and said "Could not load image 'camera_test_lm810p.jpg'. Error interpreting JPEG image file (Improper call to JPEG library in state 200)"
    Nothing showed up at all during the video test.

    UPDATE 3: Forced linux-image-generic and linux-headers-generic to earlier version with Synaptic - Still no success.
    Reset cheese's config with dconf editor - Unsuccessful

    I'm running out of ideas :S

    Update 4: Similar to cashat, guvcview works and skype does not. I also filed a system76 support case and have yet to receive a reply.

    Update 5: Forgot to mention earlier that fn+f10 does turns the camera on or off but image/video is still not displayed.

    Could these certain programs have incompatibilities with kernel updates rather than this being a kernel fault? Perhaps an ffmpeg library or something to do with gstreamer prevents these programs from working correctly with a new kernel? I know cheese is fairly unreliable but the null result from gstreamer-properties is suspicious.
    Attached Files Attached Files
    Last edited by jedsled; February 25th, 2013 at 05:31 AM.

  2. #2
    Join Date
    Aug 2010
    Beans
    2

    Question Re: Webcam Issues

    I have the same problem. Tried to restore, reboot, install, reboor the system76 driver. Still cheese recognize my camera, but no picture.
    PC:lemur4
    Ubuntu 12.10
    Camera: BisonCam, nb Pro
    linux-image-3.5.0-20-generic (3.5.0-25.38)

    Hope there will be a solution to this!

    EDIT1: Installed guvcview and i can view picture from the camere, but still, not working with cheese, skype

    EDIT2:System test
    /dev/video0: OK name : BisonCam, NB Pro driver : uvcvideo version: 3.5.7 flags : 0x4000001 [ CAPTURE STREAMING ] Format: YUYV (YUV 4:2:2 (YUYV)) Resolutions: 640x480,352x288,320x240,160x120,176x144,1600x1200, 1280x1024,1280x720,640x480 Format: MJPG (MJPEG) Resolutions: 640x480,352x288,320x240,160x120,176x144,1600x1200, 1280x1024,1280x720,640x480
    But fails to capture an image

    EDIT3:Changed grub so i can choose kernel. Used the old kernel and camera works. Must be the updated kernel.
    Last edited by cashat; February 25th, 2013 at 05:29 PM.

  3. #3
    Join Date
    Feb 2013
    Beans
    1

    Re: Webcam Issues

    Hello, its my first time posting here.
    I am having the exact same problem since last Friday night, which correlates with a recent update.
    I am running ubuntu 12.04 on a lemur ultra
    camera: Chicony Electronics 2.0
    Cheese, VlC, player and Camorama, all open but display nothing. The device is listed on /dev/video0. At first the system76 driver would not open to do a system restore, it would crash and generate an error report. A subsequently did a clean install of Ubuntu 12.04, where I noticed the the camera functioned perfectly on Camorama when booted in the installation USB. So the camera itself is not broken. After installation system-76 driver works and can do a system restore, but cheese, vlc, camorama still display no image. All so did a gstreamer-properties video test with same negative results. I have opened a support note on system76 website have not heard a reply as of yet.

  4. #4
    Join Date
    Jul 2010
    Beans
    80
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Webcam Issues

    Same here. I think the problem first appeared after one of the latest kernel updates. If I boot with an older version of the kernel the camera works fine...

  5. #5
    Join Date
    May 2009
    Beans
    37
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Webcam Issues

    Similar problem on panp9 running 12.10 ubuntu.

    The integrated webcam is listed in Cheese's preferences but its screen area remains black.

    On live USB 12.04 and 12.10, Cheese does work.

  6. #6
    Join Date
    Jul 2007
    Beans
    35
    Distro
    Kubuntu 10.10 Maverick Meerkat

    Re: Webcam Issues

    I'm running Kubuntu 13.04 with kernel 3.8.0-5 and I can't get the BisonCam, NB Pro to work either.

  7. #7
    Join Date
    Feb 2013
    Beans
    8

    Re: Webcam Issues

    Output of some commands:

    jedidiah@jedidiah-Lemur-Ultra:~$ sudo modprobe uvcvideo
    [sudo] password for jedidiah:
    jedidiah@jedidiah-Lemur-Ultra:~$ dmesg | grep BisonCam
    [ 2.762663] usb 3-4: Product: BisonCam, NB Pro
    [ 12.537878] uvcvideo: Found UVC 1.00 device BisonCam, NB Pro (5986:0401)
    [ 12.542772] input: BisonCam, NB Pro as /devices/pci0000:00/0000:00:14.0/usb3/3-4/3-4:1.0/input/input5
    [ 92.105695] usb 3-4: Product: BisonCam, NB Pro
    [ 92.108852] uvcvideo: Found UVC 1.00 device BisonCam, NB Pro (5986:0401)
    [ 92.113966] input: BisonCam, NB Pro as /devices/pci0000:00/0000:00:14.0/usb3/3-4/3-4:1.0/input/input11
    jedidiah@jedidiah-Lemur-Ultra:~$ dmesg | grep uvcvideo
    [ 12.537878] uvcvideo: Found UVC 1.00 device BisonCam, NB Pro (5986:0401)
    [ 12.542938] usbcore: registered new interface driver uvcvideo
    [ 92.108852] uvcvideo: Found UVC 1.00 device BisonCam, NB Pro (5986:0401)

    Function key toggles the existence of /dev/video0

  8. #8
    Join Date
    Oct 2007
    Beans
    2

    Re: Webcam Issues

    Reporting this issue as well. guvcview does display video, but cheese, vlc, and google hangouts do not.

    fn+f10 does control /dev/video0 but does not seem to get the camera working

  9. #9
    Join Date
    Feb 2013
    Beans
    8

    Re: Webcam Issues

    From System76 support case

    "Thank you for your email. We're believing there is a software bug as a result of a recent update that's affected the camera. The camera itself seems to work, just does not provide any on-screen feedback, although taking pictures with the camera seems to work as it should.

    "We do have an internal bug that we're tracking and I'm adding you to it so we may provide periodic updates on the issue."

    Do the problems persist only on 12.10 or also 12.04? I might try 12.04 and see if this regression is only in 12.10's update channel.
    Last edited by jedsled; February 26th, 2013 at 05:24 AM.

  10. #10
    Join Date
    Jan 2013
    Beans
    5

    Re: Webcam Issues

    Quote Originally Posted by jamesmcq24 View Post
    Reporting this issue as well. guvcview does display video, but cheese, vlc, and google hangouts do not.

    fn+f10 does control /dev/video0 but does not seem to get the camera working
    Exactly the same on my machine.

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •