Results 1 to 7 of 7

Thread: Installed Ubuntu but it keeps booting Windows 7

  1. #1
    Join Date
    Jul 2006
    Location
    Calgary, Alberta
    Beans
    1,108
    Distro
    Ubuntu 13.04 Raring Ringtail

    Installed Ubuntu but it keeps booting Windows 7

    I got Windows 7 on a work laptop and I need to do some testing in Ubuntu. So I plugged in a flash drive, rebooted, ran the install and resized my partitions to 350 and 150. Everything installed fine, it rebooted and it automatically boots Windows 7, doesn't give me any Grub. I redid the install 3 times and every time it reboots right into Windows 7 without giving me any Grub option at any point. I have Quick Boot disabled, I can see the machine POST, but it still doesn't let me choose.

    Never seen this before, any advice?
    Quote Originally Posted by Tristam Green View Post
    I can tell you something about a turntable.
    I have two of them.
    And a microphone.
    Where it's at.

  2. #2
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Installed Ubuntu but it keeps booting Windows 7

    Best to see details of what is where.

    Post the link to the BootInfo report that this creates. Is part of Boot-Repair:
    https://help.ubuntu.com/community/Boot-Info
    Boot Repair -Also handles LVM, GPT, separate /boot and UEFI dual boot.:
    https://help.ubuntu.com/community/Boot-Repair
    You can repair many boot issues with this or 'Create BootInfo' report (Other Options) & post the link it creates, so we can see your exact configuration and diagnose advanced problems.
    Install in Ubuntu liveCD or USB or Full RepairCD with Boot-Repair (for newer computers)
    http://sourceforge.net/p/boot-repair/home/Home/
    https://help.ubuntu.com/community/UbuntuSecureRemix
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  3. #3
    Join Date
    Jul 2006
    Location
    Calgary, Alberta
    Beans
    1,108
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Installed Ubuntu but it keeps booting Windows 7

    Thanks, you were pretty close.
    Figured out the problem, this computer has a UEFI boot so I had to run the LiveUSB and do a boot repair with all recommended options. That gave me the Grub options and then I could boot into either Ubuntu or Windows.
    Quote Originally Posted by Tristam Green View Post
    I can tell you something about a turntable.
    I have two of them.
    And a microphone.
    Where it's at.

  4. #4
    Join Date
    Jul 2009
    Location
    AL, USA
    Beans
    318
    Distro
    Xubuntu 13.10 Saucy Salamander

    Re: Installed Ubuntu but it keeps booting Windows 7

    It seems that I'm definitely not the only one with this issue. I don't have any Boot-info and such currently after my nth install. Will install Lubuntu 12.10 again tomorrow and gather the appropriate info.
    HP Pavilion dv6, Core i3-3110M, 6GB RAM, nVIDIA Geforce GT 650M, 640GB HDD: Win7 / Xubuntu 13.10 64bit

  5. #5
    Join Date
    Jul 2009
    Location
    AL, USA
    Beans
    318
    Distro
    Xubuntu 13.10 Saucy Salamander

    Re: Installed Ubuntu but it keeps booting Windows 7

    OK, installed Lubuntu 12.10 again.
    Also installed boot-repair in a Live session.
    Before running the repair option, here's the info link.
    http://paste.ubuntu.com/5589343/

    I'll run the repair later and post another info link.
    HP Pavilion dv6, Core i3-3110M, 6GB RAM, nVIDIA Geforce GT 650M, 640GB HDD: Win7 / Xubuntu 13.10 64bit

  6. #6
    Join Date
    Jul 2009
    Location
    AL, USA
    Beans
    318
    Distro
    Xubuntu 13.10 Saucy Salamander

    Re: Installed Ubuntu but it keeps booting Windows 7

    Ok, ran the boot-repair and it says everything went fine, we'll see after a reboot. Here's the info link it gave at finish.
    http://paste.ubuntu.com/5589373/
    HP Pavilion dv6, Core i3-3110M, 6GB RAM, nVIDIA Geforce GT 650M, 640GB HDD: Win7 / Xubuntu 13.10 64bit

  7. #7
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Installed Ubuntu but it keeps booting Windows 7

    Even if you UEFI/BIOS has UEFI, your Windows & Ubuntu are installed in BIOS mode. So you should not boot anything in UEFI mode.
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •