Results 1 to 10 of 14

Thread: imac g3 tried many xorg.conf configs... any more ideas?

Hybrid View

  1. #1
    Join Date
    Feb 2013
    Location
    Northeast Corridor
    Beans
    51
    Distro
    Lubuntu

    Exclamation imac g3 tried many xorg.conf configs... any more ideas?

    g3 slot loading imac flower power
    600mhz
    640mb ram
    airport card

    I'm able to boot to yaboot and to my command line... but i cannot get X to start up. Im checking lightdm it doesnt seem to have any errors in the log. My xorg.0.log file is throwing errors for Bus error at a certain locatation [x0xx000000] for example.
    It then says aborting x server signal 7 bus error.

    I have tried inputting the specs for the imac based on other imac examples. i was able to log in and
    Code:
    sudo nano /home/lubuntu/xorg.conf.new
    i edit my setting and hit ctrl+o to save file. I know its saving correctly. i checked the xorg.0.log to see what xorg.conf and it does use 'xorg.conf.new'

    I even changed my yaboot parameters to add
    Code:
    radeon=modeset.0
    and tried that...

    I even tried booting using yaboot parameter
    Code:
    video=offb:off
    and all that did was freeze on my open firmware screen before yaboot comes up.

    Any ideas?? I reallly want to get lubuntu up and running.. my kids have projects to do for school coming up and i feel really bad that i cant get this thing runng... i dont want to try fedora..
    Last edited by imacg3ppc; February 21st, 2013 at 03:39 PM.

  2. #2
    Join Date
    Jan 2011
    Beans
    935

    Re: imac g3 tried many xorg.conf configs... any more ideas?

    Pretty sure everything you need is in the FAQ and Known Issues (it's the very first thing listed under 12.04) pages. So this is going to be brief.

    Xorg that should work with the live CD (not saying it's the best setup and I've never used an iMac in my life):

    Code:
    Section "Device" 
         Identifier "Card0" 
         Driver "r128"       
         Option "UseFBDev" "False" 
         Option "NoInt10" "True"
         Option "ForcePCIMode" "True"        
    EndSection
    
    Section "Monitor"       
         Identifier "Monitor0"       
         HorizSync 58-62       
         VertRefresh 75-117 
    EndSection
    You put it in /etc/X11/xorg.conf . Not in your home directory.

  3. #3
    Join Date
    Feb 2013
    Location
    Northeast Corridor
    Beans
    51
    Distro
    Lubuntu

    Re: imac g3 tried many xorg.conf configs... any more ideas?

    /etc/X11/xorg.conf does not exist and i cant load /etc/X11/xorg.conf from that location... i'll have to try maybe i didnt capitalize the X? that would be sweet.

    but yea... for some reason when i ran the install (see thread http://ubuntuforums.org/showthread.php?t=2117455) i was forced to manually partition the hd to make a separate /home partition. Only way i could get thru the base system install. So i have 4 partitions instead in of three.

    apple/boot/swap/home

    so i did notice that there may be a problem loading conf file from /home.

    But what can i do about this? When i try the automatic partitioning, i get drive I/O errors and everything takes forever to boot up. I have never gotten into x on this machine.

    I will try mixing and matching more options in the xorg.conf... but i'm tempted to try and get the live cd running to see if i can boot into X and get a graphical install going... i have spent hours on this issue.
    Last edited by imacg3ppc; February 21st, 2013 at 05:42 PM.

  4. #4
    Join Date
    Feb 2013
    Location
    Northeast Corridor
    Beans
    51
    Distro
    Lubuntu

    Re: imac g3 tried many xorg.conf configs... any more ideas?

    back to the drawing boards.... going to try a fresh install and try to get a standard automatic partition table.. you guys/gals think that if i get rid of the /home mix up that i have a better chance of being able to boot into x?

  5. #5
    Join Date
    Aug 2006
    Location
    Sweden
    Beans
    Hidden!
    Distro
    Lubuntu 12.04 Precise Pangolin

    Re: imac g3 tried many xorg.conf configs... any more ideas?

    if you try this

    http://ubuntuforums.org/showthread.php?t=2090462

    but use

    live video=offb:off radeon.modeset=0 single

    and

    modprobe aty128fb mode_option=1024x768-16

    can you get GUI then ?

  6. #6
    Join Date
    Feb 2013
    Location
    Northeast Corridor
    Beans
    51
    Distro
    Lubuntu

    Re: imac g3 tried many xorg.conf configs... any more ideas?

    i am going to try that tonight, first off the hd then on the live cd. Thanks so much for the tip great to have a helping hand(s) here in the forum and when i get up and running will reciprocate with any help i can provide.

    Will update in the AM of 2/22.

    Thanks again.

  7. #7
    Join Date
    Feb 2013
    Location
    Northeast Corridor
    Beans
    51
    Distro
    Lubuntu

    Unhappy Re: imac g3 tried many xorg.conf configs... any more ideas?

    OK, so it's a no go. No matter what i cannot
    Code:
    startx
    It does tell me no screen configured, but i have edited the xorg.conf many times over with various configurations. I'm going to try an install of straight up wheezy w/ lxde to see if it makes any difference... if anyone else has any ideas... let me know! and thanks for the help if i come up with a solution i will create a new thread with the details.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •