Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19

Thread: Wireless refusing to work

  1. #11
    Join Date
    Feb 2013
    Beans
    17

    Re: Wireless refusing to work

    Quote Originally Posted by varunendra View Post
    Utterlybewildered,

    Certain parts of these forums have so high number of new threads that it is usual for threads to go out of the first page or even out of a search result after a few hours. If that happens with one of your threads without answers or 'useful' answers, feel free to bump it after 24 hours.

    Now regarding the original issue, I may *try* to help if you could post output of -
    Code:
    lspci -nnk | grep -iA2 net
    Enter the above command in a terminal and post back its output here. You may just copy-paste it in the terminal (with your mouse) to avoid typing errors.
    Hi, thank you here is the result from the terminal

    welshybabe@ubuntu:~$ lspci - nnk / grep -iA2 net
    Usage: lspci [<switches>]


    Basic display modes:
    -mm Produce machine-readable output (single -m for an obsolete format)
    -t Show bus tree


    Display options:
    -v Be verbose (-vv for very verbose)
    -k Show kernel drivers handling each device
    -x Show hex-dump of the standard part of the config space
    -xxx Show hex-dump of the whole config space (dangerous; root only)
    -xxxx Show hex-dump of the 4096-byte extended config space (root only)
    -b Bus-centric view (addresses and IRQ's as seen by the bus)
    -D Always show domain numbers


    Resolving of device ID's to names:
    -n Show numeric ID's
    -nn Show both textual and numeric ID's (names & numbers)
    -q Query the PCI ID database for unknown ID's via DNS
    -qq As above, but re-query locally cached entries
    -Q Query the PCI ID database for all ID's via DNS


    Selection of devices:
    -s [[[[<domain>]:]<bus>]:][<slot>][.[<func>]] Show only devices in selected slots
    -d [<vendor>]:[<device>] Show only devices with specified ID's


    Other options:
    -i <file> Use specified ID database instead of A2
    -p <file> Look up kernel modules in a given file instead of default modules.pcimap
    -M Enable `bus mapping' mode (dangerous; root only)


    PCI access options:
    -A <method> Use the specified PCI access method (see `-A help' for a list)
    -O <par>=<val> Set PCI access parameter (see `-O help' for a list)
    -G Enable PCI access debugging
    -H <mode> Use direct hardware access (<mode> = 1 or 2)
    -F <file> Read PCI configuration dump from a given file

  2. #12
    Join Date
    Feb 2013
    Beans
    17

    Re: Wireless refusing to work

    Quote Originally Posted by mrgs View Post
    Another (low-tech) idea is to begin with a fresh install of 12.10. Since you have been struggling with this for a week I believe a reset is worth trying. 10.04 has less than two months life time left anyway, so no point in troubleshooting.
    Thanks, just not really sure of the benefit if there's no internet connection at all with version 12.10

  3. #13
    Join Date
    Mar 2010
    Location
    India
    Beans
    7,394
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wireless refusing to work

    Quote Originally Posted by Utterlybewildered View Post
    Hi, thank you here is the result from the terminal

    welshybabe@ubuntu:~$ lspci - nnk / grep -iA2 net
    Usage: lspci [<switches>]
    ...blah-blah-blah...
    Oops!! A tiny mistake you made there..

    The symbol before 'grep' is NOT forward slash (/). It is 'Pipe' symbol (|) which is located above 'Enter' key on my US-104 type keyboard, on the same key that types backslash (\). With shift, it will type the pipe symbol that is in the command.

    Just copy-paste using your mouse if that confuses you
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  4. #14
    Join Date
    Oct 2009
    Location
    Reykjavk, sland
    Beans
    9,292
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Wireless refusing to work

    Quote Originally Posted by Utterlybewildered View Post
    Thanks, just not really sure of the benefit if there's no internet connection at all with version 12.10
    It's very unlikely that the wired connection does not work. You can try in a live boot.
    About problems due to upgrading
    Bringing old hardware back to life.
    Please visit Quick Links -> Unanswered Posts

  5. #15
    Join Date
    Feb 2013
    Beans
    17

    Re: Wireless refusing to work

    Quote Originally Posted by varunendra View Post
    Actually, most often it is as easy as downloading the linux-firmware-nonfree package on another computer > copy it to the Ubuntu machine > double-click to install it > Done!

    The one I linked above is for precise (12.04), one may have to change the version according to his/hers.

    Thanks, have tried the link but it didn't work, the wireless did SAY it was connected but the internet still didn't work from it being installed, although I suspect it was because it was for 12.04 which isn't currently being run. I attempted a look around the website where that link is to but had no idea what I was looking at there, is there a version for 10.04.4 at all?

  6. #16
    Join Date
    Feb 2013
    Beans
    17

    Re: Wireless refusing to work

    Quote Originally Posted by Utterlybewildered View Post
    Thanks, have tried the link but it didn't work, the wireless did SAY it was connected but the internet still didn't work from it being installed, although I suspect it was because it was for 12.04 which isn't currently being run. I attempted a look around the website where that link is to but had no idea what I was looking at there, is there a version for 10.04.4 at all?

    Here is the Terminal result using the correct symbol, sorry

    Usage: lspci [<switches>]


    Basic display modes:
    -mm Produce machine-readable output (single -m for an obsolete format)
    -t Show bus tree


    Display options:
    -v Be verbose (-vv for very verbose)
    -k Show kernel drivers handling each device
    -x Show hex-dump of the standard part of the config space
    -xxx Show hex-dump of the whole config space (dangerous; root only)
    -xxxx Show hex-dump of the 4096-byte extended config space (root only)
    -b Bus-centric view (addresses and IRQ's as seen by the bus)
    -D Always show domain numbers


    Resolving of device ID's to names:
    -n Show numeric ID's
    -nn Show both textual and numeric ID's (names & numbers)
    -q Query the PCI ID database for unknown ID's via DNS
    -qq As above, but re-query locally cached entries
    -Q Query the PCI ID database for all ID's via DNS


    Selection of devices:
    -s [[[[<domain>]:]<bus>]:][<slot>][.[<func>]] Show only devices in selected slots
    -d [<vendor>]:[<device>] Show only devices with specified ID's


    Other options:
    -i <file> Use specified ID database instead of /usr/share/misc/pci.ids.gz
    -p <file> Look up kernel modules in a given file instead of default modules.pcimap
    -M Enable `bus mapping' mode (dangerous; root only)


    PCI access options:
    -A <method> Use the specified PCI access method (see `-A help' for a list)
    -O <par>=<val> Set PCI access parameter (see `-O help' for a list)
    -G Enable PCI access debugging
    -H <mode> Use direct hardware access (<mode> = 1 or 2)
    -F <file> Read PCI configuration dump from a given file
    welshybabe@ubuntu:~$

  7. #17
    Join Date
    Feb 2013
    Beans
    17

    Re: Wireless refusing to work

    Quote Originally Posted by mrgs View Post
    It's very unlikely that the wired connection does not work. You can try in a live boot.
    The wired connection did indeed not work with 12.04 which is why the reversion to 10.04.4, but I've no idea what a live boot is and how it's different from just booting up from pushing the laptop on button?

  8. #18
    Join Date
    Oct 2009
    Location
    Reykjavk, sland
    Beans
    9,292
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Wireless refusing to work

    You only observations is that it did not work in an upgraded 12.04. You have not tried a live boot, which is Buntu running from a CD of USB stick.
    About problems due to upgrading
    Bringing old hardware back to life.
    Please visit Quick Links -> Unanswered Posts

  9. #19
    Join Date
    Mar 2010
    Location
    India
    Beans
    7,394
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wireless refusing to work

    Quote Originally Posted by Utterlybewildered View Post
    Here is the Terminal result using the correct symbol, sorry

    Usage: lspci [<switches>]
    Unfortunately, this one again is a wrong usage. Like I said, just copy-paste the following (copy-paste it to a text file, take it to the ubuntu machine, copy-paste again in a terminal) -
    Code:
    lspci -nnk | grep -iA2 net
    The output should be something like -
    Code:
    lspci -nnk | grep -iA2 net
    02:00.0 Network controller [0280]: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) [168c:002b] (rev 01)
    	Subsystem: Foxconn International, Inc. Device [105b:e048]
    	Kernel driver in use: ath9k
    --
    04:00.0 Ethernet controller [0200]: Atheros Communications Inc. AR8151 v2.0 Gigabit Ethernet [1969:1083] (rev c0)
    	Subsystem: ASUSTeK Computer Inc. Device [1043:13c7]
    	Kernel driver in use: atl1c
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •