Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Steam Problem Dependecy

  1. #1
    Join Date
    Apr 2012
    Beans
    17

    Question Steam Problem Dependecy

    I am trying do install steam on a frechly installed and fully updated ubuntu 12.10.
    I get the message:
    Code:
    You are missing the following 32-bit libraries, and Steam may not run:
    not
    What can i do? i guess there is no such package ...

  2. #2
    Join Date
    Feb 2013
    Beans
    2

    Re: Steam Problem Dependecy

    I have the same problem, and allow me to clarify for anyone else-

    Upon opening the steam_latest.deb file, the most recent Steam Linux download, it installs and pops up saying


    "Steam Installer
    Start Steam to complete installation of the Steam for the current user."

    After pressing the "Start Steam" button, which is the only other option from "Close", the error message comes up saying

    "You are missing the following 32-bit libraries, and Steam may not run:
    not"




    I have tried reinstalling Steam (of course), I could not find any updates in 'sudo apt-get upgrade', I have even formatted the computer and reinstalled Ubuntu 12.10 (AMD64). Any help would be much appreciated.
    Last edited by Proots; February 23rd, 2013 at 11:36 PM. Reason: Removed picture so the solution is more visible to others.

  3. #3
    Join Date
    Mar 2007
    Beans
    194
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Steam Problem Dependecy

    Try:
    Code:
    sudo apt-get install ia32-libs
    Last edited by earthmeLon; February 23rd, 2013 at 11:35 PM. Reason: typo

  4. #4
    Join Date
    Sep 2008
    Beans
    3

    Re: Steam Problem Dependecy

    I am having these same issues. I tried that terminal command and it didn't work

    sudo apt-get install ai32-libs

    *then*

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package ai32-libs

  5. #5
    Join Date
    Feb 2013
    Beans
    2

    Re: Steam Problem Dependecy

    Quote Originally Posted by CalyxNM View Post
    I am having these same issues. I tried that terminal command and it didn't work

    sudo apt-get install ai32-libs

    *then*

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package ai32-libs
    I believe it is ia32-libs, and I contacted melon to change it. I am installing it now and will report how it goes.


    -Cameron


    Edit: I ran the code in the terminal and it worked. I went to the error pop-up to close it, and Steam came up doing an update, before the package was even installed. But yes - it works. Many thanks!
    Last edited by Proots; February 23rd, 2013 at 11:31 PM.

  6. #6
    Join Date
    Sep 2008
    Beans
    3

    Re: Steam Problem Dependecy

    You are correct. It is downloading how.

    Hope it works. THANKS!

    EDIT: it worked. Downloading TF2 now.

    Last edited by CalyxNM; February 23rd, 2013 at 11:43 PM.

  7. #7
    Join Date
    Mar 2007
    Beans
    194
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Steam Problem Dependecy

    Thanks guys. Edited the post. That should fix your problem. See you in TF2

  8. #8
    Join Date
    Oct 2009
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Steam Problem Dependecy

    If you guys have any problems just double clicking the steam deb, install gdebi and install the steam deb with it:

    Code:
    sudo gdebi /path/to/steam.deb
    Come to #ubuntuforums! We have cookies! | Basic Ubuntu Security Guide

    Tomorrow's an illusion and yesterday's a dream, today is a solution...

  9. #9
    Join Date
    Feb 2013
    Beans
    3

    Re: Steam Problem Dependecy

    After trying to run Steam and getting this message twice in a row:

    Code:
    You are missing the following 32-bit libraries, and Steam may not run: 
    not
    I pasted the edited line from earthmelon into the terminal, and get this:
    Code:
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     ia32-libs : Depends: ia32-libs-multiarch but it is not installable
    E: Unable to correct problems, you have held broken packages.
    I just uninstalled an older version of Ubuntu and reinstalled 12.10 with Win7.

    Help me, oh wise ones.

  10. #10
    Join Date
    Oct 2012
    Beans
    4

    Re: Steam Problem Dependecy

    Quote Originally Posted by CalyxNM View Post
    I am having these same issues. I tried that terminal command and it didn't work

    sudo apt-get install ai32-libs

    *then*

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package ai32-libs
    Quote Originally Posted by Proots View Post
    I believe it is ia32-libs, and I contacted melon to change it. I am installing it now and will report how it goes.


    -Cameron


    Edit: I ran the code in the terminal and it worked. I went to the error pop-up to close it, and Steam came up doing an update, before the package was even installed. But yes - it works. Many thanks!
    I thank you both, I had the same problem and now it's fixed.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •