Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: Live USB won't launch in persistent mode on all computers

  1. #1
    Join Date
    Feb 2013
    Beans
    14

    Question Live USB won't launch in persistent mode on all computers

    I'm very new to Ubuntu (second day using it) so I may not know all the terms of what I'm trying to say.

    I set up Ubuntu on a 32GB USB drive with a 25GB partition to save all my data on. This works fine on the computer that I set this up on (runs windows 7), and opens up to



    and it saves all my data between sessions, etc.

    Then I tried plugging it into my other computer (running windows 8 UEFI). After configuring the BIOS to have USB priority, it boots to



    It doesn't give me an option to boot in persistent mode. It does start up if i select trial mode, but none of my data or partitions show up. I tried running boot repair, but it didn't seem to do anything. I also tried this on another Windows 7 PC (can't confirm right now, but I'm pretty sure it also used UEFI) and had the same issue.

    Why do they boot to different screens, and how can I get my Windows 8 computera to boot in persistent mode?

  2. #2
    Join Date
    Feb 2013
    Beans
    14

    Re: Live USB won't launch in persistent mode on all computers

    I Just confirmed that the other Windows 7 PC also uses UEFI.

    Edit: I just tried it on a vista machine that uses BIOS, it didn't help. But something else I noticed was that it does save data between session on other machines, but its not the same data that I had on the first machine. If I start live mode on any of the other three machines, it has one set of data. If I start it on the original machine, it has a different set of data. I have no idea where its storing the data for these other computers.
    Last edited by nk565; February 18th, 2013 at 09:28 PM. Reason: additional information

  3. #3
    Join Date
    Feb 2013
    Beans
    14

    Re: Live USB won't launch in persistent mode on all computers

    Looking around some more, my newest guess at the problem is that the casper-rw partition isn't working on any computer other than the original.

  4. #4
    Join Date
    Oct 2009
    Location
    New Hamsha
    Beans
    1,275
    Distro
    Kubuntu 13.04 Raring Ringtail

    Re: Live USB won't launch in persistent mode on all computers

    Did you create a separate partition yourself, or let the USB Disk Creator do its work? If you did the former, I would redo the USB disk and let the USB Creator do it automatically.

    See more on UEFI booting here: https://help.ubuntu.com/community/UEFI
    It seems that, for the most part, it recommends turning UEFI/QuickBoot/FastBoot/SRT/Smart Response Technology OFF in your BIOS.
    AMD A4-3400 w/ Radeon HD 6410D, 8 GB Corsair Vengeance DDR3 1333Mhz, Kubuntu 14.04, SliTaz 4.0, Windows 8.1, Ubuntu 14.04 VM
    " ... Love your neighbor as you love yourself."

  5. #5
    Join Date
    Feb 2013
    Beans
    14

    Re: Live USB won't launch in persistent mode on all computers

    Did you create a separate partition yourself, or let the USB Disk Creator do its work? If you did the former, I would redo the USB disk and let the USB Creator do it automatically.
    The Disk creator made the partition, and I expanded it.

    See more on UEFI booting here: https://help.ubuntu.com/community/UEFI
    It seems that, for the most part, it recommends turning UEFI/QuickBoot/FastBoot/SRT/Smart Response Technology OFF in your BIOS.
    It wouldn't boot at all at first. Then i turned off safeboot and it worked. But booting isn't the problem, it just doesn't seem to be booting to the right partition (I have no idea where its writing all the data).

  6. #6
    Join Date
    Feb 2013
    Beans
    14

    Re: Live USB won't launch in persistent mode on all computers

    Here is a picture of my boot settings



    Also, because the UEFI page mentions it, my computer boots to this screen



    But all the computers do because the disk is 32 bit.

  7. #7
    Join Date
    Jun 2007
    Location
    Lynne Valley, BC
    Beans
    2,573
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Live USB won't launch in persistent mode on all computers

    Quote Originally Posted by nk565 View Post
    I'm very new to Ubuntu (second day using it) so I may not know all the terms of what I'm trying to say.

    I set up Ubuntu on a 32GB USB drive with a 25GB partition to save all my data on. This works fine on the computer that I set this up on (runs windows 7), and opens up to



    and it saves all my data between sessions, etc.

    Then I tried plugging it into my other computer (running windows 8 UEFI). After configuring the BIOS to have USB priority, it boots to



    It doesn't give me an option to boot in persistent mode. It does start up if i select trial mode, but none of my data or partitions show up. I tried running boot repair, but it didn't seem to do anything. I also tried this on another Windows 7 PC (can't confirm right now, but I'm pretty sure it also used UEFI) and had the same issue.

    Why do they boot to different screens, and how can I get my Windows 8 computera to boot in persistent mode?

    Try pressing any key when starting the boot and the first screen should appear, thus giving the option for persistence.

  8. #8
    Join Date
    Feb 2013
    Beans
    14

    Re: Live USB won't launch in persistent mode on all computers

    Try pressing any key when starting the boot and the first screen should appear, thus giving the option for persistence.
    Actually I figured that out, it didn't help.

  9. #9
    Join Date
    Jun 2007
    Location
    Lynne Valley, BC
    Beans
    2,573
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Live USB won't launch in persistent mode on all computers

    Does one of the computers have a casper-rw partition on it?

    A persistent thumb drive will use that rather than the casper-rw partition on the thumb drive.

    Does the thumb drive have both casper-rw file and partition?

    I'm wondering how there could be two sources of saved data and settings.

  10. #10
    Join Date
    Feb 2013
    Beans
    14

    Re: Live USB won't launch in persistent mode on all computers

    Does one of the computers have a casper-rw partition on it?
    If any of them did, it would have to be the original computer because its the one thats different, but I know the original is using the USB's casper-rw partition because I see everything saving there.

    Does the thumb drive have both casper-rw file and partition?
    I think so,

    I just don't know how it would save to the other partition (which was created when the live USB was), from what I understand nothing but the casper-rw partition should save anything.
    Last edited by nk565; February 19th, 2013 at 05:08 AM.

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •