Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: How to get Update Manager to be quiet?

  1. #1
    Join Date
    Jun 2007
    Beans
    24

    How to get Update Manager to be quiet?

    I am a long time Mythbuntu user. It's fantastic, and makes setting up MythTV pretty darn easy.

    I recently upgraded from a really old Mythbuntu release to 12.04 in order to upgrade to MythTV 0.26. In general, it went well, after working out a few issues.


    The one thing that has persisted, which is really annoying in a 10-foot interface typically driven by a remote control, is the Update Manager behavior.

    It seems like every time I power on my projector, I am greeted with a dialog box for the Update Manager. It, of course, has the GUI focus, so I cannot use MythTV until I go get my laptop and use VNC to connect in and close the dialog box.

    I first set update checking to the least frequent interval, but it still seemed to check more often. I set it to operate in the background so it wouldn't interrupt MythTV, but it still does. I have tried several other things, but still get the annoying dialogs. Yesterday, I turned off Update Manager update checks. Today, I was greeted with a dialog saying "You must check for updates manually".

    Come on! This is ridiculous. This behavior may be acceptable on a PC where you're already sitting in front of the keyboard and mouse to operate the system. But, in a Home Theater this is not acceptable.

    To top it all off, the VNC server in 12.04 doesn't seem to like connections from my Mac, either using the Screens app or the Apple Remote Desktop viewer. It constantly disconnects (crashes?) making it even more difficult to get rid of the update manager messages.

  2. #2
    Join Date
    Sep 2012
    Beans
    5,003

    Re: How to get Update Manager to be quiet?

    Maybe just remove update-manager and update manually.


  3. #3
    Join Date
    Jun 2007
    Beans
    24

    Re: How to get Update Manager to be quiet?

    Yeah, I guess I'll have to completely remove Update Manager.

    It's almost comical at this point. As far as I know, I have disabled everything I can. But, again today when I turned on my display I was greeted by an Update Manager dialog box listing the available updates. I'm not sure how/why it came up, but I'm back to VNC to dismiss the windows.


    In any case, one of the main reasons I posted here was in the hopes that the Mythbuntu crew would see it and potentially update the behavior, as it is really bad for a "10 foot interface".

    As I mentioned, I love Mythbuntu, I think it's a great project, and I just wanted to give some feedback towards making it great for everyone.

  4. #4
    Join Date
    Jun 2007
    Beans
    14,097

    Re: How to get Update Manager to be quiet?

    may not help at all but if keeping update-manager you could try disabling it in your Startup Applications

    By default it's hidden so 1st. one needs to un-hide
    Code:
    gksudo gedit /etc/xdg/autostart/update-notifier.desktop
    scroll down towards bottom & change "NoDisplay=true" to
    NoDisplay=false

    save, (don't save that annoying 'Untitled..') then open Startup Applications (from cli - gnome-session-properties) & disable (uncheck - screen
    Attached Images Attached Images

  5. #5
    Join Date
    Dec 2008
    Beans
    115

    Re: How to get Update Manager to be quiet?

    Agreed, very irritating behaviour in 12.04.
    I did this in desktop:

    Applications
    System
    Update manager
    Settings (bottom left), give password.
    Automatically check for updates = never

    You can put them back on again should you need to.

    Phil

  6. #6
    Join Date
    Apr 2007
    Location
    Kent, England
    Beans
    337
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How to get Update Manager to be quiet?

    Also got fed up with phone calls from the Mrs, asking how to get rid of the big white box on TV.
    on the FE/BE I did the same as Phil

    But on the remote IBM Thinkpad frontends, which Update Manager causes long periods of inactivity. I remove update manager altogether with
    Code:
    sudo apt-get remove update-manager-core
    and now I ssh into the old laptops and update with
    Code:
    sudo -S apt-get update && sudo apt-get dist-upgrade
    I have to be careful with the backend as a kernel update will stop the TBS cards from working.

    works for me.

  7. #7
    Join Date
    Oct 2005
    Location
    Austin, TX
    Beans
    2,983
    Distro
    Ubuntu Development Release

    Re: How to get Update Manager to be quiet?

    The intended behavior is that it's supposed to be popping up "behind" mythfrontend not in front. Can those affected please file a bug at

    https://bugs.launchpad.net/ubuntu/+s...update-manager

    Mention that you are using Mythbuntu 12.04.2 and that it's popping up in front of mythfrontend not behind.

    The update manager guys should be able to comment on what's going on and work out a fix.

    We used to have it set so that it would just render an icon in the tray, but I guess that option must have gotten removed from the update manager code without us noticing.

  8. #8
    Join Date
    Dec 2008
    Beans
    115

    Re: How to get Update Manager to be quiet?

    Ok. Will do.

    I’m on 12.04.01 LTS but frozen a few months ago. Which versions are other posters on?

    Can I seek clarification and a view please though superm1?

    When an application writes to screen it needs to give a priority for display. The problem could be that the priority of update manager is too high, but equally could it be that Mythtv is too low. I say this because there is another screen priority problem which may be related.

    When I moved from 9.04 to 12.04, not only did I see this update manager problem, but also a problem with the newly written Mythwelcome.
    When exiting mythtv frontend back to welcome, the screen does not paint properly. Black blocks at top/bottom of screen show (parts of the desktop) but otherwise the screen sticks at frontend. No part of Welcome screen paints but it may just flick into place a minute or so later. It typically needs a control/f2 to see it.

    My question is whether you think this is a Mythwelcome problem, not an update manger?

    Phil

  9. #9
    Join Date
    Oct 2005
    Location
    Austin, TX
    Beans
    2,983
    Distro
    Ubuntu Development Release

    Re: How to get Update Manager to be quiet?

    Quote Originally Posted by PhilWig View Post
    Ok. Will do.

    I’m on 12.04.01 LTS but frozen a few months ago. Which versions are other posters on?

    Can I seek clarification and a view please though superm1?

    When an application writes to screen it needs to give a priority for display. The problem could be that the priority of update manager is too high, but equally could it be that Mythtv is too low. I say this because there is another screen priority problem which may be related.

    When I moved from 9.04 to 12.04, not only did I see this update manager problem, but also a problem with the newly written Mythwelcome.
    When exiting mythtv frontend back to welcome, the screen does not paint properly. Black blocks at top/bottom of screen show (parts of the desktop) but otherwise the screen sticks at frontend. No part of Welcome screen paints but it may just flick into place a minute or so later. It typically needs a control/f2 to see it.

    My question is whether you think this is a Mythwelcome problem, not an update manger?

    Phil
    Oh this is interesting, is everyone affected having the problem only with mythwelcome? I think mythwelcome intentionally tries to be the app behind other apps. Mythfrontend should be in front however.

  10. #10
    Join Date
    Apr 2007
    Location
    Kent, England
    Beans
    337
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: How to get Update Manager to be quiet?

    Not using Mythwelcome, never go in standby or turn machine off.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •