Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Not using swap

  1. #1
    Join Date
    Apr 2010
    Beans
    260

    Exclamation Not using swap

    Ok yesterday I was ruining games under wine and editing videos in kdenlive at the same time but what I noticed that I was getting serious lag that I did not get before, today I started ubuntu and I noticed that system is not using swap at all what I mean by this is that swap file size is written ,,0" in "free -m" and in system monitor "not available" how do I mount swap partition ??

    Thank you in advanced
    Last edited by Chelidze; March 19th, 2013 at 12:20 AM.

  2. #2
    Join Date
    Oct 2008
    Location
    ExodusHair<Čubura
    Beans
    3,888
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Not using swap

    Quote Originally Posted by Chelidze View Post
    Ok yesterday I was ruining games under wine and editing videos in kdenlive at the same time but what I noticed that I was getting serious lag that I did not get before, today I started ubuntu and I noticed that system is not using swap at all what I mean by this is that swap file size is written ,,0" in "free -m" and in system monitor "not available" how do I mount swap partition ??

    Thank you in advanced
    Did You try (first) with
    Code:
    sudo swapon -a
    ...?

  3. #3
    Join Date
    Apr 2010
    Beans
    260

    Re: Not using swap

    Thank you for the reply
    this is what I got

    Code:
    cannot find the device for UUID=237fafd6-9284-44d4-b7c5-a253846a7288
    what happened before yesterday everything was working ??

  4. #4
    Join Date
    Mar 2006
    Location
    Williams Lake
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Not using swap

    What does:

    Code:
    swapon -s
    tell you?

  5. #5
    Join Date
    Apr 2010
    Beans
    260

    Re: Not using swap

    Quote Originally Posted by cariboo907 View Post
    What does:

    Code:
    swapon -s
    tell you?
    Code:
    Filename				Type		Size	Used	Priority
    this is what I got

    I have a question what is SpeedStor ??

  6. #6
    dino99's Avatar
    dino99 is offline Ubuntu addict and loving it
    Join Date
    Jun 2006
    Location
    Nux Jam
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Not using swap

    check the swap uuid inside /etc/fstab

    list uuids:
    sudo blkid

  7. #7
    Join Date
    Feb 2013
    Beans
    Hidden!

    Re: Not using swap

    If you've installed another Linux distribution that shares the swap partition with your Ubuntu, the installation program could reformat the swap partition thus assigning it another UUID. In this case Ubuntu cannot find it anymore as it is referenced in /etc/fstab by the old UUID. Compare the output of the commands:
    Code:
    sudo blkid -t TYPE=swap
    and
    Code:
    findmnt -st swap
    Last edited by schragge; March 18th, 2013 at 04:41 PM.

  8. #8
    Join Date
    Apr 2010
    Beans
    260

    Re: Not using swap

    Quote Originally Posted by dino99 View Post
    check the swap uuid inside /etc/fstab

    list uuids:
    sudo blkid
    Code:
    /dev/sda1: UUID="A274AD5474AD2BCB" TYPE="ntfs" /dev/sda2: UUID="1A0293A402938383" TYPE="ntfs" 
    /dev/sda3: UUID="BEEA60D8EA608E89" TYPE="ntfs" 
    /dev/sda5: UUID="70015310-a958-4b94-9469-51a314962984" TYPE="ext4"
    I think I know the cause of this problem I think two month ago I took out my second ntfs hdd I do not remember what happened I installed something or did something but I remember that I had to use Boot-repair from live ubuntu 12.04 cd to use my pc, yesterday ubuntu asked me if it was ok to update grub mane or something I always press keep the old one but yesterday I pressed yes replays or something .
    now I started Gparted
    this is what it is telling me on the start
    Code:
    Invalid partition table on /dev/sda -- wrong signature 3839.
    if I press ignore this pops
    Code:
    Invalid partition table on /dev/sda -- wrong signature 3839.
    if I press ignore this is what it tells me
    Code:
    Error informing the kernel about modifications to partition /dev/sda4 -- Device or resource busy.  This means Linux won't know about any changes you made to /dev/sda4 until you reboot -- so you shouldn't mount it or use it in any way before rebooting.
    and then when It starts the software it shows the swap space as uneducated space

    should I press new and create swap if this is possible at all ??

  9. #9
    dino99's Avatar
    dino99 is offline Ubuntu addict and loving it
    Join Date
    Jun 2006
    Location
    Nux Jam
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Not using swap

    inside gparted, select the faulty partition, and from the menu, select to repair the table (but dont format that partition, otherwise backup first)

    note: a new uuid is created each time a device is plugged/unplugged, so you need to update grub also, otherwise it cant know the new uuid.

  10. #10
    Join Date
    Apr 2010
    Beans
    260

    Re: Not using swap

    Quote Originally Posted by dino99 View Post
    inside gparted, select the faulty partition, and from the menu, select to repair the table (but dont format that partition, otherwise backup first)

    note: a new uuid is created each time a device is plugged/unplugged, so you need to update grub also, otherwise it cant know the new uuid.
    Sadly I can not find that option "repair"
    Last edited by Chelidze; March 18th, 2013 at 06:37 PM.

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •