Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Cinnamon in Raring Ringtail

Hybrid View

  1. #1
    Join Date
    Oct 2008
    Location
    Exodus Hair<- Čubura
    Beans
    3,699
    Distro
    Ubuntu Development Release

    Cinnamon in Raring Ringtail

    What would be preffered way of installing Cinnamon in RR...?
    At my place (due to G3 and ricotz) I get:
    Code:
    :~$ sudo apt-get install cinnamon
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     cinnamon : Depends: libgjs0-libmozjs185-1.0
    E: Unable to correct problems, you have held broken packages.
    Code:
    :~$ sudo apt-get install libgjs0-libmozjs185-1.0
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Package libgjs0-libmozjs185-1.0 is a virtual package provided by:
      libgjs0c 1.35.4-0ubuntu1~raring1 [Not candidate version]
      libgjs0c 1.34.0-0ubuntu1 [Not candidate version]
    
    E: Package 'libgjs0-libmozjs185-1.0' has no installation candidate
    No, ppa:gwendal-lebihan-dev/cinnamon-stable did not help...
    Last edited by zika; May 16th, 2013 at 03:31 PM. Reason: After reading again I found some typos...

  2. #2
    Join Date
    Jun 2007
    Beans
    12,738

    Re: Cinnamon in Raring Ringtail

    Code:
    sudo apt-get install cinnamon caribou
    no ppa
    Then possibly file bug on no caribou dep or not working in absence of caribou (not needed to install but needed to run

    edit: to show
    $ sudo apt-get -s install cinnamon caribou
    [sudo] password for doug:
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following packages were automatically installed and are no longer required:
    gnome-shell-common gtk2-engines-pixbuf libqt4-opengl
    Use 'apt-get autoremove' to remove them.
    The following extra packages will be installed:
    cinnamon-common gir1.2-accountsservice-1.0 gir1.2-caribou-1.0 gir1.2-gkbd-3.0 gir1.2-muffin-3.0
    gir1.2-networkmanager-1.0 gir1.2-polkit-1.0 gir1.2-upowerglib-1.0 gir1.2-xkl-1.0 gjs libcaribou-common libcaribou0
    libgjs0c libmozjs185-1.0 libmuffin0 muffin-common python-pyatspi python-pyatspi2
    The following NEW packages will be installed:
    caribou cinnamon cinnamon-common gir1.2-accountsservice-1.0 gir1.2-caribou-1.0 gir1.2-gkbd-3.0 gir1.2-muffin-3.0
    gir1.2-networkmanager-1.0 gir1.2-polkit-1.0 gir1.2-upowerglib-1.0 gir1.2-xkl-1.0 gjs libcaribou-common libcaribou0
    libgjs0c libmozjs185-1.0 libmuffin0 muffin-common python-pyatspi python-pyatspi2
    0 upgraded, 20 newly installed, 0 to remove and 19 not upgraded.
    Inst muffin-common (1.1.2-1 Ubuntu:13.04/raring [all])
    Inst libmuffin0 (1.1.2-1 Ubuntu:13.04/raring [amd64])
    Inst gir1.2-muffin-3.0 (1.1.2-1 Ubuntu:13.04/raring [amd64])
    Inst gir1.2-networkmanager-1.0 (0.9.7.995+git201301311547.17123fc-0ubuntu1 Ubuntu:13.04/raring [amd64])
    Inst libmozjs185-1.0 (1.8.5-1.0.0+dfsg-4 Ubuntu:13.04/raring [amd64])
    Inst libgjs0c (1.34.0-0ubuntu1 Ubuntu:13.04/raring [amd64])
    Inst cinnamon-common (1.6.7-2 Ubuntu:13.04/raring [all])
    Inst gjs (1.34.0-0ubuntu1 Ubuntu:13.04/raring [amd64])
    Inst gir1.2-accountsservice-1.0 (0.6.29-1ubuntu5 Ubuntu:13.04/raring [amd64])
    Inst gir1.2-xkl-1.0 (5.2.1-1ubuntu2 Ubuntu:13.04/raring [amd64])
    Inst gir1.2-gkbd-3.0 (3.6.0-0ubuntu1 Ubuntu:13.04/raring [amd64])
    Inst gir1.2-polkit-1.0 (0.105-1ubuntu1 Ubuntu:13.04/raring [amd64])
    Inst gir1.2-upowerglib-1.0 (0.9.19-1ubuntu4 Ubuntu:13.04/raring [amd64])
    Inst cinnamon (1.6.7-2 Ubuntu:13.04/raring [amd64])
    Inst libcaribou-common (0.4.4-1ubuntu1 Ubuntu:13.04/raring [all])
    Inst libcaribou0 (0.4.4-1ubuntu1 Ubuntu:13.04/raring [amd64])
    Inst gir1.2-caribou-1.0 (0.4.4-1ubuntu1 Ubuntu:13.04/raring [amd64])
    Inst python-pyatspi (2.7.2+dfsg-2ubuntu1 Ubuntu:13.04/raring [all])
    Inst python-pyatspi2 (2.7.2+dfsg-2ubuntu1 Ubuntu:13.04/raring [all])
    Inst caribou (0.4.4-1ubuntu1 Ubuntu:13.04/raring [all])
    Conf muffin-common (1.1.2-1 Ubuntu:13.04/raring [all])
    Conf libmuffin0 (1.1.2-1 Ubuntu:13.04/raring [amd64])
    Conf gir1.2-muffin-3.0 (1.1.2-1 Ubuntu:13.04/raring [amd64])
    Conf gir1.2-networkmanager-1.0 (0.9.7.995+git201301311547.17123fc-0ubuntu1 Ubuntu:13.04/raring [amd64])
    Conf libmozjs185-1.0 (1.8.5-1.0.0+dfsg-4 Ubuntu:13.04/raring [amd64])
    Conf libgjs0c (1.34.0-0ubuntu1 Ubuntu:13.04/raring [amd64])
    Conf cinnamon-common (1.6.7-2 Ubuntu:13.04/raring [all])
    Conf gjs (1.34.0-0ubuntu1 Ubuntu:13.04/raring [amd64])
    Conf gir1.2-accountsservice-1.0 (0.6.29-1ubuntu5 Ubuntu:13.04/raring [amd64])
    Conf gir1.2-xkl-1.0 (5.2.1-1ubuntu2 Ubuntu:13.04/raring [amd64])
    Conf gir1.2-gkbd-3.0 (3.6.0-0ubuntu1 Ubuntu:13.04/raring [amd64])
    Conf gir1.2-polkit-1.0 (0.105-1ubuntu1 Ubuntu:13.04/raring [amd64])
    Conf gir1.2-upowerglib-1.0 (0.9.19-1ubuntu4 Ubuntu:13.04/raring [amd64])
    Conf cinnamon (1.6.7-2 Ubuntu:13.04/raring [amd64])
    Conf libcaribou-common (0.4.4-1ubuntu1 Ubuntu:13.04/raring [all])
    Conf libcaribou0 (0.4.4-1ubuntu1 Ubuntu:13.04/raring [amd64])
    Conf gir1.2-caribou-1.0 (0.4.4-1ubuntu1 Ubuntu:13.04/raring [amd64])
    Conf python-pyatspi (2.7.2+dfsg-2ubuntu1 Ubuntu:13.04/raring [all])
    Conf python-pyatspi2 (2.7.2+dfsg-2ubuntu1 Ubuntu:13.04/raring [all])
    Conf caribou (0.4.4-1ubuntu1 Ubuntu:13.04/raring [all])
    Last edited by mc4man; February 15th, 2013 at 02:55 PM.

  3. #3
    Join Date
    Apr 2008
    Beans
    10,169

    Re: Cinnamon in Raring Ringtail

    Hmmm, I knew Cinnamon had been added to the repos some time ago:

    cinnamon (1.6.7-2) unstable; urgency=low

    * new patch: network-user-connection.patch
    Set connections and passwords as user-owned, following matching changes
    in nm-applet and gnome-control-center. (Closes: #698571)
    * Remove caribou as dependency. (LP: #1106062)
    * Restrict libgudev-glib-dev and libnm-glib-dev build-dependencies to
    Linux platforms: should fix the build on FreeBSD and Hurd.

    -- Nicolas Bourdaud <nicolas.bourdaud@gmail.com> Thu, 07 Feb 2013 13:40:30 +0100

    cinnamon (1.6.7-1) unstable; urgency=low

    * New upstream cinnamon_1.6.7
    - Fix keyboard settings applet. (Closes: #695217)
    * Remove the useless dependency of cinnamon on cups-pk-helper
    * Update debian/watch: stop using redirector (thanks to Bart Martens)
    * Add libgl1-mesa-dev as build depends: should fix build on ARM
    * Build bluetooth support only on Linux architectures.
    * Add python-dbus and python-imaging dependencies. (Closes: #693935)
    * Do not install browser plugin in multiarch folder. (Closes: #695338)
    * Install translation files in the standard folder. (Closes: #695286)
    new patch: fix-gettext-files-path.patch
    * Move packaging git repo to Alioth.
    * Use rpath to fix the use of libgnome-bluetooth. (Closes: #695408)
    - update: disable-bluetooth-applet-hack.patch

    -- Nicolas Bourdaud <nicolas.bourdaud@gmail.com> Tue, 11 Dec 2012 18:24:48 +0100

    cinnamon (1.6.2-1) unstable; urgency=low

    * Initial release. (Closes: #657395)

    -- Nicolas Bourdaud <nicolas.bourdaud@gmail.com> Thu, 01 Nov 2012 17:49:55 +0100
    But I've yet to actually try it in Raring

  4. #4
    Join Date
    Oct 2008
    Location
    Exodus Hair<- Čubura
    Beans
    3,699
    Distro
    Ubuntu Development Release

    Re: Cinnamon in Raring Ringtail

    Quote Originally Posted by mc4man View Post
    Code:
    sudo apt-get install cinnamon caribou
    no ppa
    Then possibly file bug on no caribou dep or not working in absence of caribou (not needed to install but needed to run

    edit: to show
    Not that I did not think about that...
    Code:
    :~$ sudo apt-get install cinnamon caribou
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     cinnamon : Depends: libgjs0-libmozjs185-1.0
    E: Unable to correct problems, you have held broken packages.

  5. #5
    Join Date
    Jun 2006
    Location
    Plymouth UK
    Beans
    86

    Re: Cinnamon in Raring Ringtail

    Cinnamon should work using the nightly build from this ppa:

    https://launchpad.net/~gwendal-lebih...nnamon-nightly

    regards

  6. #6
    Join Date
    Oct 2008
    Location
    Exodus Hair<- Čubura
    Beans
    3,699
    Distro
    Ubuntu Development Release

    Re: Cinnamon in Raring Ringtail

    Quote Originally Posted by macstevejb View Post
    Cinnamon should work using the nightly build from this ppa:

    https://launchpad.net/~gwendal-lebih...nnamon-nightly

    regards
    After turning that PPA on and after update I still get:
    Code:
    zika@zika:~$ sudo apt-get install cinnamon
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     cinnamon : Depends: libgjs0-libmozjs185-1.0
                Recommends: nemo but it is not going to be installed
                Recommends: cinnamon-screensaver but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    A bit different but the same problem persists...
    To prevent ambiguity:
    Code:
    :~$ sudo apt-get install cinnamon caribou
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     cinnamon : Depends: libgjs0-libmozjs185-1.0
                Recommends: nemo but it is not going to be installed
                Recommends: cinnamon-screensaver but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.

  7. #7
    Join Date
    Aug 2009
    Beans
    881
    Distro
    Ubuntu Development Release

    Re: Cinnamon in Raring Ringtail

    Quote Originally Posted by zika View Post
    Code:
    $ sudo apt-get install cinnamon
    
    The following packages have unmet dependencies:
     cinnamon : Depends: libgjs0-libmozjs185-1.0
    E: Unable to correct problems, you have held broken packages.
    This sounds like you are using the Ricotz testing PPA which uses mozjs188 (which does fix some bugs but we may have to wait for 13.10 for it to get into Ubuntu). If you want to use Cinnamon, you'll either need to rebuild Cinnamon yourself (or in a PPA that depends on the Ricotz testing PPA) or ppa-purge that PPA.

  8. #8
    Join Date
    Oct 2008
    Location
    Exodus Hair<- Čubura
    Beans
    3,699
    Distro
    Ubuntu Development Release

    Re: Cinnamon in Raring Ringtail

    Quote Originally Posted by jbicha View Post
    This sounds like you are using the Ricotz testing PPA which uses mozjs188 (which does fix some bugs but we may have to wait for 13.10 for it to get into Ubuntu). If you want to use Cinnamon, you'll either need to rebuild Cinnamon yourself (or in a PPA that depends on the Ricotz testing PPA) or ppa-purge that PPA.
    Yes, I use Ricotz's testing... I thought that there might be some shortcut, but...
    My path is clear... Thank You...
    Update₁:It was not worthy... Purged Ricotz's testing PPA and installed Cinnamon just to learn that it does not work: blank screen with cursor... Terminal opens but... For the record, I've been using Cinnamon earlier, not just as spice...
    Last edited by zika; February 15th, 2013 at 07:59 PM.

  9. #9
    Join Date
    Jun 2007
    Beans
    12,738

    Re: Cinnamon in Raring Ringtail

    For what it's worth, (not much really), it does start up & run on a non-modded 13.04 install

    Though at least here it still does need caribou/libcaribou0 installed to actually start up
    (another crappy Debian maintainer package in Ubuntu

  10. #10
    Join Date
    Apr 2011
    Location
    3rd Rock from the Sun
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Cinnamon in Raring Ringtail

    I am using Cinnamon on my Raring along with Unity... I actually wanted to check out Nemo... but to have that I had to install Cinnamon.

    I am using a stable ppa: https://launchpad.net/~gwendal-lebih...innamon-stable

    It is working flawlessly AFAIK. I had a issue when 'cinnamon-settings' was not launching but that got fixed with recent python updates...

    As for the problem you are having: I checked Synaptic and I have libgjs0c and I don't have libgjs0-libmoxjs185-1.0 in Synaptic or in my repos.

    Try installing Cinnamon from the stable ppa above...
    "Evolution is Nature's way of issuing upgrades."

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •