Results 1 to 3 of 3

Thread: Setting umask for www-data?

  1. #1
    Join Date
    Jul 2010
    Location
    Berkeley, CA
    Beans
    15

    Setting umask for www-data?

    I'm using 10.04 and am having some problems setting the umask for www-data.

    I want to use a umask of 002 when the web server creates files, but nothing I do changes it from the default. I've tried adding
    Code:
    umask 002
    to: /etc/init.d/apache2
    /etc/apache2/envvars
    /home/www-data/.bashrc

    I have restarted the web server after every file change. What am I missing?

  2. #2
    Join Date
    Feb 2009
    Location
    Dallas, TX
    Beans
    6,663
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Setting umask for www-data?

    Hi jmickela.

    Instead of restarting, try stop and the start.

    Just a thought.

    Let us know how it goes.
    Regards.

  3. #3
    Join Date
    Jul 2010
    Location
    Berkeley, CA
    Beans
    15

    Re: Setting umask for www-data?

    Looks like that did it! Thanks a lot.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •