Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: totem opens favorite folders instead of Nautilus

  1. #1
    Join Date
    Nov 2005
    Location
    Montreal, Canada
    Beans
    525

    totem opens favorite folders instead of Nautilus

    When I click:
    Places > Downloads
    or
    Places > Videos
    or
    Places > Documents (etc.)
    rather than Nautilus opening the appropriate folder, totem tries to open the folder. totem will fill itself with the files it finds in the folder and complain that it doesn't have a plug-in to open text files, etc.

    What can I tweak in order to restore browsing to Nautilus from totem?

  2. #2
    Join Date
    Apr 2008
    Location
    Australian in Germany
    Beans
    4,010
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: totem opens favorite folders instead of Nautilus

    Hallo BobSongs,
    I have no help, but maybe the same problem.
    I updated a laptop for a friend via fresh install from 8.04 to 9.10 after shrinking the /home partition, which was reused, and enlarging the / partition.

    After the fresh install, the "places" menu started behaving in a similar manner.
    The link to "filesystem" works, some others do nothing, and several cause Rhytmnbox to open and want to play something.
    I'm stumped, so I will be watching to see if you get a reply.
    Michael

  3. #3
    Join Date
    Nov 2005
    Location
    Montreal, Canada
    Beans
    525

    Re: totem opens favorite folders instead of Nautilus

    >> bump <<

  4. #4
    Join Date
    Oct 2007
    Location
    Brussels, Belgium
    Beans
    80
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: totem opens favorite folders instead of Nautilus

    I believe this needed an edit of ~/.local/share/applications/mimeapps.list

    So boot up a terminal and type
    Code:
    cd ~/.local/share/applications
    vim mimeapps.list
    Note: you can of course use another text editor than vim. eg: nano, gedit, ...

    Look for a line that says
    Code:
    inode/directory=STUFFHERE;
    Most likely, the STUFFHERE part will start with "totem.desktop;". Remove the totem entry (entries are seperated by ;, be sure to remove everything of the totem entry). Either way, what you want is the nautilus entry to be the first (if there is no nautilus entry whatsoever, put "nautilus-folder-handler.desktop;" right after the "=". Then save.


    If this is a systemwide problem, you might have to edit this file instead
    Code:
    /etc/gnome/defaults.list

  5. #5
    Join Date
    Nov 2005
    Location
    Montreal, Canada
    Beans
    525

    Re: totem opens favorite folders instead of Nautilus

    Ahh! Thanks, Wardje. Let me spew the contents of that file:

    Code:
    [Added Associations]
    application/x-extension-drive=totem.desktop;
    inode/directory=totem.desktop;nautilus-folder-handler.desktop;kde4-dolphin.desktop;kde4-gwenview.desktop;kde4-kfmclient_dir.desktop;Thunar-folder-handler.desktop;
    x-content/audio-cdda=sound-juicer.desktop;
    x-content/video-dvd=totem.desktop;
    x-content/audio-player=rhythmbox.desktop;
    x-content/image-dcf=f-spot-import.desktop;
    Seems you nailed it on the head. There it is: "totem.desktop". Seems my ~ folder is revealing that I've tried adding several desktops. I'll clean out the superfluous entries.

    Thanks again!!

    Edit:

    The ~/.local/share/applications/mimeapps.list file was edited in gedit without root privileges. The line
    Code:
    inode/directory=totem.desktop;nautilus-folder-handler.desktop;kde4-dolphin.desktop;kde4-gwenview.desktop;kde4-kfmclient_dir.desktop;Thunar-folder-handler.desktop;
    was simply changed to
    Code:
    inode/directory=nautilus-folder-handler.desktop;
    I logged out of the account and logged back in. Things seem to be working perfectly. The only "change" is that Nautilus doesn't seem to show any "eject" buttons next to removable drives. However, these show up on teh desktop. And that's good enough for me.
    Last edited by BobSongs; December 12th, 2009 at 06:22 PM. Reason: more info added for future reference.

  6. #6
    Join Date
    Dec 2007
    Beans
    162

    Re: totem opens favorite folders instead of Nautilus

    thanks so much

    I was having the same problem with rhythmbox doing the same thing
    Ubuntu On a Dell Inspiron 1525N
    I've been conned into using Linux since ~06?
    UPGRADING = <--nuff said

  7. #7
    Join Date
    Apr 2008
    Location
    Australian in Germany
    Beans
    4,010
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: totem opens favorite folders instead of Nautilus

    Quote Originally Posted by Wardje View Post
    I believe this needed an edit of ~/.local/share/applications/mimeapps.list

    So boot up a terminal and type
    Code:
    cd ~/.local/share/applications
    vim mimeapps.list
    Note: you can of course use another text editor than vim. eg: nano, gedit, ...

    Look for a line that says
    Code:
    inode/directory=STUFFHERE;
    Most likely, the STUFFHERE part will start with "totem.desktop;". Remove the totem entry (entries are seperated by ;, be sure to remove everything of the totem entry). Either way, what you want is the nautilus entry to be the first (if there is no nautilus entry whatsoever, put "nautilus-folder-handler.desktop;" right after the "=". Then save.


    If this is a systemwide problem, you might have to edit this file instead
    Code:
    /etc/gnome/defaults.list
    THANKS! Needed that for a computer that I look after for a friend. It worked.
    Michael

  8. #8
    Join Date
    Dec 2010
    Beans
    1
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: totem opens favorite folders instead of Nautilus

    I had the same problem and found an easier solution (for absolute beginners, at least).

    You right click on any folder* and go to the "Open with other application".
    There you select File Browser and check the box "Remember this application for 'folder' files".

    There you have it. It worked for me.

    *If you haven`t got a folder on your desktop, you can open Nautilus from the terminal and right clicking any folder you have.

  9. #9
    Join Date
    May 2009
    Location
    Wilton, CT
    Beans
    190
    Distro
    Ubuntu 10.04 Lucid Lynx

    Smile Re: totem opens favorite folders instead of Nautilus

    Quote Originally Posted by xavierneuman View Post
    I had the same problem and found an easier solution (for absolute beginners, at least).

    You right click on any folder* and go to the "Open with other application".
    There you select File Browser and check the box "Remember this application for 'folder' files".

    There you have it. It worked for me.

    *If you haven`t got a folder on your desktop, you can open Nautilus from the terminal and right clicking any folder you have.
    This worked for me too... I'd been doing some cleanup of my "Open With" and somehow messed up associations with folders. This fixed that.

  10. #10
    Join Date
    Feb 2006
    Location
    Norway
    Beans
    66
    Distro
    Ubuntu Studio 12.10 Quantal Quetzal

    Re: totem opens favorite folders instead of Nautilus

    When you want to open a folder with totem or some other application, the intuitive way is right-click folder and choose "open with..."

    Then if you keep the "remember this program..." option totem will become the default program to open that folder and users get confused because suddenly default behaviour changed.

    So what's counter-intuitive here is that the "remember" box is checked by default - and maybe that the description is a bit misleading. It could read something like "change default program for this folder" instead.
    On Ubuntu since December 2005 (5.10 onwards)

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •