Results 1 to 5 of 5

Thread: Can't load ubuntu after upgrade from 10.04 to 12.04

Threaded View

  1. #1
    Join Date
    Sep 2012
    Beans
    5

    Can't load ubuntu after upgrade from 10.04 to 12.04

    Hi to all,

    I made an upgrade of a working-till that time-dual boot laptop containing windows XP and Ubuntu 10.04.
    During the upgrade I noticed error installing libxml-libxml-perl but any way, after the upgrade I couldn't boot anything so, I decided to repair grub and I managed to fix some things and boot windows.
    My reports as I tried to fix grub with live cd following this (2nd option) are: this and this.

    My system was still non bootable so, I decided to manually re-install grub following this:

    Code:
    sudo mount /dev/sda5 /mnt
    sudo mount --bind /dev /mnt/dev && sudo mount --bind /dev/pts /mnt/dev/pts && sudo mount --bind /proc /mnt/proc && sudo mount --bind /sys /mnt/sys 
    sudo chroot /mnt
    grub-install /dev/sda
    grub-install --recheck /dev/sda
    update-grub
    last command fixed boot menu where I can start windows but not Linux!

    I decided to fix my suspicious errors during installation so continue typing as a chroot user......

    Code:
    dpkg --configure --pending
    took 20 minutes to download missing confs!!

    I insisted on having a grub problem so I decided to remove grub and re-install it following this (Purging & Reinstalling GRUB 2)BUT:

    Code:
    root@ubuntu:/# apt-get purge grub grub-pc grub-common
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Package grub is not installed, so not removed
    You might want to run 'apt-get -f install' to correct these:
    The following packages have unmet dependencies:
     grub-gfxpayload-lists : Depends: grub-pc (>= 1.99~20101210-1ubuntu2) but it is not going to be installed
     grub-pc-bin : Depends: grub-common (= 1.99-21ubuntu3) but it is not going to be installed
     grub2-common : Depends: grub-common (= 1.99-21ubuntu3) but it is not going to be installed
     libxml-libxml-perl : Depends: perlapi-5.10.0 but it is not installable
                          Depends: libxml-sax-perl but it is not going to be installed
     ubuntu-minimal : Depends: resolvconf
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
    aaaa.... that libxml-libxml-perl problem!!!
    Shall we move on?

    Code:
    root@ubuntu:/# dpkg --configure --pending
    Setting up resolvconf (1.63ubuntu11) ...
    mkdir: cannot create directory `/run': Too many levels of symbolic links
    dpkg: error processing resolvconf (--configure):
     subprocess installed post-installation script returned error exit status 1
    dpkg: dependency problems prevent configuration of ubuntu-minimal:
     ubuntu-minimal depends on resolvconf; however:
      Package resolvconf is not configured yet.
    dpkg: error processing ubuntu-minimal (--configure):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
     resolvconf
     ubuntu-minimal
    what about?

    Code:
    root@ubuntu:/# apt-get -f install
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Correcting dependencies... Done
    The following packages will be REMOVED:
      libxml-libxml-perl
    0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
    2 not fully installed or removed.
    After this operation, 1,376 kB disk space will be freed.
    Do you want to continue [Y/n]? y
    (Reading database ... 310697 files and directories currently installed.)
    Removing libxml-libxml-perl ...
    /var/lib/dpkg/info/libxml-libxml-perl.prerm: 11: /var/lib/dpkg/info/libxml-libxml-perl.prerm: update-perl-sax-parsers: not found
    dpkg: error processing libxml-libxml-perl (--remove):
     subprocess installed pre-removal script returned error exit status 127
    No apport report written because MaxReports is reached already
                                                                  Errors were encountered while processing:
     libxml-libxml-perl
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    or even:

    Code:
    root@ubuntu:/# apt-get upgrade -f
    root@ubuntu:/# apt-get dist-upgrade -f
    ...the same!

    The system is down permanently!

    Any ideas???????
    ps: when I start now my ubuntu I receive this error message:
    "could not log bootup: Address already in use. An error occurred while mounting /run"
    Last edited by kgeo; February 12th, 2013 at 08:09 PM. Reason: error on normal linux boot

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •