Results 1 to 2 of 2

Thread: Newbie - Wireless Device "Not ready"

  1. #1
    Join Date
    Jun 2011
    Beans
    5

    Newbie - Wireless Device "Not ready"

    Hi,

    I am new to Linux, Using Ubuntu but when I tried to go on the Networking information, It says my device is "Not ready".

    By this, I know it means the Driver isn't installed so I looked online and found this driver: http://www.wireless-driver.com/realt...macos-drivers/ for my device.

    I read the readme which said " 1. In order to make the driver to work, the fold under firmware need
    to be put under the fold of /lib/firmware/ or
    /lib/firmware/(KERNEL_VERSION)/"

    So I tried to copy the folder "firmware" into /lib/firmware/ but I don't have permission to do so.

    Hope you can help!

  2. #2
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,961
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: Newbie - Wireless Device "Not ready"

    Assuming the firmware file you downloaded is on your desktop, then open a terminal and do:
    Code:
    sudo cp Desktop/firmware/* /lib/firmware
    However, I doubt the answer is precisely that. I assume the driver in question is r8192u_usb. If so, check:
    Code:
    modinfo r8192u_usb
    It says, in part:
    filename: /lib/modules/3.5.0-23-generic/kernel/drivers/staging/rtl8192u/r8192u_usb.ko
    description: Linux driver for Realtek RTL8192 USB WiFi cards
    version: V 1.1
    license: GPL
    firmware: RTL8192U/data.img
    firmware: RTL8192U/main.img
    firmware: RTL8192U/boot.img
    license: GPL
    That means the driver will look for the firmware files in /lib/firmware/RTL8192U. Therefor, what you probably really want to do is:
    Code:
    sudo mkdir /lib/firmware/RTL8192U
    sudo cp Desktop/firmware/* /lib/firmware/RTL8192U
    As you might expect, the wildcard * means copy all the files in the folder.

    Please post back if you get stuck.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •