Results 1 to 3 of 3

Thread: running Scrivener-1.5.3.1-beta.deb on Ubuntu 12.04 (32 bit)

  1. #1
    Join Date
    Mar 2011
    Location
    U.K.
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    running Scrivener-1.5.3.1-beta.deb on Ubuntu 12.04 (32 bit)

    I've successfully run earlier beta's of Scrivener on Ubuntu 12.04 ..
    but I can't get the latest 1.5.3.1-beta to launch after installing

    Scrivener is a powerful content-generation tool for writers that allows you to concentrate on composing and structuring long and difficult documents.
    Any user of Scrivener got this app running on Ubuntu 12.04 32 bit?

    One theory read in Scrivener forum is that there seems to be some incompatibility of Qt libraries between Ubuntu 12.04 and Scrivener.

    Scrivener uses earlier release of Qt libraries?

    I've tried copying the Ubuntu Qt library from /usr/lib/i386-linux-gnu/
    into /usr/share/scrivener/lib/
    but that didn't work.

  2. #2
    Join Date
    Mar 2011
    Location
    U.K.
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: running Scrivener-1.5.3.1-beta.deb on Ubuntu 12.04 (32 bit)

    Can I rephrase the question?

    In Ubuntu 12.04 how can I downgrade Qt 4.8.1 to Qt 4.8.0 ?

    and then later upgrade from Qt 4.8.0 to Qt 4.8.1?

    There was a suggestion posted here in similar circumstances ...

    https://isis.astrogeology.usgs.gov/I....html#msg14039

    setting LD_LIBRARY_PATH to load the crashing application library first (Qt 4.8.0) before the core libraries (Qt 4.8.1).

    Would this work?

  3. #3
    Join Date
    May 2011
    Location
    Alaska
    Beans
    15
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: running Scrivener-1.5.3.1-beta.deb on Ubuntu 12.04 (32 bit)

    I also have an issue with the QT libraries. I can get it to launch with no problem. I have tried to use some features to see if they work. When I try to import a .txt file, it crashes and I get the following:

    Code:
    Cannot mix incompatible Qt library (version 0x40803) with this library (version 0x40800)
    Aborted (core dumped)
    It is really frustraing. I really want to use this app as I have been searching for a program to help me keep track of timelines, ideas, and characters and it may just be what I am looking for.

    I am running 12.10 on an HP mini.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •