Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: USB and networking broken in 64-bit ubuntu for new motherboard

  1. #11
    Join Date
    Nov 2013
    Beans
    8

    Re: USB and networking broken in 64-bit ubuntu for new motherboard

    Enabling iommu in the bios will fix the Ethernet issue and make the usb 2.0 ports work for Gigabyte 970 chipset board GA-970A-DS3P rev 1.0, but usb 3.0 ports will no longer work on the back of the motherboard or from the internal 20 pin connector for the front panel. I have tried Ubuntu 12.04 LTS and 14.04 with the same result. If there is anyone else in the same boat please post up.

  2. #12
    Join Date
    Nov 2013
    Beans
    8

    Re: USB and networking broken in 64-bit ubuntu for new motherboard

    Here is my updated fix


    First enable iommu in the uefi by restarting your computer and pressing delete to enter the uefi


    plug your usb mouse, keyboard and thumbdrive in usb 2 ports.


    save and exit the uefi


    Then In Ubuntu:


    press Ctrl+Alt+T to open up a terminal


    run the following command: sudo gedit /etc/default/grub


    Edit the empty quotes in this line to read: GRUB_CMDLINE_LINUX="iommu=soft"


    save changes to grub and exit gedit and the terminal


    Open up a new terminal with ctrl+alt+t


    run the following command: sudo update-grub


    then exit the terminal using this command: exit


    Restart your computer press delete to get back into the uefi


    Disable iommu in bios, load optimized defaults and restart.


    usb, 2.0 usb 3.0 and networking all work now in Ubuntu, and disabling iommu in bios helps prevent windows freezes that was occurring if you are running a dual boot environment.


    If the above post helps anyone I am happy.
    Last edited by ozcyto; May 29th, 2014 at 12:27 AM.

  3. #13
    Join Date
    Nov 2013
    Beans
    6

    Re: USB and networking broken in 64-bit ubuntu for new motherboard

    This is obviously an issue with this board. I have the same make and model of board and I had exactly the same issue. I posted my own thread a couple of days ago and sanderj posted and forwarded me to this post. Many thanks goes out to ozcyto for his/her solution. Although for me, gksudo wasn't on my system by default and with no network couldn't download it so I had to use plain sudo command in Terminal instead. Still worked as advertised. The interesting thing was that IOMMU was already disabled in the BIOS.

  4. #14
    Join Date
    Jan 2014
    Beans
    2

    Re: USB and networking broken in 64-bit ubuntu for new motherboard

    I'm having exactly the same issue with a new Gigabyte GA-970A-DS3P motherboard: Works fine with 32bit Kubuntu 3.10, bit with 64bit there's No USB2, wireless or wired ethernet, however my USB3 works fine.

    Setting IOMMU to enabled in the BIOS has fixed my ethernet, wireless and USB2, so thank you very much for posting this.
    However now my USB3 ports are dead. This is a much better situation than before, but still not ideal.

    I tried ozcyto's instructions to set GRUB_CMDLINE_LINUX="iommu=soft" however this didn't seem to have any effect.
    Last edited by mittens2; January 30th, 2014 at 07:06 PM.

  5. #15
    Join Date
    Aug 2014
    Beans
    1

    Re: USB and networking broken in 64-bit ubuntu for new motherboard

    Quote Originally Posted by mittens2 View Post
    Setting IOMMU to enabled in the BIOS has fixed my ethernet, wireless and USB2, so thank you very much for posting this.
    However now my USB3 ports are dead. This is a much better situation than before, but still not ideal.
    Sorry for being late to the party, but I just got the invitation (in the form of a motherboard).
    Full disclosure: I don't use ubuntu or wireless, but I ran into the same issues with fedora core 20 on a gigabyte GA-970A-D3P. I never got as far as trying "iommu=soft".
    The following got ethernet and all USB ports working for me; I hope it helps you. Or someone.
    Power down and unplug the network cable (remove wireless card also, I'd guess). Disable IOMMU, Save&Exit, Boot into the OS and then plug in the network cable. (For completeness: power down, reinsert wireless card, reboot.) No need to repeat any of this for subsequent reboots.

    Post 16 here: http://ubuntuforums.org/showthread.php?t=2111223&page=2 mentioned OS confusion with eth0/eth1 and nic/USB. Removing the network during USB setup apparently removed the confusion. That's my theory, anyway.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •