Results 1 to 2 of 2

Thread: Qt4 messing with keyboard: XMODIFIERS=""

Hybrid View

  1. #1
    Join Date
    Mar 2007
    Location
    Vancouver, Canada
    Beans
    97
    Distro
    Ubuntu 12.04 Precise Pangolin

    Qt4 messing with keyboard: XMODIFIERS=""

    In bashrc I set export XMODIFIERS="". When I start a Qt programme from an open terminal my international keyboard works (US international). On the other hand, if I start it from Nautilus with run, display, or run in terminal, the keystrokes are not interpreted correctly.

    Under language support, I have 'Keyboard input method system"= none.

    Is there a way to set XMODIFIERS generally, so that it remains "" however I launch the programme?

    I suspect this is an ibus problem, but I don't see how to fix it, since I believe I am not using ibus!

    Suggestions?

  2. #2
    Join Date
    Mar 2007
    Location
    Vancouver, Canada
    Beans
    97
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Qt4 messing with keyboard: XMODIFIERS=""

    I found the problem and what seems to be the solution.

    The problem: in qtconfig the input method was scim.
    The solution: in qtconfig, set the input method to ibus.

    The wrinkle: qtconfig window would be truncated by my screen resolution settings, so I had to set my screen to the highest resolution to be able to use qtconfig. Which is why I had not checked that earlier.

    (Will log a bug for qtconfig)

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •