Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: How to make compiz and kwin stable with PowerPC radeon UMS.

  1. #1
    Join Date
    Jan 2011
    Beans
    1,015

    How to make compiz and kwin stable with PowerPC radeon UMS.

    All, attached is a patched file that should improve the stability of those using opengl window managers in 12.04. Can people test it please?

    Instructions:

    Extract and save file to your home folder.

    Open a tty console with Ctrl+Alt+F1

    Login

    Stop the Xorg server (make sure you've saved any open files you're working on first): sudo stop lightdm

    Make a copy of the original: cp /usr/lib/xorg/modules/extensions/libglx.so libglx.so.original

    Copy new file into place: sudo cp libglx.so /usr/lib/xorg/modules/extensions/libglx.so

    Start Xorg server: sudo start lightdm
    Attached Files Attached Files

  2. #2
    Join Date
    Feb 2008
    Beans
    9

    Re: How to make compiz and kwin stable with PowerPC radeon UMS.

    I followed your directions and installed the new file in place, but cannot discern any appreciable difference.
    Are there any log files you would like to see or tests you would like done?
    I am using a Radeon 9800 Pro 128 4X AGP.
    CA
    Last edited by calexand; February 15th, 2013 at 09:33 PM. Reason: typso

  3. #3
    Join Date
    Feb 2008
    Beans
    9

    Re: How to make compiz and kwin stable with PowerPC radeon UMS.

    Ok now, finally! I have downgraded the mesa files down to version 7.11-0.3.2, then I added "radeon.modeset=0 video=radeonfb:1024x768-16@60" (no quotations) to the yaboot.conf file, both per the Official FAQ and WIKI. I then installed the above mentioned file in its' proper place.
    After battling software rasterizing for months, the combination of all of these things succeeded: glxgears shows over 5000!
    Thank you all who provided all the different instructions/fixes.

    Mods~Can this please be made "sticky"?

    CA
    Last edited by calexand; February 17th, 2013 at 01:34 AM.

  4. #4
    Join Date
    Jan 2011
    Beans
    1,015

    Re: How to make compiz and kwin stable with PowerPC radeon UMS.

    The patch is only really if you are using compiz or kwin (and possibly other opengl window managers although I haven't been able to run them on my iBook). If you are using lubuntu or xubuntu then you probably won't see any difference with the patch.

    I need to raise a launchpad bug and the reason I wanted people to test was so that they can confirm the bug and solution. It is much better to seek an official patch because I don't want to keep having to rebuild the xorg core package.

    You should try KMS before falling back to UMS. KMS is hit and miss on PowerPC hence my own interest in UMS.
    Last edited by rsavage; February 17th, 2013 at 09:53 AM.

  5. #5
    Join Date
    Jan 2011
    Beans
    1,015

    Re: How to make compiz and kwin stable with PowerPC radeon UMS.

    If you want to try out compiz and you are using something like lubuntu then the easiest thing is to use lucid's version. Change your sources temporarily to lucid and install compiz, emerald and compiz config setting manager (ccsm) etc. For ccsm you'll need the attached deb file. It is exactly the same as that used in lucid except built against the latest python (I probably should of bumped the package version number, but it was just going to be for my personal use). To get compiz run:

    Code:
    compiz --replace  ccp
    If you've compiled a later version of compiz then you may need:
    Code:
     
    LIBGL_ALWAYS_INDIRECT=1 compiz --replace ccp
    Compiz is pretty stable using the cairo window decorator. It is only when you change to a metacity (or marco) or emerald theme that it goes wrong (and what the patch in post 1 fixes). To select the metacity theme you want you may have to change a gconf setting (under apps > gwd) .
    Attached Files Attached Files

  6. #6
    Join Date
    Jan 2011
    Beans
    1,015

    Re: How to make compiz and kwin stable with PowerPC radeon UMS.

    I know I'm completely wasting my time here (you've all been brainwashed to use Lubuntu), but I would really appreciate it if you could confirm this bug https://bugs.launchpad.net/ubuntu/+s...r/+bug/1160903

    Thanks

  7. #7
    Join Date
    Feb 2008
    Beans
    9

    Re: How to make compiz and kwin stable with PowerPC radeon UMS.

    Actually, I am using Ubuntu with the Lubuntu de over the top. I am not having this particular problem, as far as I can tell, all is now alright. I even run Ubuntu de in 3D occasionally.
    CA

    Quote Originally Posted by rsavage View Post
    I know I'm completely wasting my time here (you've all been brainwashed to use Lubuntu), but I would really appreciate it if you could confirm this bug https://bugs.launchpad.net/ubuntu/+s...r/+bug/1160903

    Thanks
    Last edited by calexand; March 29th, 2013 at 12:48 AM. Reason: additional info...

  8. #8
    Join Date
    Jan 2011
    Beans
    1,015

    Re: How to make compiz and kwin stable with PowerPC radeon UMS.

    Your graphics card if better/newer than mine. If you can run the latest compiz/unity okay then could you think about maybe testing the latest 13.04 builds http://cdimage.ubuntu.com/daily-live/current/ . Without people testing them (and marking them as passed on the iso tracker) they can't be released (which is what happened to 12.10).

  9. #9
    Join Date
    Feb 2008
    Beans
    9

    Re: How to make compiz and kwin stable with PowerPC radeon UMS.

    Downloading now...
    CA

    Quote Originally Posted by rsavage View Post
    Your graphics card if better/newer than mine. If you can run the latest compiz/unity okay then could you think about maybe testing the latest 13.04 builds http://cdimage.ubuntu.com/daily-live/current/ . Without people testing them (and marking them as passed on the iso tracker) they can't be released (which is what happened to 12.10).

  10. #10
    Join Date
    Feb 2008
    Beans
    9

    Re: How to make compiz and kwin stable with PowerPC radeon UMS.

    I could not get 13.04 to run, it always froze at the white screen upon finding the display. I thought that it didn't like my "burn" even though I burned it at 4X, so I burned another at 1X speed, still a no go.
    I then thought that it didn't like my current video card, so I replaced it with my Radeon 8500 Mac: froze. I reset the CUDA and zapped the PRAM: froze.
    I tried every option that I could think of including "linux video=ofonly": same.
    I give up, apparently I cannot help... Sorry.
    CA

    Quote Originally Posted by calexand View Post
    Downloading now...
    CA

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •