Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: server 12.04 can't connect to MySQL

  1. #11
    Join Date
    Apr 2008
    Location
    LOCATION=/dev/random
    Beans
    5,767
    Distro
    Ubuntu Development Release

    Re: server 12.04 can't connect to MySQL

    Can you check if mysql is actually listening for connections on port 3306...
    Code:
    netstat -anp | grep -i mysql
    Cheesemill

  2. #12
    Join Date
    Nov 2007
    Location
    London, England
    Beans
    5,308
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: server 12.04 can't connect to MySQL

    I don't think that will show anything unless run with sudo because listing process names is privileged. Can I suggest this command:
    Code:
    netstat -lnt
    and look for port 3306. It should be listening on 0.0.0.0, not 127.0.0.1.

    After changing mysql.conf, you need to restart the mysql service for the change to take effect.

  3. #13
    Join Date
    Sep 2011
    Location
    the Netherlands
    Beans
    66
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: server 12.04 can't connect to MySQL

    Unfortunately I need to connect from a windows machine, I could test it from an ubuntu machine though, but I don't have it here now..

    Output for netstat -anp | grep -i mysql

    Code:
    tcp        0      0 127.0.0.1:3306          0.0.0.0:*               LISTEN      7695/mysqld
    unix  2      [ ACC ]     STREAM     LISTENING     19040    7695/mysqld         /var/run/mysqld/mysqld.sock
    Output for netstat -lnt

    Code:
    Active Internet connections (only servers)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State
    tcp        0      0 127.0.0.1:3306          0.0.0.0:*               LISTEN
    tcp        0      0 0.0.0.0:139             0.0.0.0:*               LISTEN
    tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN
    tcp        0      0 0.0.0.0:1105            0.0.0.0:*               LISTEN
    tcp        0      0 0.0.0.0:445             0.0.0.0:*               LISTEN
    tcp6       0      0 :::1105                 :::*                    LISTEN
    I have tried connecting via LibreOffice directly using the openoffice mysql-connector but that doesn't connect either..
    [Please come back to the ubuntuforums..] [Please mark as solved..]

  4. #14
    Join Date
    Apr 2008
    Location
    LOCATION=/dev/random
    Beans
    5,767
    Distro
    Ubuntu Development Release

    Re: server 12.04 can't connect to MySQL

    Quote Originally Posted by bart.a View Post
    Code:
    Active Internet connections (only servers)
    Proto Recv-Q Send-Q Local Address           Foreign Address         State
     tcp        0      0 127.0.0.1:3306          0.0.0.0:*               LISTEN
    tcp        0      0 0.0.0.0:139             0.0.0.0:*               LISTEN
    tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN
    tcp        0      0 0.0.0.0:1105            0.0.0.0:*               LISTEN
    tcp        0      0 0.0.0.0:445             0.0.0.0:*               LISTEN
    tcp6       0      0 :::1105                 :::*                    LISTEN
    This line seems to say that mysql is only listening on localhost.

    Can you post the contents of your /etc/mysql/my.cnf please.
    Cheesemill

  5. #15
    Join Date
    Sep 2011
    Location
    the Netherlands
    Beans
    66
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: server 12.04 can't connect to MySQL

    Output /etc/mysql/my.cnf

    Code:
    #
    # The MySQL database server configuration file.
    #
    # You can copy this to one of:
    # - "/etc/mysql/my.cnf" to set global options,
    # - "~/.my.cnf" to set user-specific options.
    #
    # One can use all long options that the program supports.
    # Run program with --help to get a list of available options and with
    # --print-defaults to see which it would actually understand and use.
    #
    # For explanations see
    # http://dev.mysql.com/doc/mysql/en/server-system-variables.html
    
    # This will be passed to all mysql clients
    # It has been reported that passwords should be enclosed with ticks/quotes
    # escpecially if they contain "#" chars...
    # Remember to edit /etc/mysql/debian.cnf when changing the socket location.
    [client]
    port            = 3306
    socket          = /var/run/mysqld/mysqld.sock
    
    # Here is entries for some specific programs
    # The following values assume you have at least 32M ram
    
    # This was formally known as [safe_mysqld]. Both versions are currently parsed.
    [mysqld_safe]
    socket          = /var/run/mysqld/mysqld.sock
    nice            = 0
    
    [mysqld]
    #
    # * Basic Settings
    #
    user            = mysql
    pid-file        = /var/run/mysqld/mysqld.pid
    socket          = /var/run/mysqld/mysqld.sock
    port            = 3306
    basedir         = /usr
    datadir         = /var/lib/mysql
    tmpdir          = /tmp
    lc-messages-dir = /usr/share/mysql
    skip-external-locking
    #
    # Instead of skip-networking the default is now to listen only on
    # localhost which is more compatible and is not less secure.
    # bind-address          = 127.0.0.1
    #
    # * Fine Tuning
    #
    key_buffer              = 16M
    max_allowed_packet      = 16M
    thread_stack            = 192K
    thread_cache_size       = 8
    # This replaces the startup script and checks MyISAM tables if needed
    # the first time they are touched
    myisam-recover         = BACKUP
    #max_connections        = 100
    #table_cache            = 64
    #thread_concurrency     = 10
    #
    # * Query Cache Configuration
    #
    query_cache_limit       = 1M
    query_cache_size        = 16M
    #
    # * Logging and Replication
    #
    # Both location gets rotated by the cronjob.
    # Be aware that this log type is a performance killer.
    # As of 5.1 you can enable the log at runtime!
    #general_log_file        = /var/log/mysql/mysql.log
    #general_log             = 1
    #
    # Error logging goes to syslog due to /etc/mysql/conf.d/mysqld_safe_syslog.cnf.
    #
    # Here you can see queries with especially long duration
    #log_slow_queries       = /var/log/mysql/mysql-slow.log
    #long_query_time = 2
    #log-queries-not-using-indexes
    #
    # The following can be used as easy to replay backup logs or for replication.
    # note: if you are setting up a replication slave, see README.Debian about
    #       other settings you may need to change.
    #server-id              = 1
    #log_bin                        = /var/log/mysql/mysql-bin.log
    expire_logs_days        = 10
    max_binlog_size         = 100M
    #binlog_do_db           = include_database_name
    #binlog_ignore_db       = include_database_name
    #
    # * InnoDB
    #
    # InnoDB is enabled by default with a 10MB datafile in /var/lib/mysql/.
    # Read the manual for more InnoDB related options. There are many!
    #
    # * Security Features
    #
    # Read the manual, too, if you want chroot!
    # chroot = /var/lib/mysql/
    #
    # For generating SSL certificates I recommend the OpenSSL GUI "tinyca".
    #
    # ssl-ca=/etc/mysql/cacert.pem
    # ssl-cert=/etc/mysql/server-cert.pem
    # ssl-key=/etc/mysql/server-key.pem
    
    
    
    [mysqldump]
    quick
    quote-names
    max_allowed_packet      = 16M
    
    [mysql]
    #no-auto-rehash # faster start of mysql but no tab completition
    
    [isamchk]
    key_buffer              = 16M
    
    #
    # * IMPORTANT: Additional settings that can override those from this file!
    #   The files must end with '.cnf', otherwise they'll be ignored.
    #
    !includedir /etc/mysql/conf.d/
    [Please come back to the ubuntuforums..] [Please mark as solved..]

  6. #16
    Join Date
    Sep 2011
    Location
    the Netherlands
    Beans
    66
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: server 12.04 can't connect to MySQL

    PROBLEM SOLVED!!

    Thanks guys for all your efforts and pointing me in the right direction! I really appreciate it!

    The bind-address in my.cnf was just commented out..
    I removed the comment and set the bind-address to the servers (static) IP-address..

    Now I can connect to the dbases from LibreOffice out of every workstation like before..

    Thanks again for your efforts!!
    [Please come back to the ubuntuforums..] [Please mark as solved..]

  7. #17
    Join Date
    Apr 2008
    Location
    LOCATION=/dev/random
    Beans
    5,767
    Distro
    Ubuntu Development Release

    Re: server 12.04 can't connect to MySQL

    How strange.

    The default behaviour if bind-address is commented out is to listen on all available interfaces.

    This is why I suggested it as a solution in my first post.
    Cheesemill

  8. #18
    Join Date
    Nov 2007
    Location
    Newry, Northern Ireland
    Beans
    1,192

    Re: server 12.04 can't connect to MySQL

    Binding mysqld to the 192.168.1.x address may have some unexpected consequences....

    Anything requiring a localhost connection, like phpmyadmin or the debian syst maintenance user will not be able to connect unless they use the Unix socket.

    You could change the bind-address to 0.0.0.0 to listen on all interfaces.
    Can't think of anything profound or witty.
    My Blog: http://gonzothegeek.blogspot.co.uk/

  9. #19
    Join Date
    Sep 2011
    Location
    the Netherlands
    Beans
    66
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: server 12.04 can't connect to MySQL

    I tried it and phpmyadmin and libreoffice both connect just fine with the bind-address set to either the servers IP-address or 0.0.0.0

    So the best option would be to set the bind-address to 0.0.0.0 , right?
    [Please come back to the ubuntuforums..] [Please mark as solved..]

  10. #20
    Join Date
    Nov 2007
    Location
    Newry, Northern Ireland
    Beans
    1,192

    Re: server 12.04 can't connect to MySQL

    Quote Originally Posted by bart.a View Post
    I tried it and phpmyadmin and libreoffice both connect just fine with the bind-address set to either the servers IP-address or 0.0.0.0

    So the best option would be to set the bind-address to 0.0.0.0 , right?
    It will definitely mean that mysql will be listening on all interfaces, yes.
    Can't think of anything profound or witty.
    My Blog: http://gonzothegeek.blogspot.co.uk/

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •