Page 3 of 3 FirstFirst 123
Results 21 to 26 of 26

Thread: Can't get wireless network to work

  1. #21
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    21,280
    Distro
    Ubuntu 15.04 Vivid Vervet

    Re: Can't get wireless network to work

    If you have read a few of the many other threads about this device, you will see that 64-bit is hit or miss; some report it works fine, some report it never works. I haven't been able to spot a pattern yet. You have:
    kernel: 3.5.0-22-generic (x86_64)
    Which of the many inf files floating around on the forum did you download and install? We might try another, such as attached. It would involve removing what you have now:
    Code:
    sudo nidiswrapper -e bcmwlhigh5
    sudo rm -rf /etc/ndiswrapper/*
    Then install the files from this package.
    Code:
    cd Skrivbord/Broadcom_bcm43xx_USB_32_64bit_v2_amended
    sudo ndiswrapper -i bcmn43xx64.inf
    sudo modprobe -r ndiswrapper
    sudo modprobe ndiswrapper
    ...assuming you've downloaded the file to your desktop and extracted it there.

    I also wonder if the creaky old Windows XP driver has trouble with N speeds. Is 802.11N enabled in your router? If you disable it, can you connect?
    Attached Files Attached Files
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  2. #22
    Join Date
    Oct 2012
    Location
    Sweden
    Beans
    21
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Can't get wireless network to work

    Quote Originally Posted by chili555 View Post
    If you have read a few of the many other threads about this device, you will see that 64-bit is hit or miss; some report it works fine, some report it never works. I haven't been able to spot a pattern yet. You have: Which of the many inf files floating around on the forum did you download and install? We might try another, such as attached. It would involve removing what you have now:
    Code:
    sudo nidiswrapper -e bcmwlhigh5
    sudo rm -rf /etc/ndiswrapper/*
    Then install the files from this package.
    Code:
    cd Skrivbord/Broadcom_bcm43xx_USB_32_64bit_v2_amended
    sudo ndiswrapper -i bcmn43xx64.inf
    sudo modprobe -r ndiswrapper
    sudo modprobe ndiswrapper
    ...assuming you've downloaded the file to your desktop and extracted it there.

    I also wonder if the creaky old Windows XP driver has trouble with N speeds. Is 802.11N enabled in your router? If you disable it, can you connect?
    This is the one I downloaded.

    I removed the old one, and when installing the new one (had to specify exact directory, else it would just keep looking in /usr/sbin/ndiswrapper) it gave me this error:
    Code:
    couldn't find SourceDisksFiles section - continuing anyway...
    It then came up with the same crap as before, listing the networks, tries to connect but then just tells me the password is incorrect.

    Also I have no idea how to disable 802.11N speeds, or if I even have it.
    This is the router I have, if it helps you in any way.

    A thought I just got, is... does this wireless adapter support WPA-PSK/WPA2-PSK security?

  3. #23
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    21,280
    Distro
    Ubuntu 15.04 Vivid Vervet

    Re: Can't get wireless network to work

    I'm fairly certain it does support the common encryption modes. Find out:
    Code:
    sudo iwlist wlan0 auth
    Your router certainly does N speeds. Look in the administration pages in Wireless > Mode. Here is a screenshot from the User Guide. I suggest, as a trial, you select 11bg mixed; that is, not N.
    Attached Images Attached Images
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  4. #24
    Join Date
    Oct 2012
    Location
    Sweden
    Beans
    21
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Can't get wireless network to work

    Quote Originally Posted by chili555 View Post
    I'm fairly certain it does support the common encryption modes. Find out:
    Code:
    sudo iwlist wlan0 auth
    Your router certainly does N speeds. Look in the administration pages in Wireless > Mode. Here is a screenshot from the User Guide. I suggest, as a trial, you select 11bg mixed; that is, not N.
    Found the option, and it's set to 11bgn right now.
    I'll look more into this tomorrow, as it is midnight right now, and I do not currently have access to the computer.

  5. #25
    Join Date
    Oct 2012
    Location
    Sweden
    Beans
    21
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Can't get wireless network to work

    Quote Originally Posted by chili555 View Post
    I'm fairly certain it does support the common encryption modes. Find out:
    Code:
    sudo iwlist wlan0 auth
    Your router certainly does N speeds. Look in the administration pages in Wireless > Mode. Here is a screenshot from the User Guide. I suggest, as a trial, you select 11bg mixed; that is, not N.
    I've been quite busy, but now finally got some time to get back into this.

    Anyway, I tried changing it to 11bg mixed, and bam it works!
    http://fuskbugg.se/file/WY62sj/Skrmb...6%20131852.png
    Is there anything else than the speed I'll loose by choosing to use this? (Doesn't really matter as it's just my phone, laptop and mom's computer using the wireless, but still...)

    Thanks for all the help by the way, pretty rare to find such nice and helpful people out there!
    Last edited by DerpishCat; February 6th, 2013 at 01:29 PM. Reason: Realized pic was huge, so linking it instead

  6. #26
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    21,280
    Distro
    Ubuntu 15.04 Vivid Vervet

    Re: Can't get wireless network to work

    Is there anything else than the speed I'll loose by choosing to use this?
    None that I am aware of. N speeds are mainly useful to stream video, etc. over a network. Very few of us have an internet connection where 54 Mb/s, the maximum afforded by 802.11G, is insufficient. There are, of course, exceptions.
    Thanks for all the help by the way, pretty rare to find such nice and helpful people out there!
    Thank you for your very kind words. I had trouble finding any help of any kind when I started in Linux 200 years ago. I vowed to help as much as I could if I ever could.

    I'm very glad it's working! Your experience added data to the knowledge base: ndiswrapper, WNA3100 and 802.11N probably doesn't work.

    Would you please use thread tools at the top to mark solved. The searchers will appreciate it.

    Finally, in post #16, we had to compile ndiswrapper from source. Every time you get a new kernel version, also known as linux-image, you'll need to re-compile:
    Code:
    cd Skrivbord/ndiswrapper-1.58rc1
    sudo su
    make clean
    make
    make install
    modprobe ndiswrapper
    exit
    Please retain these instructions and the ndiswrapper-1.58rc1 folder for that day.

    Have fun!
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

Page 3 of 3 FirstFirst 123

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •