Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: How to activate DBus-interface in the VLC media-player?

  1. #1
    Join Date
    Jan 2006
    Location
    Grønland,Oslo
    Beans
    618

    How to activate DBus-interface in the VLC media-player?

    EDIT: This issue was solved by updating VLC from a PPA (package archive).
    Ref: https://launchpad.net/~videolan/+archive/master-daily
    Let's hope Ubuntu will update its final version of VLC from this PPA.
    ------------------

    Hello,
    How do I activate DBus-interface in the VLC media-player?
    I want VLC to show up in the sound-menu. Also audio-recorder needs messages from the DBus.

    Earlier it was easy to set via VLC's menu:
    Tools -> Preferences -> Show all -> Interface -> Control Interface and Enable DBus.

    But I cannot find this option anymore.

    $ cat /etc/issue
    Ubuntu Raring Ringtail (development branch) \n \l

    $ vlc --version
    VLC media player 2.0.5 Twoflower (revision 2.0.5-0-g1661b7d)

    Audio-recorder:
    https://launchpad.net/audio-recorder
    Last edited by moma; February 6th, 2013 at 10:35 PM.

  2. #2
    Join Date
    Oct 2008
    Location
    ExodusHair<Čubura
    Beans
    4,115
    Distro
    Ubuntu Development Release

    Re: How to activate DBus-interface in the VLC media-player?

    Quote Originally Posted by moma View Post
    Hello,
    How do I activate DBus-interface in the VLC media-player?
    I want VLC to show up in the sound-menu. Also audio-recorder needs messages from the DBus.

    Earlier it was easy to set via VLC's menu:
    Tools -> Preferences -> Show all -> Interface -> Control Interface and Enable DBus.

    But I cannot find this option anymore.

    $ cat /etc/issue
    Ubuntu Raring Ringtail (development branch) \n \l

    $ vlc --version
    VLC media player 2.0.5 Twoflower (revision 2.0.5-0-g1661b7d)

    Audio-recorder:
    https://launchpad.net/audio-recorder
    Is it:
    Code:
    /usr/bin/vlc -I dummy --control dbus
    ...?
    I've just checked and it is open by default in GS...
    Last edited by zika; February 2nd, 2013 at 08:10 PM.

  3. #3
    Join Date
    Jun 2007
    Beans
    13,590

    Re: How to activate DBus-interface in the VLC media-player?

    it should be auto-enabled. If not then do so in in dconf (dconf-editor >
    com.canonical.indicator.sound interested-media-players

    (sometimes in lieu of above just opening vlc > tools > preferences, changing anything & saving that change will add vlc to sound menu next time opened

    edit: for reference - http://forum.videolan.org/viewtopic.php?f=13&t=107797
    Last edited by mc4man; February 2nd, 2013 at 08:24 PM.

  4. #4
    Join Date
    Jan 2006
    Location
    Grønland,Oslo
    Beans
    618

    Re: How to activate DBus-interface in the VLC media-player?

    Ok, thank you.

    This works fine:
    $ vlc --control dbus
    Sound-menu now shows all controls for VLC. Good.
    Audio-recorder also receives correct messages form VLC.

    But when I close VLC, the sound-menu still (correctly) displays "VLC media player". If I start VLC from it, the player obviously fires without "--control dbus" option and looses its Dbus-capability (and the controls won't work).

    VLC should absolutely have a permanent option for the sound-menu (for the DBus). This is not going to work. Something has gone wrong.

    Many applications except to see MPRIS2-messages (like org.mpris.MediaPlayer2.vlc) on the DBus.

    @mc4man: Thanks for the link. That explains a lot.
    "vlc" is already in the interested-media-players list. I even tried "vlc --control dbus".
    Last edited by moma; February 2nd, 2013 at 09:01 PM.

  5. #5
    Join Date
    Jun 2007
    Beans
    13,590

    Re: How to activate DBus-interface in the VLC media-player?

    You could test some of the simple (supported??) with either types -
    Ex.'s, add a few tracks to vlc

    Code:
    qdbus org.mpris.MediaPlayer2.vlc /org/mpris/MediaPlayer2 org.mpris.MediaPlayer2.Player.Play
    qdbus org.mpris.MediaPlayer2.vlc /org/mpris/MediaPlayer2 org.mpris.MediaPlayer2.Player.Pause
    ect.

    or the variant -
    Code:
    dbus-send --print-reply --dest=org.mpris.MediaPlayer2.vlc /org/mpris/MediaPlayer2 org.mpris.MediaPlayer2.Player.Next
    dbus-send --print-reply --dest=org.mpris.MediaPlayer2.vlc /org/mpris/MediaPlayer2 org.mpris.MediaPlayer2.Player.Previous
    ect.

  6. #6
    Join Date
    Jan 2006
    Location
    Grønland,Oslo
    Beans
    618

    Re: How to activate DBus-interface in the VLC media-player?

    Hello,
    The commands of course fail when VLC is started without DBus-interface.
    $ vlc

    $ qdbus org.mpris.MediaPlayer2.vlc /org/mpris/MediaPlayer2 org.mpris.MediaPlayer2.Player.Stop

    Service 'org.mpris.MediaPlayer2.vlc' does not exist.
    etc. many similar error messages.
    ------------

    The commands works well if VLC is started with --control dbus.
    $ vlc --control dbus

    $ qdbus org.mpris.MediaPlayer2.vlc /org/mpris/MediaPlayer2 org.mpris.MediaPlayer2.Player.Play

    All these work: Play,Stop,Pause,Next,Previous

    Also this:
    $ qdbus org.mpris.MediaPlayer2.vlc /org/mpris/MediaPlayer2 org.mpris.MediaPlayer2.Quit
    -------------

    So the question is: Will Ubuntu 13.04 come with VLC whose DBus-interface is auto-enabled? This is a very important issue. VLC cannot integrate with Unity (and its sound-menu or audio-recorder of all!) without DBus.
    Last edited by moma; February 2nd, 2013 at 09:00 PM.

  7. #7
    Join Date
    Jun 2007
    Beans
    13,590

    Re: How to activate DBus-interface in the VLC media-player?

    Quote Originally Posted by moma View Post
    So VLC should absolutely have a permanent option for the sound-menu (for the DBus). This is not going to work. Something has gone wrong.

    Many applications except to see MPRIS2-messages (like org.mpris.MediaPlayer2.vlc) on the DBus.

    @mc4man: Thanks for the link. That explains a lot.
    "vlc" is already in the interested-media-players list. I even tried "vlc --control dbus".
    Vlc is permanent here, only seen as 'vlc', in dconf (screen

    have you tried a log out after adding to dconf?
    Attached Images Attached Images

  8. #8
    Join Date
    Jan 2006
    Location
    Grønland,Oslo
    Beans
    618

    Re: How to activate DBus-interface in the VLC media-player?

    Re-hi,
    Yes, I just did re-login. The login-screen has started to speak

    No change. The "vlc" command itself fails to activate DBus. So does the sound-menu.



    I have installed various media-players to test the audio-recorder for Raring. Looks good.
    EOL.
    Last edited by moma; February 2nd, 2013 at 09:19 PM.

  9. #9
    Join Date
    Jun 2007
    Beans
    13,590

    Re: How to activate DBus-interface in the VLC media-player?

    Try a little experiment -
    (you could use a hatchet job on your current user, ie. move ~/.config/dconf/user to a .bak, & remove ~/.config/vlc/vlcrc, log out/in, ect. but try instead -

    Set up a new user (apologizes for gnome dev's thinking a 9 char password is needed..
    Log in to new user, open vlc > tools > pref's, enable something like 'one instance', save, close vlc.
    log out/in, is vlc in the sound menu?

  10. #10
    Join Date
    Oct 2008
    Location
    ExodusHair<Čubura
    Beans
    4,115
    Distro
    Ubuntu Development Release

    Re: How to activate DBus-interface in the VLC media-player?

    Quote Originally Posted by moma View Post
    So the question is: Will Ubuntu 13.04 come with VLC whose DBus-interface is auto-enabled? This is a very important issue. VLC cannot integrate with Unity (and its sound-menu or audio-recorder of all!) without DBus.
    It does on this machine... As I said already...

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •