Results 1 to 10 of 16

Thread: Installing B43 legacy drivers in Xubuntu

Hybrid View

  1. #1
    Join Date
    Jan 2013

    Installing B43 legacy drivers in Xubuntu

    I'm new to Linux and I found out that after my installation of Xubuntu 12.04, my wireless card was not being detected by Xubuntu. I found out that there are some drivers that I need to install in order for my wireless card to be detected. I found out that my type of card requires a b43legacy driver. I am wondering how to install these drivers and also where to get the exact file(s). I have also heard that if I am connected via ethernet cable, I can simply install "additional drivers". Is this true?

  2. #2
    Join Date
    Apr 2011
    3rd Rock from the Sun
    Ubuntu Development Release

    Re: Installing B43 legacy drivers in Xubuntu

    Yes, if you have ethernet cable or any other internet for that matter you can install "additional drivers". I would recommend that you search this forum for b43 issues, a lots of related issues have been addressed before.

    Also you might find more info here.
    "Evolution is Nature's way of issuing upgrades."

  3. #3
    Join Date
    Feb 2008
    Planet earth, for now.

    Re: Installing B43 legacy drivers in Xubuntu

    Thread moved to Networking & Wireless

    Welcome to the forums. Please provide the output of:

    sudo lshw -C network
    If there is nothing in Additional Drivers (which is already there and looks for available drivers, you don't need to install Additional Drivers but the drivers it finds) get online with a cable and try installing b43-fwcutter and firmware-b43legacy-installer which can be found in Synaptics then restart.

    If that doesn't work, try uninstalling firmware-b43legacy-installer and installing firmware-b43-installer. We'll know more when you provide the output I've asked for.
    Last edited by Bucky Ball; January 30th, 2013 at 04:13 PM.

  4. #4
    Join Date
    Jan 2013

    Re: Installing B43 legacy drivers in Xubuntu

    description: Ethernet interface
    product: NetXtreme BCM5702X Gigabit Ethernet
    vendor: Broadcom Corporation
    physical id: 0
    bus info: pci@0000:02:00.0
    logical name: eth0
    version: 02
    serial: 00:0d:56:df:df:52
    size: 1Gbit/s
    capacity: 1Gbit/s
    width: 64 bits
    clock: 66MHz
    capabilities: pcix pm vpd msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
    configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.121 duplex=full firmware=5702-v2.25 ip= latency=64 link=yes mingnt=64 multicast=yes port=twisted pair speed=1Gbit/s
    resources: irq:11 memory:faff0000-faffffff
    description: Network controller
    product: BCM4306 802.11a/b/g
    vendor: Broadcom Corporation
    physical id: 3
    bus info: pci@0000:02:03.0
    version: 02
    width: 32 bits
    clock: 33MHz
    capabilities: pm bus_master cap_list
    configuration: driver=wl latency=32
    resources: irq:5 memory:fafee000-fafeffff

    This is what came up. I have tried installing additional drivers and it gave me STA Proprietary Driver, I clicked activate and it started installing, after a minute or sol the screen went black and information popped up, not sure what it said. Nothing happened for a while and the only way to exit was to power off the computer. Back in Xubuntu I clicked on additional drivers once again and there were no drivers detected this time.

  5. #5
    Join Date
    Jan 2013

    Re: Installing B43 legacy drivers in Xubuntu

    Update: I reinstalled Xubuntu altogether and immediately went to Additional Drivers, where I proceeded to activate the STA driver. Once again near the end of the installation the black screen with the words on it came up, it did not look like an error message at all but there was no way I could get out of the screen or finish the installation. I then used this command: sudo apt-get install firmware-b43legacy-installer, which worked, but when I go to Additional Drivers, nothing pops up for me to install. I'm really confused as to what I'm supposed to do.

    This is what I ran:
    ashton@Ashton-Latitude-D600:~$ sudo apt-get install firmware-b43legacy-installer[sudo] password for ashton:
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following extra packages will be installed:
    The following NEW packages will be installed:
    b43-fwcutter firmware-b43legacy-installer
    0 upgraded, 2 newly installed, 0 to remove and 230 not upgraded.
    Need to get 21.9 kB of archives.
    After this operation, 109 kB of additional disk space will be used.
    Do you want to continue [Y/n]? Y
    Get:1 precise/main b43-fwcutter i386 1:015-9 [18.9 kB]
    Get:2 precise/multiverse firmware-b43legacy-installer all 1:015-9 [3,000 B]
    Fetched 21.9 kB in 0s (54.3 kB/s)
    Selecting previously unselected package b43-fwcutter.
    (Reading database ... 128224 files and directories currently installed.)
    Unpacking b43-fwcutter (from .../b43-fwcutter_1%3a015-9_i386.deb) ...
    Selecting previously unselected package firmware-b43legacy-installer.
    Unpacking firmware-b43legacy-installer (from .../firmware-b43legacy-installer_1%3a015-9_all.deb) ...
    Processing triggers for man-db ...
    Setting up b43-fwcutter (1:015-9) ...
    Setting up firmware-b43legacy-installer (1:015-9) ...
    No chroot environment found. Starting normal installation
    --2013-01-30 15:13:51--
    Resolving (
    Connecting to (||:80... connected.
    HTTP request sent, awaiting response... 200 OK
    Length: 652866 (638K) [application/octet-stream]
    Saving to: `wl_apsta-'

    100%[======================================>] 652,866 400K/s in 1.6s

    2013-01-30 15:13:58 (400 KB/s) - `wl_apsta-' saved [652866/652866]

    This file is recognised as:
    filename : wl_apsta.o
    version : 295.14
    MD5 : e08665c5c5b66beb9c3b2dd54aa80cb3
    Extracting b43legacy/ucode2.fw
    Extracting b43legacy/ucode4.fw
    Extracting b43legacy/ucode5.fw
    Extracting b43legacy/ucode11.fw
    Extracting b43legacy/pcm4.fw
    Extracting b43legacy/pcm5.fw
    Extracting b43legacy/a0g0bsinitvals2.fw
    Extracting b43legacy/b0g0bsinitvals5.fw
    Extracting b43legacy/a0g0initvals5.fw
    Extracting b43legacy/a0g1bsinitvals5.fw
    Extracting b43legacy/a0g0initvals2.fw
    Extracting b43legacy/a0g1initvals5.fw
    Extracting b43legacy/b0g0bsinitvals2.fw
    Extracting b43legacy/b0g0initvals5.fw
    Extracting b43legacy/b0g0initvals2.fw
    Extracting b43legacy/a0g0bsinitvals5.fw
    Last edited by D0wnp0ur; January 30th, 2013 at 08:29 PM.

  6. #6
    Join Date
    Mar 2011
    19th Hole
    Ubuntu 13.10 Saucy Salamander

    Re: Installing B43 legacy drivers in Xubuntu

    The STA driver will not work with your broadcom chip and, in fact, must be blacklisted so that it doesn't capture the system resources needed by b43legacy. The BCM4306 chip is frankly a royal pain in the neck. I have a couple of old laptops that use this chip and must go through the same-old-same-old for every install. To do the following, you must be connected by ethernet cable. These steps will not work without a wired connection. These steps must be done in order and to completion. Skipping any step will gum up the works and require that you start over from the beginning.

    1. bring up "additional drivers" and disable the sta driver. Your b43 legacy driver cannot be installed that way.

    2. do:
    echo "blacklist sta" | sudo tee -a /etc/modprobe.d/blacklist.conf
    3. Then:
    echo "blacklist wl" | sudo tee -a /etc/modprobe.d/blacklist.conf
    These two steps will blacklist competing incompatible drivers.

    4. Then open synaptic package manager and search for bcm. Mark every already checkmarked box and tag for removal. Apply.

    5. Reboot

    6. Do:
    lspci -vvnn | grep 14e4
    7. The output will consist of one or two network cards, depending on whether your wired ethernet card is also a broadcom. We are not interested in the wired card. Look instead for the reference that contains BCM4306. The important number in this reference are the four digits immediately following "14ef:" If they are any of:
    then we must install b43legacy. If they are anything else, then we must install b43 (not legacy).

    8. Run synaptic again. Search using bcm. Check the box "b43-fwcutter" for installation. Then, based on the results from step #7, check either firmware-b43-installer or firmware-b43legacy-installer for installation. Do not check both. You must choose one or the other based on the results from step #7.

    9. Reboot

    10. To check, do:
    lsmod | grep b43
    This should return a nubmer of lines showing the b43 and variants are now residing as kernel modules.

    11. To check that sta and wl are no longer gumming up the works, do:
    lsmod | grep -w sta | grep -w wl
    This should return nothing. Your wireless should now be working. If not post back to this forum and we will try more troubleshooting.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts