Results 1 to 9 of 9

Thread: toshiba satellite w/ atheros running 12.04--no wifi

Hybrid View

  1. #1
    Join Date
    Jan 2013
    Beans
    4

    toshiba satellite w/ atheros running 12.04--no wifi

    I just installed ubuntu 12.04, and although I can get online with an ethernet cord, I have no wifi access.
    I've run most of the code provided in this post. I'd be happy to give details, but this is what seems most important to me:
    $lspci gives me a bunch of entries, including one for 02:00.0 Ethernet controller (it's an Atheros AR8152 v 1.1 if you're interested) but no wifi controller or anything.
    $iwconfig returns lo and eth0, both with "no wireless extensions."
    ndiswrapper is installed.
    I installed ndisgtk and it says I have no wireless drivers.
    I'm kind of lost and this is a pain, so if you have any ideas I'd appreciate it.

  2. #2
    Join Date
    Jul 2005
    Beans
    2,048

    Re: toshiba satellite w/ atheros running 12.04--no wifi

    Quote Originally Posted by happyturtle View Post
    I just installed ubuntu 12.04, and although I can get online with an ethernet cord, I have no wifi access.
    I've run most of the code provided in this post. I'd be happy to give details,
    Yes, please provide the outputs of the commands given in that post.

  3. #3
    Join Date
    Feb 2008
    Location
    Funky Town, AUS
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: toshiba satellite w/ atheros running 12.04--no wifi

    Welcome to the forums. Please provide the output of:

    Code:
    sudo lshw -C network
    That is a very old thread you have linked to (over four years) and the information given could well be (is probably) obsolete. ndiswrapper is largely superseded. Did you do an update with the cable then check Additional Drivers?

    With ndiswrapper installed and the wrong driver you won't have much luck getting anything else to work.

    Please provide the output of the command I have provided and that should give us the card and what you have installed for it along with other info.
    Last edited by Bucky Ball; January 30th, 2013 at 03:21 AM.

  4. #4
    Join Date
    Jan 2013
    Beans
    13

    Re: toshiba satellite w/ atheros running 12.04--no wifi

    Quote Originally Posted by happyturtle View Post
    I just installed ubuntu 12.04, and although I can get online with an ethernet cord, I have no wifi access.
    I've run most of the code provided in this post. I'd be happy to give details, but this is what seems most important to me:
    $lspci gives me a bunch of entries, including one for 02:00.0 Ethernet controller (it's an Atheros AR8152 v 1.1 if you're interested) but no wifi controller or anything.
    $iwconfig returns lo and eth0, both with "no wireless extensions."
    ndiswrapper is installed.
    I installed ndisgtk and it says I have no wireless drivers.
    I'm kind of lost and this is a pain, so if you have any ideas I'd appreciate it.
    ok...do you have wifi on your windows? if you have it, boot back into windows to find your wireless card type. then record it down. boot back into ubuntu, and use a ethernet connection to visit linuxwireless.org, and that is a good website to find most of your drivers. find your driver, open a terminal, follow the instructions for ubuntu, reboot and hope your wifi will work!
    and also, remove ndiswrapper. i tried it out but it never works and i dont know why. it will also crash with the driver provided on linuxwireless.org. also do a sudo apt-get update before doing anything.

    thanks!
    Last edited by AngJinhang; January 30th, 2013 at 04:02 AM. Reason: forgot to type in something

  5. #5
    Join Date
    Feb 2008
    Location
    Funky Town, AUS
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: toshiba satellite w/ atheros running 12.04--no wifi

    Quote Originally Posted by AngJinhang View Post
    ok...do you have wifi on your windows? if you have it, boot back into windows to find your wireless card type.
    I have already provided a command to find this information and a lot more while in Ubuntu in the post directly above yours. Please read all posts, not just the first one, to avoid repitition. Thanks.

  6. #6
    Join Date
    Jan 2013
    Beans
    4

    Re: toshiba satellite w/ atheros running 12.04--no wifi

    sudo lshw -C network:
    *-network
    description: Ethernet interface
    product: AR8152 v1.1 Fast Ethernet
    vendor: Atheros Communications Inc.
    physical id: 0
    bus info: pci@0000:02:00.0
    logical name: eth0
    version: c1
    serial: c8:0a:a9:65:60:0e
    size: 100Mbit/s
    capacity: 100Mbit/s
    width: 64 bits
    clock: 33MHz
    capabilities: pm msi pciexpress vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation
    configuration: autonegotiation=on broadcast=yes driver=atl1c driverversion=1.0.1.0-NAPI duplex=full firmware=N/A ip=192.168.10.160 latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
    resources: irq:42 memory:f2000000-f203ffff ioport:6000(size=128)

    Also: I did install updates, but the only thing under additional drivers is a graphics driver.

  7. #7
    Join Date
    Jan 2013
    Beans
    4

    Re: toshiba satellite w/ atheros running 12.04--no wifi

    Can anyone help me with this problem?

  8. #8
    Join Date
    Jul 2005
    Beans
    2,048

    Re: toshiba satellite w/ atheros running 12.04--no wifi

    Please provide the outputs requested from this post:

    http://ubuntuforums.org/showthread.php?p=6183681

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •