Results 1 to 4 of 4

Thread: Shotwell will not launch

  1. #1
    Join Date
    Jan 2013
    Beans
    2

    Shotwell will not launch

    Installed Shotwell and was importing library when system crashed. Now Shotwell wont launch. Tried removing and reinstalling but no joy. Runs when i sudo shotwell but when i run in terminal i get the following

    shotwell
    cp: cannot stat `/home/john/.shotwell/data/photo.db.bak': No such file or directory
    **
    ERROR:/build/buildd/shotwell-0.12.3/src/db/VersionTable.vala:18:version_table_construct: assertion failed: (_tmp3_ == SQLITE_OK)
    Aborted (core dumped)


    Any ideas for a beginer???

  2. #2
    Join Date
    Jul 2005
    Location
    England
    Beans
    13,518

    Re: Shotwell will not launch

    Try removing the hidden /home/john/.shotwell folder and everything in it, then see if shotwell will start. You will have to re-import all your pictures again, which can take an age in my experience, which is one of the many reasons why I prefer digikam, even in gnome.
    DISTRO: Xubuntu 12.04-64bit --- Boot-Repair --- Grub2 wiki & Grub2 Basics --- RootSudo

  3. #3
    Join Date
    Jan 2013
    Beans
    2

    Re: Shotwell will not launch

    Many thanks, that has worked a treat!

    And now i know how to find hidden files....

  4. #4
    Join Date
    Jul 2005
    Location
    England
    Beans
    13,518

    Re: Shotwell will not launch

    Great!
    Please mark the thread as SOLVED from the thread tools menu at the top.
    DISTRO: Xubuntu 12.04-64bit --- Boot-Repair --- Grub2 wiki & Grub2 Basics --- RootSudo

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •