Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 35

Thread: Ralink rt5390 driver causing kernel panic.

  1. #21
    Join Date
    Oct 2011
    Beans
    10

    Re: Ralink rt5390 driver causing kernel panic.

    Yes, I'm at some distance, but here, windows reach without problems and linux dont
    I set the router to WPA2 only and changed it to channel 11 and I don't know if it's the WPA2 only, or the channel, but it's even worse now xD. Before, I had connection dropouts, but now it's almost impossible to connect in my bedroom.

  2. #22
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,104
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Ralink rt5390 driver causing kernel panic.

    Quote Originally Posted by chiec View Post
    Yes, I'm at some distance, but here, windows reach without problems and linux dont
    I set the router to WPA2 only and changed it to channel 11 and I don't know if it's the WPA2 only, or the channel, but it's even worse now xD. Before, I had connection dropouts, but now it's almost impossible to connect in my bedroom.
    I suggest you change back to the original channel (6 maybe?) and try it. You might also try a temporary driver parameter:
    Code:
    sudo modprobe -r rt2800pci
    sudo modprobe rt2800pci nohwcrypt=Y
    If it helps, we'll write one small file to make it persistent.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  3. #23
    Join Date
    Oct 2011
    Beans
    10

    Re: Ralink rt5390 driver causing kernel panic.

    Quote Originally Posted by chili555 View Post
    I suggest you change back to the original channel (6 maybe?) and try it. You might also try a temporary driver parameter:
    Code:
    sudo modprobe -r rt2800pci
    sudo modprobe rt2800pci nohwcrypt=Y
    If it helps, we'll write one small file to make it persistent.

    It helped a little, less dropouts, but there are still. I'm going to install the module that gave me kernel panics and then reinstall the cw-backports again. If that helped me before, maybe it still can xD

    Thanks

  4. #24
    Join Date
    Oct 2011
    Beans
    10

    Re: Ralink rt5390 driver causing kernel panic.

    Didn't worked u.u. Still very very slow compared with rt5390sta

  5. #25
    Join Date
    Jul 2011
    Beans
    13

    Re: Ralink rt5390 driver causing kernel panic.

    I'd like to weigh back in, this problem seems to be Gnome-related. May I suggest trying KDE, I've had no dropouts on Kubuntu and I did not even install the cw backports package.

  6. #26
    Join Date
    Jul 2011
    Beans
    13

    Re: Ralink rt5390 driver causing kernel panic.

    I've filed the bug with Gnome.

    It would be great if this got fixed upstream!

    https://bugzilla.gnome.org/show_bug.cgi?id=693122

  7. #27
    Join Date
    Oct 2011
    Beans
    10

    Re: Ralink rt5390 driver causing kernel panic.

    I just installed the 32-bits ubuntu and the driver from ralink works perfectly!

    If the drivers are free, why isn't this one by default (at least on 32bits distributions)?

    PD: I'm using gnome remix edition, so isn't gnome's fault.

  8. #28
    Join Date
    Jul 2011
    Beans
    13

    Re: Ralink rt5390 driver causing kernel panic.

    How might I make this persistent, Chili?

    Code:
    Code:
    sudo modprobe -r rt2800pci
    sudo modprobe rt2800pci nohwcrypt=Y
    Last edited by dotpc; February 19th, 2013 at 03:56 PM. Reason: formatting

  9. #29
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,104
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Ralink rt5390 driver causing kernel panic.

    Write a new file:
    Code:
    gksudo gedit /etc/modprobe.d/rt2800pci.conf
    Add a single line:
    Code:
    options rt2800pci nohwcrypt=Y
    Proofread carefully, save and close gedit.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  10. #30
    Join Date
    Jul 2011
    Beans
    13

    Re: Ralink rt5390 driver causing kernel panic.

    Weighing back in! I started having disconnect issues on KDE, which led me to try many other avenues ... eventually leading to Arch Linux and using netcfg.

    Performance is amazing, and I've had ZERO disconnects over many days. This problem seems to be part of network manager after all. Chiec, if you are brave you should try Arch and netcfg (or maybe wicd in Ubuntu).

Page 3 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •