Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: nVidia gt 520

  1. #1
    Join Date
    Mar 2009
    Location
    Vancouver, BC
    Beans
    12
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    nVidia gt 520

    I know there's already quite a few threads on this and some have kinda of helped, but I still can't get this working.

    I have an HTPC hooked up to my Panasonic 1080p Plasma with an HDMI cable.
    TV: Panasonic TC-P50G15
    CPU: Intel Core 2 Duo E6300
    Mobo: Gigabyte GA-EP45-UD3L P45
    Vid: Gigabyte Nvidia GeForce GT 520 GV-N520SL-1GI

    I originally couldn't get audio through HDMI with Nouveau and I read that it needs the Nvidia proprietary driver.

    Tried Ubuntu 12.04.1, 12.10, Lubuntu 12.04.1, 12.10, XBMCbuntu 11.0, 12.0 RC3 with the following.

    What I've tried (I fresh re-installed each of the above OS's after each try):
    Fresh install, install all software updates, activate nvidia-current in jockey. Reboot, shows blank aubergine screen right after GRUB loads. Fixed GRUB and Plymouth using this tutorial: http://jechem.blogspot.ca/2011/04/fi...ubuntu-on.html
    It then will show the Plymouth them but then boots straight to tty and startx then fails.

    I've tried with the x-swat ppa and the xorg-edgers ppa. I've also tried installing the Nvidia drivers from the website using this tut: http://ubuntuforums.org/showpost.php...postcount=1124
    I've tried with nvidia-current, nvidia-current-updates, nvidia-experimental-310, and the newest on nvidia.com

    My Xorg.0.log has this error no matter what I try
    Code:
    (EE) NVIDIA(0): Failed to initialize the NVIDIA GPU at PCI:1:0:0.
    My xorg.conf looks like:
    Code:
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce GT 520"
        BusID "PCI:01:00:0"
    EndSection
    of course I need to end this post with the requisite "it all worked in windows 7"...grrr, don't you just hate reading that?

    Any help would be appreciated!

  2. #2
    Join Date
    Mar 2009
    Location
    Vancouver, BC
    Beans
    12
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: nVidia gt 520

    bump? any ideas anyone?

  3. #3
    Join Date
    Feb 2009
    Location
    Dallas, TX
    Beans
    6,593
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: nVidia gt 520

    Hi dah81.

    Could you post the content of this file?
    Code:
    /var/log/Xorg.0.log
    Please paste the file here: paste.ubuntu.com, and post back the link to it.

    Regards.

  4. #4
    Join Date
    Mar 2009
    Location
    Vancouver, BC
    Beans
    12
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: nVidia gt 520


  5. #5
    Join Date
    Jan 2013
    Beans
    48

    Re: nVidia gt 520

    You can get the "current" "approved" nVidia drivers doing the following:

    sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
    sudo apt-get update
    sudo apt-get install nvidia-current

    I don't know if this will fix your problems, but it did mine and I have a seemingly stable system with the 304.xx drivers installed and the nVidia settings tool and all that.

    http://news.softpedia.com/news/How-t...4-295542.shtml may offer more help and hope.

  6. #6
    Join Date
    Feb 2009
    Location
    Dallas, TX
    Beans
    6,593
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: nVidia gt 520

    Thanks.

    Unfortunately there's no much information in the log. There's a bunch of people that have solved their Nvidia card issues by adding the nomodeset option to grub.

    I would try that first. Take a look at the first answer here to see how to do it.

    Let us know how it goes.
    Regards.

  7. #7
    Join Date
    Mar 2009
    Location
    Vancouver, BC
    Beans
    12
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: nVidia gt 520

    I added
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset video=uvesafb:mode_option=1920x1080-24,mtrr=3,scroll=ywrap"
    to GRUB already, that is the only way I even get past Plymouth.

    I have already tried x-swat's nvidia-current with the same results.

    Any other ideas?
    Last edited by dah81; January 30th, 2013 at 05:10 AM.

  8. #8
    Join Date
    Feb 2009
    Location
    Dallas, TX
    Beans
    6,593
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: nVidia gt 520

    Could you post the result of these commands?
    Code:
    lspci -nnk | grep -iA2 vga
    
    sudo lshw -C display
    Regards.

  9. #9
    Join Date
    Mar 2009
    Location
    Vancouver, BC
    Beans
    12
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: nVidia gt 520

    lspci -nnk | grep -iA2 vga
    Code:
    01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF119 [GeForce GT 520] [10de:1040] (rev a1)
            Subsystem: Giga-byte Technology Device [1458:352f]
            Kernel driver in use: nvidia
    sudo lshw -C display
    Code:
      *-display
           description: VGA compatible controller
           product: GF119 [GeForce GT 520]
           vendor: NVIDIA Corporation
           physical id: 0
           bus info: pci@0000:01:00.0
           version: a1
           width: 64 bits
           clock: 33MHz
           capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
           configuration: driver=nvidia latency=0
           resources: irq:16 memory:fb000000-fbffffff memory:e0000000-e7ffffff memory:ee000000-efffffff ioport:ef00(size=128) memory:e8000000-e807ffff

  10. #10
    Join Date
    Mar 2009
    Location
    Vancouver, BC
    Beans
    12
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: nVidia gt 520

    bump again? any ideas?

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •