Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: wl module has to be restarted after boot for wirless to work

  1. #11
    Join Date
    Jun 2009
    Beans
    32

    Re: wl module has to be restarted after boot for wirless to work

    Yes well, I didn't think that it could be something that simple either considering that I spent hours researching this before posting. But I can't complain that it was that simple!

    So to summarize the fix, on the first restart after ignoring ipv6 it wouldn't see the network anymore. Setting ipv6 vack to automatic, it saw it, connected and worked fine without having to run rmmod wl and modprobe wl, something that never happened in the previous 30 or so restarts i did trying other stuff. Then i ignored ipv6 again and restarted again. This time it saw the network, connected automatically and the connection was again fast and working.

    Three more restarts later it still works. So I guess we can be sure that there was something to do with ipv6.

    I am also sceptical how long this will last but for now problem solved and a clue was uncovered although it is still a mystery as to what was happening and what restarting wl has to do with this.

    I will put SOLVED in a few days i guess if it holds. Thanks for the tip chili555.

  2. #12
    Join Date
    Jun 2009
    Beans
    32

    [SOLVED]Re: wl module has to be restarted after boot for wirless to work

    So anyone having problems with SLOW internet connection and has a modem with ipv6 settings should simply try and disable it (its easy, take a look at the screenshot chili555 sent me a few posts above)

    Specificcally it seems that it is crucial to have three text files in the HOME folder each NAMED as

    net.ipv6.conf.all.disable_ipv6 = 1

    net.ipv6.conf.default.disable_ipv6 = 1

    net.ipv6.conf.lo.disable_ipv6 = 1

    respectively and each containing the text

    #disable ipv6

    I am not sure at all why these are where they are and i think the text is just a commented line (or maybe not!). BUT i had huge troubles with my wireless and all i know is that after disabling ipv6 it worked as a charm. Then i deleted the above files because they were the only thing in my home folder other than my other neatly arranged folders and the wifi went bananas again taking as before a minute to open google.com . I restored the files from the recycled bin and it snapped back to working furiously fast again. I did that a few times to be sure, restarts and everything included. (dmesg had some crazy log entries in it, cfg80211 was disabling all my frequencies one by one when i deleted the files but anyway ask if you are interested i am happy that its over)

    So there you have it, IF you have tried everything as i did to get the wireless to work and finally got it to work with the wl driver (check that with lsmod | grep wl ), BUT the connection is slow to very slow, disable ipv6 or/and make sure that the above files exist.

    Mine works incredibly well, before i manage to type the pass for login it is already connected to my network and working fast as it should be.

    A symptom that would tell you that the above is what you need to do (ASSUMING always that you are using the wl driver) is to try the commands "sudo rmmod wl" and then "sudo modprobe wl" (dont type the quotes) to restart the driver. In my case doing that after startup would fix the slowness problem and i was searching for a permanent solution which turned out to be the above. So if restarting makes the wireless work well, go for ipv6.

    There I did my duty, i hope someone gets help from this as i did from so many posts.

    BTW chili555 if you are following this please let us know what these files are and why on earth they are in the home folder!!
    Last edited by psifunk; January 31st, 2013 at 12:02 AM.

  3. #13
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    21,168
    Distro
    Ubuntu 15.04 Vivid Vervet

    Re: wl module has to be restarted after boot for wirless to work

    BTW chili555 if you are following this please let us know what these files are and why on earth they are in the home folder!!
    Why indeed? I have never heard of the files in /home/user. I always thought they were additional lines in /etc/sysctl.conf. I also thought, as I've often suggested, that disabling it in Network Manager was quite enough.

    I am beginning to suspect it's router related. Some have no problems at all with IPv6, some do. Some have no problems at all with 802.11N, some do. Some have no problems at all with AES, some do. I don't understand it all yet.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •