Results 1 to 5 of 5

Thread: Problem with NVIDIA 310 driver

  1. #1
    Join Date
    May 2008
    Location
    Sydney Australia
    Beans
    23
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Problem with NVIDIA 310 driver

    I installed the Nvidia 310 experimental driver from Additional Drivers. Reason was because I installed Steam and Serious Sam 3 was running at a low frame rate. Anyway, after installing the driver and reboot, I get no GUI. Just a CLI. Is there anyway to revert back to a more stable driver version.

    Running 12.04LTS
    Nvidia GTX 285

  2. #2
    Join Date
    Jul 2012
    Beans
    314
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Problem with NVIDIA 310 driver

    Hello,

    You aren't the only one. You will have to use CLI to uninstall the driver you installed.

  3. #3
    Join Date
    Feb 2009
    Location
    Dallas, TX
    Beans
    6,590
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Problem with NVIDIA 310 driver

    Hi Piccy.

    Quote Originally Posted by Piccy View Post
    Is there anyway to revert back to a more stable driver version.
    Sure there is.

    Uninstall all Nvidia packages:
    Code:
    sudo apt-get purge nvidia-*
    Then remove the Xorg config file:
    Code:
    sudo rm -rf /etc/X11/xorg.conf
    Then restart.

    You should boot into the GUI using the Nvidia open source driver (nouveau). Once on the desktop, install the recommended Nvidia driver, usually named nvidia-current (recommended).

    Before you reboot to take effect. Create a custom Xorg config file:
    Code:
    sudo nvidia-xconfig
    Another reboot, will get you using the stable Nvidia proprietary driver.

    Hope it helps. Let us know how it goes.
    Regards.
    Last edited by papibe; January 23rd, 2013 at 05:10 AM.

  4. #4
    Join Date
    May 2008
    Location
    Sydney Australia
    Beans
    23
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Problem with NVIDIA 310 driver

    Thanks papibe

    That worked!!!!!

    BTW the additional drivers window tells me that the nvidia-current driver is activated but its not in use

    Whats up with that?

    Any way of telling what driver is in use?

  5. #5
    Join Date
    Feb 2009
    Location
    Dallas, TX
    Beans
    6,590
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Problem with NVIDIA 310 driver

    Sure there is.

    Could you post the result of these 2 commands?
    Code:
    lsmod | grep -i nvidia
    
    lspci -nnk | grep -iA2 vga
    Regards.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •