Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: WiFi nets works are not automatically detected

  1. #1
    Join Date
    May 2009
    Location
    Oxfordshire, UK
    Beans
    Hidden!
    Distro
    Lubuntu 13.04 Raring Ringtail

    WiFi nets works are not automatically detected

    I just did a fresh install of Precise (and changed desktop back to Gnome)
    I have the b4318 wireless card so I had to do the download of fw-cutter etc and all went to plan and the Wifi is enabled and working nicely.

    The only minor problem is that the networks don't seem to be automatically detected and listed. I have to uncheck "Enable Wireless" and then re-enable it again, after which the available wireless networks show up in the pulldown menu.

    Any suggestions on how to fix this?

    Thanks

    Caitlin
    Last edited by oxf; December 29th, 2012 at 09:35 PM.

  2. #2
    Join Date
    May 2009
    Location
    Oxfordshire, UK
    Beans
    Hidden!
    Distro
    Lubuntu 13.04 Raring Ringtail

    Re: WiFi nets works are not automatically detected

    Update: It seems that occasionally, but not often, it will detect them after a longish and inconvenient delay.
    Last edited by oxf; December 29th, 2012 at 10:37 PM.

  3. #3
    Join Date
    Dec 2012
    Beans
    61

    Re: WiFi nets works are not automatically detected

    Keep this in start up
    Code:
    sudo ifconfig <wireless interface> up

  4. #4
    Join Date
    May 2009
    Location
    Oxfordshire, UK
    Beans
    Hidden!
    Distro
    Lubuntu 13.04 Raring Ringtail

    Re: WiFi nets works are not automatically detected

    Quote Originally Posted by srekcahrai View Post
    Keep this in start up
    Code:
    sudo ifconfig <wireless interface> up
    Thanks,
    Do you mean I just run that in terminal?
    What exactly do you mean by "keep in startup"?

  5. #5
    Join Date
    Apr 2012
    Beans
    Hidden!

    Re: WiFi nets works are not automatically detected

    Hi oxf, please post the output of..

    Code:
    cat /etc/modules
    and.
    Code:
    lspci -nn | grep AN
    Thanks.
    Craving anchovy, herring and squid pizza.....with clam sauce

  6. #6
    Join Date
    Dec 2012
    Beans
    61

    Re: WiFi nets works are not automatically detected

    For temporary, run in terminal
    For permanent, store in start up

    To store in startup, click on the icon like settings icon at top right. Startup application option will be available.

  7. #7
    Join Date
    May 2009
    Location
    Oxfordshire, UK
    Beans
    Hidden!
    Distro
    Lubuntu 13.04 Raring Ringtail

    Re: WiFi nets works are not automatically detected

    Quote Originally Posted by Hadaka View Post
    Hi oxf, please post the output of..

    Code:
    cat /etc/modules
    and.
    Code:
    lspci -nn | grep AN
    Thanks.
    Thanks ....

    Code:
    mbdb@M2000:~$ cat /etc/modules
    # /etc/modules: kernel modules to load at boot time.
    #
    # This file contains the names of kernel modules that should be loaded
    # at boot time, one per line. Lines beginning with "#" are ignored.
    
    lp
    Code:
    mbdb@M2000:~$ lspci -nn | grep AN
    05:02.0 Network controller [0280]: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller [14e4:4318] (rev 02)
    I should also add the following:

    1. Sometimes if I wait long enough they are eventually detected and listed in the pulldown, however, can be quite a wait.

    2. It's not just the available WiFi networks that are not listed. In fact everything in the menu above "Enable Networking is missing. This includes:
    Wired networs
    Wireless networks
    Connect to Hidden network
    Create New....
    VPN ...... etc etc

    Caitlin

  8. #8
    Join Date
    May 2009
    Location
    Oxfordshire, UK
    Beans
    Hidden!
    Distro
    Lubuntu 13.04 Raring Ringtail

    Re: WiFi nets works are not automatically detected

    Quote Originally Posted by srekcahrai View Post
    Keep this in start up
    Code:
    sudo ifconfig <wireless interface> up
    Actually that doesn't seem to affect it either way. This problem is a bit of an irritating one as the WiFi is in essence working OK it's just doesn't always load/show in the menu.

    It's definately related to the "Enable Wireless" check box, i.e if I uncheck and then recheck "Enable Wireless" voila...it's detected. Also some times if I leave it long enough it will detect on it's own.

  9. #9
    Join Date
    Apr 2012
    Beans
    Hidden!

    Re: WiFi nets works are not automatically detected

    Hi, this may help,it will load your dirver on startup or reboot.

    Code:
    sudo su
    echo b43 >> /etc/modules
    exit
    Craving anchovy, herring and squid pizza.....with clam sauce

  10. #10
    Join Date
    May 2009
    Location
    Oxfordshire, UK
    Beans
    Hidden!
    Distro
    Lubuntu 13.04 Raring Ringtail

    Re: WiFi nets works are not automatically detected

    Quote Originally Posted by Hadaka View Post
    Hi, this may help,it will load your dirver on startup or reboot.

    Code:
    sudo su
    echo b43 >> /etc/modules
    exit
    Thanks I'll try that. I presume thats entered in Startup Applications? in which case three separate entries since there's only one line available?

    Caitlin

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •