Results 1 to 7 of 7

Thread: cannot ssh over wifi

  1. #1
    Join Date
    Sep 2007
    Beans
    66

    Question cannot ssh over wifi

    I have a machine I cannot ssh to over wifi from my computer. Ssh works over ehternet. I can also connect to it from another machine (even on another unconnected network in a different geographical location). I have flushed out all my iptables by running:
    Code:
    iptables -F
    iptables -X
    iptables -t nat -F
    iptables -t nat -X
    iptables -t mangle -F
    iptables -t mangle -X
    iptables -P INPUT ACCEPT
    iptables -P FORWARD ACCEPT
    iptables -P OUTPUT ACCEPT
    I have also stopped ufw (
    Code:
    sudo service stop ufw
    ) but none of it has worked. Any ideas?

    I have tried pinging to the machine but it fails from my laptop. It works form other locations.

    If I switch to windows, it all works. Thanks

  2. #2
    Join Date
    Jul 2005
    Beans
    2,050

    Re: cannot ssh over wifi

    Are you connected by WiFi to the same router that you are connected to via Ethernet?

    Sure the settings are "automatic" with each one of them?

  3. #3
    Join Date
    Jan 2013
    Beans
    18

    Re: cannot ssh over wifi

    check that you're not blocking port 22 over the wireless (who knows...) or that the wireless isn't on a "blocked" network segment (e.g. the ssh server allows from 192.168.1.50-99, and wireless starts at 192.168.1.100)

  4. #4
    Join Date
    Aug 2009
    Beans
    106

    Re: cannot ssh over wifi

    Some routers have a setting in there about wifi isolation or something like that. It prevents two wifi devices from connecting to each other. Turn that off.

    Look in the wifi settings on the router. Maybe in the advanced settings.

  5. #5
    Join Date
    Jul 2005
    Beans
    2,050

    Re: cannot ssh over wifi

    Quote Originally Posted by lisanels47 View Post
    Some routers have a setting in there about wifi isolation or something like that. It prevents two wifi devices from connecting to each other. Turn that off.

    Look in the wifi settings on the router. Maybe in the advanced settings.
    Oh, I'll bet you that's the problem!

  6. #6
    Join Date
    May 2010
    Beans
    10

    Re: cannot ssh over wifi

    Have had the same problem, wireless isolation enabled on the router/access point. If there is no option to turn it off then assume it's set to enabled.

  7. #7
    Join Date
    Sep 2007
    Beans
    66

    Re: cannot ssh over wifi

    I'm actually at a college so I can't reset wifi access points. It also works on another operating system, say windows. I think the problem is somewhere within my settings.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •