Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: ffmpeg unknown encoder 'xvid'

  1. #1
    Join Date
    May 2008
    Beans
    75
    Distro
    Ubuntu 8.10 Intrepid Ibex

    ffmpeg unknown encoder 'xvid'

    EDIT: This should probably be in Multimedia & Video - ack!

    I continually get the error of "unknown encoder 'xvid'" when attempting to convert an .avi file to .mp4. I'm running Ubuntu 8.10.

    I have installed, uninstalled and reinstalled ffmpeg several times to no avail.

    Right now, I have medibuntu added to Synaptic and I suppose it's the medibuntu version of ffmpeg that is currently installed. Along with ffmpeg, I have also installed the following packages (which have deleted the non-unstripped versions of each lib):

    libavutil-unstripped-49
    libpostproc-unstripped-51
    libavdevice-unstripped-52
    libswscale-unstripped-0
    libavcodec-unstripped-51
    libavformat-unstripped-52
    libavifile-0.7c2 (not sure if this one is required)

    Terminal command of "ffmpeg -formats |grep aac" returns the following:

    D aac ADTS AAC
    EA libfaac
    D A mpeg4aac

    From reading elsewhere on the forums, the output stated above shows that ffmpeg is a bad install, but this output has been the same every time I uninstall/reinstall ffmpeg.

    Medibuntu has been added, and Synaptic has been reloaded after the addition. Medibuntu is also checked off as well as listed under the Third-Party Software category.

    How can I get xvid encoding added in - am I missing a lib?
    Last edited by Mahinva; December 21st, 2008 at 05:16 PM.

  2. #2
    Join Date
    Sep 2006
    Beans
    3,682

    Re: ffmpeg unknown encoder 'xvid'

    What is your ffmpeg command and the full ffmpeg response? You probably need to change "xvid" to "libxvid" in your command.

  3. #3
    Join Date
    Jun 2007
    Beans
    377

    Re: ffmpeg unknown encoder 'xvid'

    I'm pretty sure you're using Intrepid. The medibuntu repo in Intrepid does not have the unstripped version of ffmpeg, and I've heard they're not considering putting it in. You'll have to compile from source, there's a guide to that in the HOWTOs which I've used and am happy with.

  4. #4
    Join Date
    May 2008
    Beans
    75
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: ffmpeg unknown encoder 'xvid'

    Quote Originally Posted by FakeOutdoorsman View Post
    What is your ffmpeg command and the full ffmpeg response? You probably need to change "xvid" to "libxvid" in your command.
    Here is the command I've been using. I picked this up on a thread for converting videos for Sansa View.

    Code:
    ffmpeg -i /home/USER/ -r 29.97 -vcodec xvid -b 700k -acodec aac -ab 128k -bufsize 4M -qmax 51 -mbd 2 -flags +4mv+trell -aic 2 -cmp 2 -subcmp 2 -ar 44100 -g 300 -s 320x240 -aspect 4:3 -ac 2 -f mp4 -y /home/USER/
    /home/USER/ gets filled out completely when I am trying to convert - I just have it filled by default so I don't forget my path.

    I then get back the following:

    Code:
    FFmpeg version r11872+debian_3:0.svn20080206-12ubuntu3, Copyright (c) 2000-2008 Fabrice Bellard, et al.
      configuration: --enable-gpl --enable-pp --enable-swscaler --enable-x11grab --prefix=/usr --enable-libgsm --enable-libtheora --enable-libvorbis --enable-pthreads --disable-strip --enable-libfaad --enable-libfaadbin --enable-liba52 --enable-liba52bin --enable-libdc1394 --disable-armv5te --disable-armv6 --disable-altivec --disable-vis --enable-shared --disable-static
      libavutil version: 49.6.0
      libavcodec version: 51.50.0
      libavformat version: 52.7.0
      libavdevice version: 52.0.0
      built on Oct  3 2008 22:40:31, gcc: 4.3.2
    Input #0, avi, from '/home/USER/VIDEO.avi':
      Duration: 01:30:32.8, start: 0.000000, bitrate: 1080 kb/s
        Stream #0.0: Video: mpeg4, yuv420p, 528x288 [PAR 1:1 DAR 11:6], 23.98 tb(r)
        Stream #0.1: Audio: liba52, 48000 Hz, stereo, 192 kb/s
    Unknown encoder 'xvid'
    Quote Originally Posted by Ng Oon-Ee View Post
    I'm pretty sure you're using Intrepid. The medibuntu repo in Intrepid does not have the unstripped version of ffmpeg, and I've heard they're not considering putting it in. You'll have to compile from source, there's a guide to that in the HOWTOs which I've used and am happy with.
    Yes, you're correct - I am using Intrepid. I don't know if I have followed the exact HOWTO you've used, but I did manually add medibuntu to the repository. Is simply adding medibuntu not sufficient enough - I thought that after adding medibuntu, the ffmpeg I'd install after would be the correct one? I only have 1 listing for ffmpeg in the repo.

    Would you be able to provide a link to the HOWTO? This is the one I've found but am not sure whether it'll be fruitful or not:

    http://ubuntuforums.org/showthread.php?t=786095

    Thanks for both of your insight!
    Last edited by Mahinva; December 22nd, 2008 at 05:31 PM.

  5. #5
    Join Date
    Sep 2006
    Beans
    3,682

    Re: ffmpeg unknown encoder 'xvid'

    Try this:
    Code:
    ffmpeg -i input.avi -r 29.97 -vcodec libxvid -b 700k -acodec libfaac -ab 128k -bufsize 4M -qmax 51 -mbd 2 -flags +4mv+trell -aic 2 -cmp 2 -subcmp 2 -ar 44100 -g 300 -s 320x240 -aspect 4:3 -ac 2 -f mp4 -y output.mp4
    I renamed "xvid" to "libxvid" and "aac" to "libfaac". Older revisions of ffmpeg use the former names. It should work because you have the unstripped libraries installed. You don't need anything from Medibuntu to get this to work.

    If you want the bleeding-edge, access to more codecs/encoders/decoders, or want to customize your ffmpeg install then the guide you linked to will help with that.
    Last edited by FakeOutdoorsman; December 22nd, 2008 at 07:50 PM. Reason: typo

  6. #6
    Join Date
    May 2008
    Beans
    75
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: ffmpeg unknown encoder 'xvid'

    Thank you, FakeOutdoorsman! I am running the command you provided successfully. I'm not sure exactly how long it will take for the conversion to finish, but I'm guessing it'll be under 2 hours. I hope that I will be able to mark this thread as solved after playing the completed video on my View without any problems.

    I've got fingers crossed.

    My encoding needs are very simple right now; I just want to convert files to mp4 and have them play without lagging fps on my Sansa View. I will keep that HOWTO in mind in case things change. Thanks.

  7. #7
    Join Date
    Sep 2006
    Beans
    3,682

    Re: ffmpeg unknown encoder 'xvid'

    You can encode a specific number of frames for a test encode by using the -vframes option. For example, to encode the first 300 frames use "-vframes 300".

  8. #8
    Join Date
    May 2008
    Beans
    75
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: [SOLVED] ffmpeg unknown encoder 'xvid'

    Wonderful - this worked! Sound and video are perfect. Thank you so much!

  9. #9
    Join Date
    Jun 2007
    Location
    /home/jacob
    Beans
    608
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: [SOLVED] ffmpeg unknown encoder 'xvid'

    im having the same problem but when i try and switch xvid with libxvid it still doesn't work

    i get this error:
    Code:
    Unknown encoder 'libxvid'
    intel core 2 duo 1.8ghz
    1 gig ram
    250 gig hard drive
    evga Geforce 8600 ssc 256mb over clocked

  10. #10
    Join Date
    Sep 2006
    Beans
    3,682

    Re: [SOLVED] ffmpeg unknown encoder 'xvid'

    Quote Originally Posted by jacob01 View Post
    im having the same problem but when i try and switch xvid with libxvid it still doesn't work

    i get this error:
    Code:
    Unknown encoder 'libxvid'
    I'm assuming you're using Ubuntu 8.10. You probably need to install the ffmpeg unstripped libraries:
    Code:
    sudo apt-get install libavcodec-unstripped-51

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •