Results 1 to 4 of 4

Thread: Problems With Fullscreen WINE Games In Unity/Compiz

  1. #1

    Problems With Fullscreen WINE Games In Unity/Compiz

    I'm having issues with getting Windows games to go fullscreen. The top bar is gray and always says "WINE Windows Program Loader" and the Ubuntu sidebar shows as well. I've did a bit of reading and it appears to be related to Unity's Compiz. So I downloaded CompizConfig Settings Manager (ccsm) from the Ubuntu Software Center and ticked the box beside "Legacy Fullscreen Support" in the "Workarounds" section, since that's what another site recommended. But to no avail. I've also tried emulating a virtual desktop in winecfg (WINE Config), no luck there either. Non-WINE applications like VLC have no issue going fullscreen. All I want is for all my Steam games to go into fullscreen correctly like they do on Windows. I've already tested alot of games and got them into fullscreen and running correctly, but to do so I had to install KDE and XFCE. I really dont want to feel forced to use another windowing manager just to get games to play right.

    Also, can someone recommend a script or app that disables Compiz's desktop effects while games are running? I have heard that it can have a huge hit on performance.

    Thanks!

  2. #2

    Re: Problems With Fullscreen WINE Games In Unity/Compiz

    noone knows?

  3. #3
    Join Date
    Apr 2008
    Location
    Norwich CT
    Beans
    1,374
    Distro
    Kubuntu 12.04 Precise Pangolin

    Talking Re: Problems With Fullscreen WINE Games In Unity/Compiz

    The program you need is called fusion-icon. You can quickly install it by entering

    sudo apt-get install fusion-icon

    or you can install it with the pokey Software Center, or the still-great package manager Synaptic. It will give you an icon that allows you to turn Compiz on or off at will.

    Or, you could install lubuntu-desktop, log out, and log back in to Lubuntu, which is lightweight and fast. It is Ubuntu, with the LXDE interface. If it'll quickly run a single-core laptop such as I'm typing on, it'll run games for you very well indeed. It runs (some) games for me on this laptop. Also, kde-full or kubuntu-desktop, when logged into, has a settings app for desktop effects. On the third tab of that app, there's a checkbox for "disable effects for full-screen windows." Check that and games will run at full speed. You might also log into Unity 2D.

    I am most decidedly not a user of the Unity interface, but fusion-icon is the file you need (or my other, uh, suggestions.

    And DON'T hesitate to ask questions in these forums. Everybody here was once 100% clueless. I'm now (I estimate) 86% clueless...
    Last edited by oldrocker99; January 18th, 2013 at 04:44 PM.

    I drink my Ubuntu black, no sugar.
    Ubuntu user 28819

  4. #4

    Re: Problems With Fullscreen WINE Games In Unity/Compiz

    @ oldrocker99: I installed CFI as you suggested but couldnt get it to run by clicking its' icon. So I entered the command 'compiz-fusion icon &' in a terminal just before I was about to run a game, and it messed up my display entirely (see http://ubuntuforums.org/showthread.p...1#post12469601). I know I will get this fixed, there is no doubt about that.

    So, to anyone that's willing to help, what are my options for getting WINE games to go into fullscreen properly and increase gaming performance? If someone can post links that would be very helpful. I'm more than willing to do the research and legwork to get things working the way I want them to, just need a bit of guidance.

    Thanks in advance!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •