Results 1 to 6 of 6

Thread: "missing operating system" when booting from SSD of hybrid disk

  1. #1
    Join Date
    Dec 2007
    Beans
    56

    "missing operating system" when booting from SSD of hybrid disk

    I'm trying to get my hybrid-disk (SSD+HDD) machine to boot from the SSD, but i get a message saying "missing operating system" when booting.

    The machine is a new Lenovo Thinkpad S430 with 16Gb SSD and 500Gb HDD. I installed Ubuntu from USB stick on the whole disks, wiping out the existing partitions. I put / and /boot on the SSD (/dev/sdb), and the rest (/home, /usr, /var, /tmp, swap, /srv, /opt) on the HDD (/dev/sda). The BIOS is configured to first try booting from SSD, then USB stick, then CD (no HDD).

    When booting Ubuntu from USB, i can see both the HDD and SDD. Partitions are not empty, indeed the install seems to have run well. I've tried using gparted to flag the / partition (/dev/sdb1) with "boot" but no effect. Same for /boot partition (/dev/sdb5). Both filesystem types are ext4.

  2. #2
    Join Date
    Nov 2009
    Location
    Segur De Calafell, Spain
    Beans
    11,822
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: "missing operating system" when booting from SSD of hybrid disk

    That is usually a bios message, not grub/ubuntu message. It means you have no boot flag set. Linux doesn't use a boot flag but windows does and many computers are designed to give an error if they can't see a boot flag on one of the partitions. It doesn't even try to boot the computer.

    Just use Gparted from live mode and put a boot flag on the /boot partition for example. In Gparted you need to right-click the partition and select Manage Flags.

    It should be fine after that.
    Darko.
    -----------------------------------------------------------------------
    Ubuntu 14.04 LTS 64bit & Windows 7 Ultimate 64bit

  3. #3
    Join Date
    Dec 2007
    Beans
    56

    Re: "missing operating system" when booting from SSD of hybrid disk

    Darko, i did just that - see what i wrote above.

  4. #4
    Join Date
    Nov 2009
    Location
    Segur De Calafell, Spain
    Beans
    11,822
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: "missing operating system" when booting from SSD of hybrid disk

    Try putting the boot flag on any primary partition of sda, not sdb. In a hybrid setup the ssd is usually only a cached drive so maybe it expects the boot flag on sda.

    If that doesn't work, I don't have other ideas but that message is definitely from bios, not ubuntu.
    Darko.
    -----------------------------------------------------------------------
    Ubuntu 14.04 LTS 64bit & Windows 7 Ultimate 64bit

  5. #5
    Join Date
    Dec 2007
    Beans
    56

    Re: "missing operating system" when booting from SSD of hybrid disk

    Danko, thanks for your reply.

    I did a complete new install, and it worked now. I think i may have improperly set the HDD as the boot disk on the first install. I now set this to the SSD, and it prompted me to create an efi partition there. On my first attempt, there was no such partition.

  6. #6
    Join Date
    Nov 2009
    Location
    Segur De Calafell, Spain
    Beans
    11,822
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: "missing operating system" when booting from SSD of hybrid disk

    Well, you never mentioned you are using the new UEFI boot. That's a whole different ball game.

    If you ask me it was better to disable the uefi boot if bios gives you the option, before you did a reinstall. That way it would have installed in legacy mode.

    But this is fine too, if it works for you.
    Darko.
    -----------------------------------------------------------------------
    Ubuntu 14.04 LTS 64bit & Windows 7 Ultimate 64bit

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •