Results 1 to 3 of 3

Thread: Help Configuring Multiple IP Addresses with Different Gateways in Interfaces

  1. #1
    Join Date
    Jul 2009
    Beans
    98

    Help Configuring Multiple IP Addresses with Different Gateways in Interfaces

    Hi All,

    I'm trying to setup 15 or so different IP addresses that I'd like the eth0 interface to bind on. I've looked online at quite a few guides that show how to add multiple IP addresses to the /etc/network/interfaces file. However, they do not show a configuration in which different ranges of IP addresses are added on one interface. So, based on what I found, I have the following (the IP Addresses have been randomized for privacy, so of course the IPs themselves don't look right):

    Code:
    auto lo
    iface lo inet loopback
    
    auto eth0
    iface eth0 inet static
    address 74.3.3.2
    netmask 255.255.255.248
    network 74.3.3.1
    broadcast 74.3.3.3
    gateway 74.3.3.4
    
    auto eth0:0
    iface eth0:0 inet static
    address 77.1.1.100
    netmask 255.255.255.252
    gateway 77.1.1.92
    
    auto eth0:1
    {etc...}
    {goes up to auto eth0:13}
    Does this look right? Is there an easier / better way to do this?

    Do the settings in the interfaces and the networking daemon run by default in Ubuntu with XWindows installed?

    Code:
    sudo update-rc.d networking defaults
    Would this code make sure the networking daemon is running by default when the computer starts? Would network manager in gnome still work for other devices besides what is configured in the interfaces file?

    Any help is appreciated. Thanks!

  2. #2
    Join Date
    Oct 2007
    Beans
    338

    Re: Help Configuring Multiple IP Addresses with Different Gateways in Interfaces

    To err is human - and to blame it on a computer is even more so.
    Author: Robert Orben

  3. #3
    Join Date
    Jul 2009
    Beans
    98

    Re: Help Configuring Multiple IP Addresses with Different Gateways in Interfaces

    Quote Originally Posted by chadk5utc View Post
    I guess that means I have it setup correctly?

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •