Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: lightdm login leads to a wrong environment

  1. #11
    Join Date
    Dec 2007
    Beans
    458

    Re: lightdm login leads to a wrong environment

    OK, sorry if you're offended by a second user, but on some forums it is considered a good idea to keep discussions of the same problem together. (EDIT: That's Section II, rule #1 of this forum also.) Note that I (1) found the bug report; (2) reported that it is supposed to be fixed but doesn't seem to be; and (3) actually tried the proposed solution, found it incomplete, and explained why. Where I come from that's considered a substantive contribution to the discussion.

    Meanwhile, if by some chance the OP does post back, his posts won't get lost. And don't worry, this isn't a filibuster.

    Perhaps you were offended by the remark about gdm being someone's little joke (I have removed it). That was a joke, not a barb thrown at you. Keep in mind how you would feel about your OS almost being bricked. And please, I'm trying to keep this on a friendly and helpful basis.
    Last edited by VanillaMozilla; January 22nd, 2013 at 04:15 PM.

  2. #12
    Join Date
    Sep 2012
    Location
    Gnome12o4/LXQt14o4
    Beans
    Hidden!

    Re: lightdm login leads to a wrong environment

    I see you edited all your post, good show Im moving on now.

  3. #13
    Join Date
    Dec 2007
    Beans
    458

    Re: lightdm login leads to a wrong environment

    Edited for clarity and brevity. Also, didn't want to offend you. If you have more info on this, it's very welcome, but don't feel obligated, as it's just a computer for testing. Thanks for your help.

  4. #14
    Join Date
    Dec 2007
    Beans
    458

    Re: lightdm login leads to a wrong environment

    This works for me.

    Edit /etc/lightdm/lightdm.conf. Change the greeter from unity-greeter to lightdm-gtk-greeter.

    There's no need to use gdm instead of lightdm; you just need to change the greeter.

    But be prepared with an escape if it doesn't work.

  5. #15
    Join Date
    Jan 2013
    Beans
    2

    Smile Re: lightdm login leads to a wrong environment


    Hello,
    Sorry for not giving news for the past days. I have been very busy trying out to restore a fully operational user session. While I was trying it blew all my menus and I was having a hard time.
    As my contribution, here is a summary of what I did.
    I understood that when it deals with 2D (whether unity session or gnome-classic session ), it is handled through metacity) whereas when it comes to 3D it is compiz. I realized that the problem came from compiz, and i remembered that I had changed one parameter in ccsm, which resulted in a question "some plugins may be uncompatible, do you want to go on" (the idea, not the exact words !). As a lesson to other users: DON'T ANSWER YES IF YOU ARE RUNNING GNOME CLASSIC. It ruins the environment. Despite all my efforts, I was not able to restore it. From a user standpoint, everything acts as if there were conflicts between options used by compiz in the 2 environments.
    From all the posts I read, the best I found that gave me hints to solve the problem was:
    HTML Code:
    http://ubuntuforums.org/showthread.php?t=1860615
    I followed the tips but none of them gave me the solution.
    I did not switched to GDM because it did not seem to me it would solve the problem. What I did instead what to rely on the observation I made in my first post:
    HTML Code:
      I then created another user and I can log in normally for this user, but it is impossible to do it for my main user. 
    I created a new user from scratch and copied patiently from one user to the user, trying not to copy what seemed to be in connection with compiz.
    After five days of hard labour, it works now.: 3D and everything restored
    There may be much simpler solutions, but I failed to find them.
    Thank you both for your help.
    Last edited by Seagul; January 23rd, 2013 at 12:01 PM.

  6. #16
    Join Date
    Sep 2012
    Location
    Gnome12o4/LXQt14o4
    Beans
    Hidden!

    Re: lightdm login leads to a wrong environment

    Very nice job, glad you got it all sorted out. And your thread was, shall we say, very entertaining

    https://wiki.ubuntu.com/UnansweredPo.../SolvedThreads

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •