Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Auto mounting network share using fstab

  1. #1
    Join Date
    Jan 2013
    Beans
    8

    Auto mounting network share using fstab

    I am trying to auto mount a network ntfs share in Ubunutu.

    I have followed these instructions to the T using Ubuntu 12.10
    HTML Code:
    http://ubuntuforums.org/showthread.php?p=12456976#post12456976
    . After I do
    Code:
    sudo mount -a
    I get
    Code:
    mount error (13): Permission denied
    Can anyone help?

  2. #2
    Join Date
    Apr 2008
    Location
    LOCATION=/dev/random
    Beans
    5,767
    Distro
    Ubuntu Development Release

    Re: Auto mounting network share using fstab

    What line did you add to your fstab file?
    Can you post the result of...
    Code:
    cat /etc/fstab
    Cheesemill

  3. #3
    Join Date
    Feb 2009
    Location
    Dallas, TX
    Beans
    6,894
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Auto mounting network share using fstab

    Hi corydchurch. Welcome to the forums

    Although it may work, smbfs is a deprecated package. Try installing 'cifs-utils' instead.

    If that doesn't work, could you post the content of your /etc/fstab ?

    Regards.

  4. #4
    Join Date
    Jan 2013
    Beans
    8

    Re: Auto mounting network share using fstab

    thanks for the fast response.

    just like the link above instructed, here's my line in fstab:

    Code:
    //myurl/media /media/plex cifs auto,iocharset=utf8,uid=1000,gid=1000,credentials=/root/.cifcredentials,file_mode=0775,dir_mode=0775 0 0
    of course for "myurl" I put my url to the network share.

    and here's the entire fstab file:

    Code:
    # /etc/fstab: static file system information.
    #
    # Use 'blkid' to print the universally unique identifier for a
    # device; this may be used with UUID= as a more robust way to name devices
    # that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    # / was on /dev/sda1 during installation
    UUID=cbc1cb0d-bdb6-4363-b8b7-872e069b949a /               ext4    errors=remount-ro 0       1
    # swap was on /dev/sda5 during installation
    UUID=5164db60-3507-4b4d-9229-790b86b5504c none            swap    sw              0       0
    //myurl/media /media/plex cifs auto,iocharset=utf8,uid=1000,gid=1000,credentials=/root/.cifcredentials,file_mode=0775,dir_mode=0775 0 0

  5. #5
    Join Date
    Jan 2013
    Beans
    8

    Re: Auto mounting network share using fstab

    Quote Originally Posted by papibe View Post
    Hi corydchurch. Welcome to the forums

    Although it may work, smbfs is a deprecated package. Try installing 'cifs-utils' instead.

    If that doesn't work, could you post the content of your /etc/fstab ?

    Regards.
    Yes, I have also installed cifs-utils. does that change how I write up my line in fstab?

  6. #6
    Join Date
    Apr 2008
    Location
    LOCATION=/dev/random
    Beans
    5,767
    Distro
    Ubuntu Development Release

    Re: Auto mounting network share using fstab

    You have a typo in your fstab file.
    Code:
    credentials=/root/.cifcredentials
    should be
    Code:
    credentials=/root/.cifscredentials
    If that's what you've called your credentials file.
    Cheesemill

  7. #7
    Join Date
    Jan 2013
    Beans
    8

    Re: Auto mounting network share using fstab

    no I know. I already created the credentials file and forgot the "s" so instead of renaming the file, I just omitted the "s" in the file name in fstab.

  8. #8
    Join Date
    Feb 2009
    Location
    Dallas, TX
    Beans
    6,894
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Auto mounting network share using fstab

    Try mounting the share manually on the command line to see if you get a more comprehensive error message:
    Code:
    sudo mount -ocredentials=/root/.cifcredentials -t cifs //myurl/media /media/plex
    Let us know how it goes.
    Regards.

  9. #9
    Join Date
    Jan 2013
    Beans
    8

    Re: Auto mounting network share using fstab

    I get the same thing as sudo mount -a

    Code:
    mount error(13): Permission denied
    Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

    I am looking at that page now
    HTML Code:
    http://linux.die.net/man/8/mount.cifs
    but honestly not sure what to look for.

  10. #10
    Join Date
    Apr 2008
    Location
    LOCATION=/dev/random
    Beans
    5,767
    Distro
    Ubuntu Development Release

    Re: Auto mounting network share using fstab

    Does your password have any special characters in it?

    If so then you may have to surround your password with quotes in the /root/.cifcredentials file...
    Code:
    username=rob
    password="my!$%password"
    Cheesemill

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •