Results 1 to 8 of 8

Thread: [LBP Canon Printer] the printer worked just for one time! Now it crashes!

Hybrid View

  1. #1
    Join Date
    Dec 2012

    Red face [LBP Canon Printer] Can you help me to solve this error?

    Hello everyone,
    I've installed Ubuntu 12.10 i386 (updated) on our school lab room computers. there's a canon printer there that is connected to teacher PC via USB.
    I installed it following
    the printer worked for just one time well and after a reboot I get this error (Plz click on the below image to enlarge it). The teacher is asking me for "printer"!
    Last edited by acronim; January 16th, 2013 at 12:49 PM.

  2. #2
    Join Date
    Dec 2012

    Re: [LBP Canon Printer] Can you help me to solve this error?

    If you know anything to solve this error, please let me to know!

    I'm a newbie and I still don't know how should I solve these kind of errors.

    kind regards.

  3. #3
    Join Date
    Dec 2012

    Exclamation May you do an autopsy on this error?

    Critical issue for me; please help.
    Any comments would be valuable.
    I would appreciate any comments.

  4. #4
    Join Date
    Dec 2012

    Re: May you do an autopsy on this error?

    I'm confused! do you need more details? If you need to know more, tell me and I'll gather them around the system!

  5. #5
    Join Date
    Apr 2005

    Re: [LBP Canon Printer] the printer worked just for one time! Now it crashes!

    this must all be very frustrating and disappointing for you; and perhaps very irritating too..

    I think we all struggle to know how to help you; I sense you may feel there is a large army of highly seasoned debuggers to sort stuff..not sure that is true.........

    ......for most of us, we plod along installing things and generally they work....

    I wonder if you have googled on the errors eg

    c3pldrv crashed with SIGSEGV
    .......most folks responses to the answers that emerge are: WHAT?

    1) I can only check you installed the common driver first and then the specific......

    I assume

    sudo dpkg -l | grep Canon
    gives you the correct answers; perhaps you copy and paste back what you get;

    2) what does
    captstatusui -P LBP%%%%
    give..I can't remember which LBP you have and this thread doesn't seem to detail it

    ........I have an LBP connected via a USB cable to a standalone computer running 32bit Ubuntu ........ I sense your school lab variant may be much more complicated........ maybe you help us by spelling out what it is ..

    I can only comment on what worked for me on my 32bit system:

    my favoured install is an amalgam of the Ubuntu capt page and sivella's advice:

    so from

    .........having installed the drivers ..........

    I like the command to register the printer:

    sudo /usr/sbin/lpadmin -p LBP%%%% -m CNCUPSLBP%%%%CAPTK.ppd -v ccp://localhost:59787 -E you don't need fifo directories........

    and then I like Sivella post #4 for the completeness

    of proceeding to

    Register the printer with ccpd daemon:

    then Start ccpd daemon:

    then Test install:

    ......then I did the Sivella tweaks to ensure it starts each time ..and it does ..........

  6. #6
    Join Date
    Jul 2005

    Re: [LBP Canon Printer] the printer worked just for one time! Now it crashes!

    I just setup a couple of Canon printers in 12.04 . The first printer was automatically detected and I used the default driver. It worked fine - once - and then was flaky. Even when I could get it to print, it was very slow - almost like I had set it to "super fine" mode. I know this printer prints much faster than this and that something was wrong.

    So I went back to the driver Canon published for 10.04. The Debian package did not work, but I was able to install it via the text installer, and now it works well. Second printer also worked well by installing the same way. I don't know the model Canon you have but you might look for a driver for it on Canon's Europe site and even if 12.10 isn't officially supported, as in my case you might be able to get the old driver to work.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts