Results 1 to 2 of 2

Thread: How do you stop login screen showing wallpaper?

Hybrid View

  1. #1
    Join Date
    Jan 2013
    Beans
    6

    Question How do you stop login screen showing wallpaper?

    I'm using Wallch to cycle through all my photo's and it works really well. However when i shutdown and come to login next, the login screen shows the last photo that was being shown.

    I don't want this to happen and the only post i could find has a dirty solution, i don't want to change the permissions for 1000's of photo's.

    I have also tried using scripts that run at logout and although this works, the scripts run after logout. I set the desktop back to original using the following commands.

    Code:
    gsettings set org.gnome.desktop.background picture-uri 'file:///usr/share/backgrounds/warty-final-ubuntu.png'
    gsettings set org.gnome.desktop.background picture-options zoom
    Next time i login my desktop is set back to the warty ubuntu wallpaper, however the login screen still shows the last picture that was on my wallpaper, so it must being set somewhere before logging out and it mustn't be being read from the gnome desktop settings. Does anyone know how to disable this or where the setting is likely to be stored so it edit it with my logout script?

  2. #2
    Join Date
    Jan 2013
    Beans
    6

    Talking A solution.

    Ok found the setting, though still had some trouble.

    Read a post that told me how do it. Though it didn't work for me.

    The post suggest to switch to the lightdm user using the following commands.

    Code:
    sudo -i
    xhost +SI:localuser:lightdm
    su lightdm -s /bin/bash
    Then change the setting with
    Code:
    gsettings set com.canonical.unity-greeter draw-user-backgrounds 'false'
    How ever this did not seem to work for me as if i
    Code:
    cat /usr/share/glib-2.0/schemas/com.canonical.unity-greeter.gschema.xml
    i still had
    Code:
        <key name="draw-user-backgrounds" type="b">
          <default>true</default>
          <summary>Whether to draw user backgrounds</summary>
        </key>
    in the configuration file.

    So i just hacked it using
    Code:
    sudo nano /usr/share/glib-2.0/schemas/com.canonical.unity-greeter.gschema.xml
    to look like
    Code:
        <key name="draw-user-backgrounds" type="b">
          <default>false</default>
          <summary>Whether to draw user backgrounds</summary>
        </key>
    This works and the problem is solved, though i would be interested in finding out why i couldn't change the setting using gsettings.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •