Page 2 of 5 FirstFirst 1234 ... LastLast
Results 11 to 20 of 46

Thread: New Install - Very slow at "Reading package lists..." in apt-get

  1. #11

    Re: New Install - Very slow at "Reading package lists..." in apt-get

    It appears that Linux or the motherboard is the problem. I just finished cloning the partition to a new drive (160 GB SATA 1 platter drive) and after repairing GRUB booted Linux. The apt-get update takes just as long as previously.

    What would cause this kind of behaviour?

  2. #12

    Re: New Install - Very slow at "Reading package lists..." in apt-get

    I followed the suggestion I found here:

    http://forum.parallels.com/showthread.php?t=263981

    But that did not help

    I am running out of ideas, any suggestions welcome (short of format and run windows)

  3. #13

    Re: New Install - Very slow at "Reading package lists..." in apt-get

    This is turning into a messy problem. I have tried read/write to other drives, and the same very slow performance happens.

    I am going to repartition my SSD and install windows. See if it suffers from the same performance woes.

  4. #14
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: New Install - Very slow at "Reading package lists..." in apt-get

    See the comments here about the setting you show as frozen. I do not think that is what your want. May be another BIOS setting.

    http://mackonsti.wordpress.com/2011/...e-ata-command/
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  5. #15

    Re: New Install - Very slow at "Reading package lists..." in apt-get

    Quote Originally Posted by oldfred View Post
    See the comments here about the setting you show as frozen. I do not think that is what your want. May be another BIOS setting.

    http://mackonsti.wordpress.com/2011/...e-ata-command/

    Cool suggestion, but it did not help. I tried the method of putting the computer to sleep and waking it up. The drive is no longer in a frozen state, but the speed has not changed.

    2nd Update: I installed windows and ran a drive speed test. Through any test I ran the drive seemed to run at a very good speed. Attached is the results of an actual test.
    Attached Images Attached Images

  6. #16

    Re: New Install - Very slow at "Reading package lists..." in apt-get

    Bump - Does anyone have this same motherboard (P75-D3)? I am very interested to find someone else who has this board and has success running linux.

  7. #17
    Join Date
    Mar 2007
    Location
    Tavistock, Devon
    Beans
    118
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: New Install - Very slow at "Reading package lists..." in apt-get

    I'm having this very same problem. Not just in ubuntu, but with linux mint too (which i guess is ubuntu)

    There's definitely something quirky going on here. I had a brand new SSD and it's slow as a tortoise....

    Ubuntu boots in seconds however and I love the silence, but for anything else, especially installing stuff, geez- put the kettle on we may be sometime!

    Would love to see a fix for this.

  8. #18

    Re: New Install - Very slow at "Reading package lists..." in apt-get

    Quote Originally Posted by daverich View Post
    I'm having this very same problem. Not just in ubuntu, but with linux mint too (which i guess is ubuntu)

    There's definitely something quirky going on here. I had a brand new SSD and it's slow as a tortoise....

    Ubuntu boots in seconds however and I love the silence, but for anything else, especially installing stuff, geez- put the kettle on we may be sometime!

    Would love to see a fix for this.
    Yikes. I have reached the point of deciding it is either the motherboard or the kernel. What motherboard is in your computer?

  9. #19
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: New Install - Very slow at "Reading package lists..." in apt-get

    What motherboard is it.

    It could be many BIOS setting that may not seem to apply.

    Some examples that others posted for older systems. Most will not apply but you can review list:
    Some issues on booting install:
    fixed the problem by adding rootdelay to grub.cfg this allows time for the usb drive to load.
    Though my drive was appearing in the bios and working for install it was actually "disabled"!
    BIOS settings need USB mouse & keyboard
    BIOS in not updated to latest revision
    BIOS not set to boot CD or USB first
    BIOS shows floppy or firewire and you do not have those
    changing newer BIOS SATA 6 Gbit/s from 6 Gbs to a SATA II - 3Gbs
    BIOS & disable "Boot Sector Virus Protection"
    Other BIOS settings - Security or locked down Boot sector, Bitlocker
    Old BIOS, new drive 137GB max boot size or very large / partition over 100GB
    https://help.ubuntu.com/community/BootPartition
    https://help.ubuntu.com/community/Cr...onAfterInstall
    NTFS partition needs chkdsk, gparted will not see drive if chkdsk flag set, flag is set on resize
    Raid meta data on drive - even if one drive (Vendor happend to set it on)
    Old gpt data on drive
    Disable Quickboot in BIOS
    turning off UDMA in the BIOS my problem has gone away.(old system & may make system slower)
    BIOS setting, Keyboard response in grub really slow
    Fast Boot setting prevents keyboard from working & other issues
    Bios not loading no key works - disconnected power for about 10-15 minutes and the bios reset itself.
    After update, It had reset to the BIOS defaults, setting the video to ONBOARD and switching off the dynamic video memory allocation (manually allocating 32Mb instead of leaving it as AUTO).
    The mode for the disc was set to AUTO. Changed it to LBA. Then it worked.
    Sometimes specific issues by motherboard like this:
    [Natty] Marvell 88SE9120 IDE-Part not working
    https://bugs.launchpad.net/ubuntu/+s...ux/+bug/777325
    External drive needed separate power supply
    Asus m4a87td core unlocker feature on usb3 was causing the problem
    Asus - Security> I / O interface Security> "New interface card" or so. SET IT TO LOCKED!!!
    In the Asus BIOS I selected Advanced Mode>Advanced>SATA Configuration.
    Changed IDE Mode to AHCI Mode
    Then,when the SATA3G_1 selection appears in the drive list below,select the Enabled option.
    set pci=nomsi or other boot paramter
    So to people with an Asrock Z77 Extreme4 motherboard: if you install Ubuntu, make sure the drives you are installing from and to are not connected to the Asmedia SATA ports!
    lib64 folder missing??
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  10. #20
    Join Date
    Sep 2006
    Beans
    68

    Re: New Install - Very slow at "Reading package lists..." in apt-get

    I also have this same problem regarding "Reading package lists:" all of the sudden taking a very long time. I also have a SSD but it has nothing to do with the SSD performance. It boots in seconds, sometimes I don't even see the boot screen. It's a dual boot and Win 7 runs through it's boot screen once every time. Exactly once, no longer no shorter (unless it has to do updates). So the SSD is fine. I only have slowness with software center and apt-get update when it comes time to read the package lists. It's 11.9 Mb of data, it can't take very long to read off of anything. Several minutes is crazy. My 11 year old machine did the same thing, like he said, in seconds instead of minutes. It was not like this when I installed. This is new. I do not get any errors. I've tried changing servers. I've removed all but the standard Ubuntu repos. I've cleaned and cleared and deleted lists, ran dpkg commands I found in other posts. I'd say I've done a couple hours worth of different things trying to fix it and nothing has made a bit of difference to apt-get update. I can actually get the Software Center to open now without having to stare at a grey screen for 10 minutes. I have no clue what actually fixed that because it was not my focus. I only noticed it when I opened software center and it actually worked. Before that, when run from command line, it would hang up at "softwarecenter.db.database - INFO - open() database: path=None use_axi=True use_agent=True". I don't know how I fixed one's ability to read the database and not the other's. I have run every command I can find to clear out old caches. As far as I can tell apt-get update package lists are contained in /var/lib/apt/lists only and don't come from anywhere else. I've deleted them and deleted them over and over again followed by different commands. No broken dependencies, no errors of any kind. Just extremely slow performing a relatively simple task.
    Thoughts?
    Last edited by Buggin; February 11th, 2013 at 04:55 AM. Reason: typo

Page 2 of 5 FirstFirst 1234 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •