Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: GRUB and blinking cursor after refit

  1. #1
    Join Date
    Dec 2008
    Beans
    11

    GRUB and blinking cursor after refit

    I've installed ubuntu ibex on my macbook aluminium and i've installed refit. I have two penguins and one apple.
    When I try to boot to ubuntu i just get GRUB and blinkin cursor
    I tried to reintall GRUB but and it all seems fine

    grub> root (hd0,2)
    grub> setup (hd0,2)
    Checking if "/boot/grub/stage1" exists... yes
    Checking if "/boot/grub/stage2" exists... yes
    Checking if "/boot/grub/e2fs_stage1_5" exists... yes
    Running "embed /boot/grub/e2fs_stage1_5 (hd0,2)"... failed (this is not fatal)
    Running "embed /boot/grub/e2fs_stage1_5 (hd0,2)"... failed (this is not fatal)
    Running "install /boot/grub/stage1 (hd0,2) /boot/grub/stage2 p /boot/grub/menu
    .lst "... succeeded
    Done.

    There is some kind of problem and i can't figure it out

  2. #2
    Join Date
    Aug 2005
    Location
    Huntsville, AL, USA
    Beans
    7,526
    Distro
    Ubuntu

    Re: GRUB and blinking cursor after refit

    Quote Originally Posted by zowey View Post
    I've installed ubuntu ibex on my macbook aluminium and i've installed refit. I have two penguins and one apple.
    When I try to boot to ubuntu i just get GRUB and blinkin cursor
    I tried to reintall GRUB but and it all seems fine

    grub> root (hd0,2)
    grub> setup (hd0,2)
    Checking if "/boot/grub/stage1" exists... yes
    Checking if "/boot/grub/stage2" exists... yes
    Checking if "/boot/grub/e2fs_stage1_5" exists... yes
    Running "embed /boot/grub/e2fs_stage1_5 (hd0,2)"... failed (this is not fatal)
    Running "embed /boot/grub/e2fs_stage1_5 (hd0,2)"... failed (this is not fatal)
    Running "install /boot/grub/stage1 (hd0,2) /boot/grub/stage2 p /boot/grub/menu
    .lst "... succeeded
    Done.

    There is some kind of problem and i can't figure it out
    do you get the same result using either tux?

  3. #3
    Join Date
    Dec 2008
    Beans
    11

    Re: GRUB and blinking cursor after refit

    yes, GRUB word and blinking cursor

  4. #4
    Join Date
    Aug 2005
    Location
    Huntsville, AL, USA
    Beans
    7,526
    Distro
    Ubuntu

    Re: GRUB and blinking cursor after refit

    Quote Originally Posted by zowey View Post
    yes, GRUB word and blinking cursor
    Is it a grub commandline, like this:
    grub>

    or it just says grub and that's it.

    Have you made sure the partitions are in sync with rEFIt?

  5. #5
    Join Date
    Dec 2008
    Beans
    11

    Re: GRUB and blinking cursor after refit

    it's not grub command line.. I can't type. and there is no '>' sign

  6. #6
    pxwpxw's Avatar
    pxwpxw is offline Chocolate Ubuntu Mocha Blend
    Join Date
    Apr 2006
    Beans
    Hidden!
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: GRUB and blinking cursor after refit

    Quote Originally Posted by zowey View Post
    it's not grub command line.. I can't type. and there is no '>' sign
    You must use the refit Partition Tool to sync the MBR partition table.
    And then if neither refit Tux icon works, do a restart using the Option key,
    try a couple of times.

  7. #7
    Join Date
    Dec 2008
    Beans
    11

    Re: GRUB and blinking cursor after refit

    i did sync.. when do i press option key?

  8. #8
    pxwpxw's Avatar
    pxwpxw is offline Chocolate Ubuntu Mocha Blend
    Join Date
    Apr 2006
    Beans
    Hidden!
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: GRUB and blinking cursor after refit

    Quote Originally Posted by zowey View Post
    i did sync.. when do i press option key?
    Hold Option key down as it restarts, until disk icons appear.
    You can either restart from refit, or using the power off button.

  9. #9
    Join Date
    Dec 2008
    Beans
    11

    Re: GRUB and blinking cursor after refit

    unfortunately that didn't help.
    I held option and I got two hard drive pictures... osX and Windows option, I selected windows drive and again it was GRUB and blinking cursor. I tried again and again two penguins, but with the same result

  10. #10
    pxwpxw's Avatar
    pxwpxw is offline Chocolate Ubuntu Mocha Blend
    Join Date
    Apr 2006
    Beans
    Hidden!
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: GRUB and blinking cursor after refit

    Quote Originally Posted by zowey View Post
    unfortunately that didn't help.
    I held option and I got two hard drive pictures... osX and Windows option, I selected windows drive and again it was GRUB and blinking cursor. I tried again and again two penguins, but with the same result
    Thats strange.
    There may be something wrong with the ubuntu install - but do not change it, just do these checks from MacOSX and post the result, perhaps we can see where the problem is.

    From Applications:Utilities:Terminal
    Code:
    diskutil list
    
    sudo hexdump -Cn512 /dev/disk0
    
    sudo hexdump -Cn512 /dev/disk0s3
    And from Applications:Utilities: Partition Inspector
    Get a Partition report and post it.

Page 1 of 3 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •