Results 1 to 7 of 7

Thread: no sound through hdmi on tv, have tried following other fixes

  1. #1
    Join Date
    Apr 2010
    Beans
    156

    [SOLVED] no sound through hdmi on tv, have tried following other fixes

    hdmi picture on my tv works fine but sound does not, hdmi doesn't come up on the sound or pulseaudio menu,

    sudo aplay -l

    gives

    Code:
    **** List of PLAYBACK Hardware Devices ****card 0: PCH [HDA Intel PCH], device 0: ALC269VB Analog [ALC269VB Analog]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    I have tried

    sudo alsamixer -c 0

    and then unmuted S/PDIF but nothing changes (also whenever I start a new session S/PDIF is once again muted)

    also tried running

    speaker-test -c 2 -r 48000 -D hw:0,3

    but again nothing happened. I have intel HD graphics 4000 and an i5 processor.

    Thank you in advance for any help
    Last edited by slgtheindividual; May 6th, 2013 at 03:34 PM.

  2. #2
    Join Date
    Apr 2010
    Beans
    156

    Re: no sound through hdmi on tv, have tried following other fixes

    Any help would be greatly appreciated, I'm still having this problem, if you need any more information I will happily provide it, thank you.

  3. #3
    Join Date
    Nov 2009
    Location
    Warsaw, Poland
    Beans
    79
    Distro
    Xubuntu 13.04 Raring Ringtail

    Re: no sound through hdmi on tv, have tried following other fixes

    open movie, play it

    pavucontrol
    First tab:
    select default out for your player (something with HDMI).

    Third tab:
    set up volume

    Last tab:
    check if there is everything ok

    Regards!

    edit. this topic might be very useful if it is a case: http://askubuntu.com/questions/69820...across-reboots
    Last edited by e-San; April 16th, 2013 at 09:31 AM.

  4. #4
    Join Date
    Apr 2010
    Beans
    156

    Re: no sound through hdmi on tv, have tried following other fixes

    nothing with HDMI appears anywhere on any tab in pulse audio, even when playing video, all that appears are speakers (which alters the laptop speakers) and headphones, no hdmi or tv speakers.

  5. #5
    Join Date
    Apr 2010
    Beans
    156

    Re: no sound through hdmi on tv, have tried following other fixes

    I have since upgraded to 13.04 raring ringtail and I'm still having this problem, any help would be greatly appreciated

  6. #6
    Join Date
    Apr 2010
    Beans
    156

    Re: no sound through hdmi on tv, have tried following other fixes

    please? anybody?

  7. #7
    Join Date
    Apr 2010
    Beans
    156

    Re: no sound through hdmi on tv, have tried following other fixes

    the following solved my problem http://ubuntuforums.org/showthread.php?t=2141858

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •