Hello, running 12.10 amd64 on a ASUS M5A88-M Motherboard with a built in RS880 [Radeon HD 4250] graphics card.

I've got a nice 5.1 surround sound AV receiver which only accepts HDMI, so I'm not interested in any other way to play audio other than HDMI. I've built a home theatre PC, so having the graphics on the MoBo cuts down on space, power and fan noise. I really can't fit a graphics card into the tiny, quite little box I've built.

Stereo sound and display work great in ubuntu, but I cannot find anyway to get 5.1 audio playback of DVDs. Ubuntu sound settings only shows stereo configuration. There doesn't seem to be any option to change this to 5.1 surround. I have also tried pavucontrol, which also will only offer me stereo.

The hardware will play 5.1 surround sound in Windows 8 Pro + Media center. However, Win8 with all the latest drivers will also only show 2-Channel stereo in the sound settings and will not play 5.1 surround for 5.1 encoded movie files. I can only get it to work properly when playing a DVD in Win8 Media center.

cat /proc/asound/version 
Advanced Linux Sound Architecture Driver Version 1.0.25.
pacmd list-sinks
Welcome to PulseAudio! Use "help" for usage information.
>>> 2 sink(s) available.
  * index: 0
	name: <alsa_output.pci-0000_01_05.1.hdmi-stereo>
	driver: <module-alsa-card.c>
	suspend cause: IDLE 
	priority: 9050
	volume: 0: 100% 1: 100%
	        0: 0.00 dB 1: 0.00 dB
	        balance 0.00
	base volume: 100%
	             0.00 dB
	volume steps: 65537
	muted: no
	current latency: 0.00 ms
	max request: 0 KiB
	max rewind: 0 KiB
	monitor source: 0
	sample spec: s16le 2ch 48000Hz
	channel map: front-left,front-right
	used by: 0
	linked by: 0
	configured latency: 0.00 ms; range is 0.50 .. 341.33 ms
	card: 0 <alsa_card.pci-0000_01_05.1>
	module: 4
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix"
		alsa.name = "HDMI 0"
		alsa.id = "HDMI 0"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "3"
		alsa.card = "1"
		alsa.card_name = "HDA ATI HDMI"
		alsa.long_card_name = "HDA ATI HDMI at 0xfeae8000 irq 19"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:01:05.1"
		sysfs.path = "/devices/pci0000:00/0000:00:01.0/0000:01:05.1/sound/card1"
		device.bus = "pci"
		device.vendor.id = "1002"
		device.vendor.name = "Advanced Micro Devices [AMD] nee ATI"
		device.product.name = "RS880 HDMI Audio [Radeon HD 4200 Series]"
		device.string = "hdmi:1"
		device.buffering.buffer_size = "65536"
		device.buffering.fragment_size = "32768"
		device.access_mode = "mmap+timer"
		device.profile.name = "hdmi-stereo"
		device.profile.description = "Digital Stereo (HDMI)"
		device.description = "RS880 HDMI Audio [Radeon HD 4200 Series] Digital Stereo (HDMI)"
		alsa.mixer_name = "ATI RS690/780 HDMI"
		alsa.components = "HDA:1002791a,00791a00,00100000"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
		hdmi-output-0: HDMI / DisplayPort (priority 5900, available: unknown)
	active port: <hdmi-output-0>
    index: 1
// index 1 is for the audio jacks so unimportant here
Does anyone have any hints on how I can get 5.1 audio working over this HDMI connection in ubuntu? The damn annoying thing is that I know it works in Windows 8 Media Center, which I really don't want to have to use.