Results 1 to 3 of 3

Thread: ASUS X55C and Ubuntu 12.04 or 12.10

  1. #1
    Join Date
    Jun 2009
    Beans
    10

    Question ASUS X55C and Ubuntu 12.04 or 12.10

    Hello.

    I've bought new ASUS X55C laptop (LINK), with no OS preinstaled (only DOS). I've installed Win7, since I got in box cd with Win7 drivers, and everything works fine.

    Now, I want to install Ubuntu 12.04 (dualboot), and I tried it (from CD, without installation). I noticed that my network isn't worknig (wifi, LAN), keyboard commands doesn't work fine, etc...

    I googled for ubuntu drivers, but all I've founded is this LINK. My question is this:

    Can anyone tell me is Ubuntu going to work fine (network, keyboard,...) when I install it, although it doesn't work on "Try Ubuntu" mode? I wouldn't like to install OS that wouldn't work.

    Sorry for bad english, and thanks in advance.

  2. #2
    Join Date
    Jan 2009
    Location
    United States
    Beans
    184
    Distro
    Lubuntu 13.04 Raring Ringtail

    Re: ASUS X55C and Ubuntu 12.04 or 12.10

    md96360,

    my advice would be to try dip your foot in the pool by dual-booting. I would also make sure your connected through ethernet before installing and that will save hassle. When I installed on my Asus production machine, it was connected through ethernet and all the drivers worked perfectly.
    Asus G74SX ROG Intel® Core™ i7 2630QM Processor 12GB Memory NVIDIA® GeForce® GTX 560M with 3GB GDDR5 VRAM 1tb Western Digital Hard Drive, 500gb Western Digital Hard Drive, 1.5 tb Western Digital Hard Drive, 2 2TB Western Digital Hard Drives.

  3. #3
    Join Date
    Dec 2013
    Beans
    1

    Re: ASUS X55C and Ubuntu 12.04 or 12.10

    This is my first post but I have been using Ubuntu for about three years. I wish to share my experience with installing Ubunti 12.04 LTS on the ASUS X55c. You can see my original post on a Amazon review (mike321) here:http://www.amazon.com/ASUS-X55C-DS31...owViewpoints=0

    __________________________________________________ ___________________________

    I finally installed Linux (Ubuntu 12.04 LTS) on the X55C. I am very satisfied with the laptops usability now. It goes out of hibernation relatively quickly and it connects to the internet with no issues. The control pad also works well. However, this was no easy task, since this model is equipped with secure boot UEFI. To install Ubuntu, follow these steps:

    1. Shut down. Take battery out. Start. Press <F2>. You're in BIOS.Go to "Security" tab. "Disable" Secure Boot Control. Now go to "Boot" tab. "Disable" Fast Boot. "Enable" Launch CSM. Now appears submenu. "Enable" Launch PXe Oprom. Now you can select in Boot Option Properties "P2 ...DVDROM" to boot first in sequence.

    2.Burn yourself a Ubuntu 12.04 (or equivalent) image installation DVD. Boot with this DVD.

    3. You now see "Install" Ubuntu prompt. Choose "Install" and follow instructions. At "Installation Type," choose "Something Else." I had to partition the disk myself for this to work. SO you need around (?) 5 MB for "Reserved Bios Area"- the other stuff is your choice- I got this up and running with /root 3 GB, / 20 gb, / home 20 gb, swap 4 gb. Now install

    4. When system restarts, you will see a screen saying "no connection to drive." No worries. Boot from start dvd. This time "Try Ubuntu"..Now install Boot Repair. This is a program you install in the "Try Ubuntu" area. Follow online documentation. Shut down.

    5. GO into Bios. Select "Ubuntu" as first boot option. For some reason "Atheros Boot Agent" was installed before I used Boot Repair program. You can still use W8 in Grub by selecting "Windows UEFI" option

    ________________________

    Good Luck!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •