Results 1 to 2 of 2

Thread: Howto create .deb packages for the latest mono version ?

  1. #1
    Join Date
    Feb 2008
    Location
    readlink("/proc/self/exe"
    Beans
    1,120
    Distro
    Ubuntu Development Release

    Howto create .deb packages for the latest mono version ?

    Question:

    Mono 3.0 is out, but I found no ppa from where I could install it.

    There is this one:
    https://launchpad.net/~directhex/+ppa-packages

    but it's mono 2.10.8.1-5.

    I'm playing with ASP.NET MVC4, which is why I need the 3.0 release.

    Now I can compile & install mono 3.0 myself.
    How I do it, I tutorialized here:
    http://ubuntuforums.org/showthread.php?t=1591370

    My problem now is, for every new ubuntu installation I have/want to make (server, laptop, desktop, renewed installation when HD breakes) I need to go through this lengthy procedure again.

    So I want to compile it once, and then upload it to a PPA, so that I (and everybody else) don't need to install it from source again.

    Now the question:
    The entire build process needs configure run with options, post-configure makefile fixes, post-configure sourcecode fixes, etc.

    Is there an easy way I can create .deb packages from the already compiled files ?

    So that in the installation script, I only need to write several times:
    Code:
    cd package_directory_1/
    make install
    cd package_directory_2/
    make install
    cd package_directory_3/
    make install
    etc.

    ?


    Edit:
    Double posted due to timeout bug.
    Please delete.
    Last edited by WitchCraft; January 11th, 2013 at 02:27 PM. Reason: can't delete
    In a world without walls and fences, who needs Windows and Gates?
    Linux is like a wigwam.... no Gates, no Windows but Apache inside!
    http://www.debianadmin.com
    apt-get install libstdc++6-4.3-doc

  2. #2
    Join Date
    Oct 2006
    Location
    Ayrshire.
    Beans
    46,806
    Distro
    Ubuntu Development Release

    Re: Howto create .deb packages for the latest mono version ?

    Thread closed.

    Duplicate here : http://ubuntuforums.org/showthread.php?t=2103730

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •