Results 1 to 3 of 3

Thread: Sound works only on internal speakers, not on external

  1. #1
    Join Date
    Nov 2005
    Location
    Philippines
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Sound works only on internal speakers, not on external

    Need help.

    Before, I watch movies with my laptop. Watch youtube videos via firefox with my laptop. No problem on sound, with internal speakers.

    Today, I just hook my external speakers and found out that both movies doesn't produce sound on external speakers. Not even on my headphone.

    Sound only works on internal speakers but not on external speakers or headphone.

    What else should I install to fix this one?

    kenweill@ASUSK55VD:~$ aplay -l
    **** List of PLAYBACK Hardware Devices ****
    card 0: PCH [HDA Intel PCH], device 0: ALC270 Analog [ALC270 Analog]
    Subdevices: 1/1
    Subdevice #0: subdevice #0
    card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
    Subdevices: 1/1
    Subdevice #0: subdevice #0

  2. #2
    Join Date
    Nov 2005
    Location
    Philippines
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Sound works only on internal speakers, not on external

    I can't edit this post and so I'll just reply on my own thread.

    Got this fixed with
    Code:
    echo "options snd-hda-intel model=asus" | sudo tee -a /etc/modprobe.d/alsa-base.conf
    then reboot system.

    Found the solution from http://ubuntuforums.org/showpost.php...13&postcount=3

  3. #3
    Join Date
    Jun 2007
    Beans
    11,620

    Re: Sound works only on internal speakers, not on external

    That's odd, since 'asus' is not a valid model for that codec.

    Code:
    ALC269/270/275/276/280/282
    ======
      laptop-amic	Laptops with analog-mic input
      laptop-dmic	Laptops with digital-mic input
      alc269-dmic	Enable ALC269(VA) digital mic workaround
      alc271-dmic	Enable ALC271X digital mic workaround
      inv-dmic	Inverted internal mic workaround
      lenovo-dock   Enables docking station I/O for some Lenovos
    http://git.alsa-project.org/?p=alsa-...ls.txt;hb=HEAD

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •